[Con] Save doesn't work

I usually save once a day but somewhere between 3 and 14 days(usually) it just stops saving. sometimes I can work around this by exiting and loading but mostly this works only for 1 extra day.

What info can I give you to help solve the problem?

Firstly, welcome aboard!

as well as happy π day tomorrow sorry, something about 3 and 14 reminded me of 3.14, I’ll get back on topic.
First and most important, what version are you playing? Humble Bundle or Steam? Stable (r206) or latest (r210)? 32-bit or 64-bit?

Your system specs would probably also help, but I’m not sure about what info would be needed for that.

Yea the same think keeps happening to me, I have a good sized games going with a number of save files and then once it gets to around day 15 when I try to save a new file or overwrite a previous save it just deletes them. Then eventually my game crashes shortly after, meaning I lose everything i’d been working the past few hours for. #SadFace frowning

I’m play on steam and in alpha 8 if that’s any similar.

OK I’m gonna ask for someone who is having this issue (Cuz thankfully I haven’t hit it yet) to try a experiment!
I have steam build BTW…

While playing the game and when you hit this issue try this -
go into Steam/Steam apps/Common/Stonehearth/saved_games/ and delete the Funky# folder inside the saved_game folder.

Remember! try it while your still in the game. I tried it just to see if it would freak out but it didn’t (for me at least) and was still able to make a new save and reload it and play away.

It probably won’t fix anything (again I haven’t hit this issue, Yet!) but what do you have to lose right! and if it works Bonus! and pls spread the word if it does. If it doesn’t, well I tried to find a work around for ya :frowning:

No coding guru am I :slight_smile:

1 Like

We have two threads. One for savegames that get deleted when trying to save/overwrite, and one for saving not working (the game doesn’t create new saves, as if the button was broken).

Normally one bug leads to the other. If @hellthrive could notice if his savegames get deleted, this thread might get merged with the former “Saved game dissapeared” report.

Despite this, sometimes the saves just get corrupt and it’s not this bug, because this bug is usually related to memory issues. So there are people finding workarounds as @Soul, which might or might not work, but definitely worth trying so you can see how far you can go in the game before running into memory or performance problems.

I saw the other thread but i haven’t seen any of my saves disappear(if I notice the new save doesn’t work and I try to save over another save it corrupts that save(when the game doesn’t crash first)). While I’m certainly trying the workarounds to get a bit further I want to help them solve it for good.

for some more info my system:AMD Phenom II X4 955 3.20 Ghz processor with 6 GB ram.
I play on steam
as for the version I run the 32 bit because my system(yeah my entire pc) crashes the moment I dare to start the 64 bit version(posted about this in the relevant thread) so I don’t know if my save game problem will reoccur in the 64 bit version

I tried playing some more after it fails to save but my game crashes between 1 and 4 days after it happens.

edit 16th march: just tried the latest version stopped saving on day 4 and @Soul couldn’t find the funky folder

1 Like

So it ate (the game did) what was inside the save folder? Man that sux srry to hear that… At least this info might give them some sort of inclination to what/were it might be occurring (hopefully? :slight_smile: ). Ty for trying to give it a shot…

Edit* Man was used purely in the generic way…(Not going to get hit with that again :P)

Edit #2*

Just to be sure (not questioning your puter skills) - Inside your saves folder should be another folder labeled with a series of #'s ie: 142637271536 <- most likely differing #'s Is that what is missing? or your Saved_games folder is missing?

1 Like

Well, just use “Human”. glances at @Newf Uh… use life-form. That couldn’t offend anyone, right? glances at a spambot Um…

1 Like

The word you are looking for is ‘being’

Just for the record I’m male but even if I wasn’t I would assume that I would have enough sense to see you using an expression that doesn’t reflects on what I am.

I’m in IT I better hope to have some computer skills :smile:. No I found the folder just fine but I didn’t find any folder other than the numbered ones and the tmp_save.

What I did notice was that all the saves I currently had contained 4 files in the folder:

  1. client_state.bin
  2. metadata.json
  3. screenshot.png
  4. server_state.bin

I also found all my deleted saves folders still present. Those folders only contained the 4th item.

ps. just saw that I didn’t answer all the questions from @coasterspaul I have never installed the humble bundle version. I run the latest but it also happened when I tried the stable version.

And I hadn’t even noticed the thing with pi day :smile:

Got to love it when a program actively eats itself :smile: Hopefully they can narrow it down and staple <- because tape isn’t working) it back together again.

If you’ve only got the one .bin file, then there’s no hope of recovering a save. If you have both .bin files, you can copy those and the other two (.json/.png) from another folder and paste them into a more recent game save folder and load that again. This is usually how I keep a game going when I’ve ‘saved new’ and it doesn’t show a new screenshot/game save (at that point I know the save failed).

Clear as mud? :stuck_out_tongue:

@NonBritGit these saves were old ones that I deleted ingame but it left about 250MB of junk that I had to look for to be able to remove it. But even If i tried they would have shown incompatible versions

I just tried to keep my game going by restarting the game but I only got 1 extra day and the following attemps never gave me the possibility to save my 5th day

Do you always save as ‘new’? Overwriting has been troublesome. When you save as ‘new’ and you don’t see the snapshot update with the new game save, that’s when you grab and copy the files I mentioned.

1 Like

I always save as new because it gives me another point to get back to when I decide that I made a mistake in my developing town. I only overwrite when I save multiple times a day which I only do when there happens insanely much in my town.

When I do the new save and no save shows up in game it also doesn’t show up in the savegame folder

Do you have a tmp_save directory next to the save directories? That’s where the aborted saves usually go. And usually just the two .bin files.

Just tried saving on the latest build, downloaded today, did not work! I played the game earlier saved twice on 2 separate saves. Closed the game down to do some real world stuff, when I Continued from the main menu would not save or even from a reload. Found a tmp_save file in the save folder though but nothing in game just the 2 saves from earlier.

1 Like

This is happening to me too. It usually begins once I start a large mining operation, though that could just be coincidence. I also start having large buildings around that time. Very frustrating, can’t play the game as it is happening to me every time.

also just tested the latest build I only could save more than the first day(which was saved as second day of deepmun for some reason)

@soth I don’t know if the big operations are a must but I usually make my storage areas in the rocks(also gives me a nice supply of ores and rock) which means I usually dig at least 7 caves of 20x20.

also the game crashed on day 2

Played again and saving ok, 6 days. Not sure what caused the issue.