[Res] Stonehearth is completely unable to launch (reset network adapter)

Hey everyone! I have been away from the internet for a while and I had a wish to get back to playing with Stonehearth again.

But, in my hiatus, one of the updates has completely made it impossible to play! I cant even get a error code or anything, which is why I cant do this in the normal format. My steam goes into “In game Stonehearth” for 3-4 seconds, then back to online. No game window or anything.

I have messed with the stonehearth.json file, as people recommended, I have uninstalled the game and deleted the game folder with no avail.

Hope I can get this fixed soon!


Are you launching from inside steam or from a desktop shortcut?

I have tried both the shortcut and steam, neither seem to work, sadly.

Because you tried reinstalling the game, I’m going to assume you have no old mods installed which could mess things up. Because the game worked in the past, it seems unlikely that we can blame the graphics card drivers or operating system version (unless you’ve changed either since then).

Having said that, have you checked this topic? With the early access steam release, a lot of anti-malware and privacy programs were found that interfere with the chrome browser in stonehearth.

If there is no answer there, try uploading your stonehearth.log here as there may be hints in there.


Go to the steam library, right click on stonehearth->properties->local files and then click on verify integrity of game cache. That fixed it for me one time!


@Gorkiork Sadly, I have also tried this :confused:

@Tuhalu I have tried everything on that list, with no results. However, if this in fact the stonehearth.log file you were asking for, I can give this to you:

stonehearth.log (2.1 KB)

Thanks for the help!


1 Like

Have you tried deleting stonehearth and doing a fresh install? You’ll need to manually delete the folder from steam though. Easiest way is to ask steam to delete local content and then in properties, browse local files and delete the stonehearth folder from steam/common.

It has helped me a few times when I get game breaking bugs

In your stonehearth.log you have a pretty critical clue:

core.system | Could not find an open port to host Stonehearth!: open: The requested service provider could not be loaded or initialized

Stonehearth is built from the ground up as a multiplayer game (although they haven’t added any multiplayer modes yet). This means that it has a client and a server, even when you’re just playing single player. For communication with the client, locally or across a network, a server needs to have an open port. Your computer is denying that somehow.

I think you need to take a close look at anything that might be blocking ports for Stonehearth. A firewall is the obvious suspect, but it may not be the only one.

I checked my Firewall settings, and Stonehearth was an exception in the settings. I even turned it off (the firewall that is) and it still didn’t launch. Is there something else that can block ports?

I’m not aware of anything, although there probably are. Maybe now is a good time to ask @Albert (of Radiant) if he has any ideas.

I was reading another post earlier (by @albert) about a problem similar to this. It turned out to be bloatware (from Lavasoft to be specific) that had been installed alongside another program. Maybe check your “programs and features” under windows settings and see if something smuggled itself in.

@MartyrSpirit - My magic decoder ring tells me it’s Norton 360.

1 Like

@Albert Nope, I don’t use Norton, and I have disabled my firewall multiple times, even though it is an exception anyway

@Boulderboy That wasnt it either, I don’t seem to have any bloatware of any kind, nor malware according to both Microsoft Security Essentials OR Malwarebytes

This is getting annoying to no end :smiley:


1 Like

Feces. Well, that exhausts my debugging skills. This is usually the point where I threaten to dump a coffee in my computer if it doesn’t behave.

People far smarter than I shall have to help :frowning: If I notice anything while I’m surfing the world wide interwebs or the forums I’ll make sure to link it here. Nothing more frustrating than a mystery bug keeping you out of a great game

@MartyrSpirit - Hmm. Ok, time to throw out that ‘magic’ decoder ring.

Have you tried running stonehearth as administrator?

Also, what version of Windows are you running?


  1. Yes, I have tried running it as admin.

  2. Windows 7 Home

Also, even though this may not be relevant, I also have issues running things like Minecraft and Unturned. Even though games such as Dirty Bomb or CS:GO run fine. In addition, when I checked my firewall to add a rule? It gave me an error saying MMC encountered an error with the snap-in. I have tried to fix this issue with no avail.

Do you have Service Pack 1 for it?

This smells like lmhost or netsh to me - tied to localhost maybe? I don’t think it’s a SH issue due to having issues with minecraft too.

@MartyrSpirit - As a SWAG

You can reset your network adapter using the following from an administrative command prompt.

netsh advfirewall reset

netsh branchcache reset

netsh int ip reset c:\resetlog.txt

netsh winsock reset

After resetting your computer, I expect one of the following to have happened:

Absolutely nothing,
Problem is fixed,
Your computer blows up.



THANK YOU! bows deeply You have fixed it oh most froggy one. May your skin never be dry!

Thank you also to everyone else, @Boulderboy , @Tuhalu, @Gorkiork and @Albert for your help!

A very happy and excited Derek


/Does the nailed it dance