Stonehearth will not start


Stonehearth wont start. No errors shown.


NO logs to upload.


NO crash log to upload.

Latest stable version. No mods.

Windows 10, GTX 980, External monitor.

I have tried to launch in window mode.
I have tried the three netsh commands listed.
I don’t have lava softs stuff that you mentioned.
I tried deleting local folders, then uninstalling the game. Reinstalled with same result. I am guessing this is why there are no logs in the Stonehearth folder. Since the game does not start how can there be any logs created?

I’ve been playing Stonehearth trouble free for 2 years? or so. A long time! What changed?

Thank you for any help you can provide.


Two questions:

a) Have you installed any new programs to your PC (or downloads)
b) Check that your anti-virus is not blocking it (especially if not using steam)

After you answer I can help more, had this problem a while back but I need more details

Hi LordGovernorGeneral,

Thank you much for your offer of help!

  1. I can’t think of anything new other than updates to steam, graphics, anti-virus and OS.
  2. I am using Steam and I have had the same anti-virus for a while now (Avast). No previous problems.

I tried disabling AV and running SH with no success.

1 Like

Mhmm, did you try verifying file integrity?

Go to steam, library, right click on Stonehearth,click properties, click local files and then click verify file integrity

I did initially, but did not mention it due to doing a full reinstall.

I just did it again. Stated 100% integrity.

Could there be something running in Chrome that I am just not aware of? …not sure what to look for. My daughter does use this machine (rarely) but perhaps she clicked something to allow a chrome extension or something?

I assume you are launching the game from within steam. Try making a short cut (right click on game and click create desktop shortcut) and then try running that as administrator.

Alternatively if that does not work, try seeing through the properties of the shortcut what permissions it has. Maybe Avast is being annoying.

Done, with no luck.

I went to shortcut properties, clicked the security tab and it shows all system permissions allowed except for the box labeled “special permissions”.

I’m racking my brain trying to think of anything new on my system since SH last worked. Has there been any history of Java causing problems. I’m not sure if I installed the latest version before or after SH stopped working. I was trying to run some line quality tests and needed java to do it.

Make sure you are running the official version, not the beta (have opt of betas turned off)

Something that may cause it is some sort of virus. I am not 100% sure if anything of use would come out of this but;
You can try, assuming your computer does periodic backups but if you do, try to do the following (instructions are from the Microsoft page, but I believe it works more or less the same on all systems.)


Right-click the Start button, then select Control Panel > System and Maintenance > Backup and Restore.
Do one of the following:
To restore your files, choose Restore my files.
To restore the files of all users, choose Restore all users’ files.
Do one of the following:
To look through the contents of the backup, select Browse for files or Browse for folders. When you’re browsing for folders, you won’t be able to see the individual files in a folder. To view individual files, use the Browse for files option.
To search the contents of the backup, select Search, type all or part of a file name, and then select Search.
If you’re searching for files or folders associated with a specific user account, you can improve search results by typing the location of the file or folder in the Search for box. For example, to search for all JPG files that were backed up, type JPG in the Search for box. To only search for JPG files associated with the user Bill, type C:\Users\Bill\JPG in the Search for box."

(Copied wrong thing at first - this is the correct version)

(Starting a new reply to avoid confusion.)

Not sure if it will be very helpful, but you may find an old version of the game which worked and you can work from there.

You can opt to flag this for needing immediate support if you want - I don’t know how to do it but someone had said its possible a few days ago on a thread somewhere but I cant find it]

Hope this last solution works, as I have no remaining things that I know of to help. What you can do, so that Staff helps is that if you upload you game files even if they’re empty such as the log folder, crash folder, save folder and etc, they may specify what something, but for now that may help. They could take a more learned look at them for you, I myself am simply a humble gamer, with know-how gained through trial and error and experience, not a Staff member or technician.

Sadly, I don’t have a previous back-up to look for an older version.

I appreciate your time in trying to help.

I’m grasping at straws, but I went into windows event viewer to look at the errors posted regarding SH.

Here is what was posted:

  • System

    • Provider

    [ Name] Application Error

    • EventID 1000

    [ Qualifiers] 0

    Level 2

    Task 100

    Keywords 0x80000000000000

    • TimeCreated

    [ SystemTime] 2017-04-29T19:15:06.708968400Z

    EventRecordID 18009

    Channel Application

    Computer KRE-PC


  • EventData

    C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\x64\Stonehearth.exe

It’s all greek to me, but I thought someone more learned might find something useful.

You are most welcome friend,

Staff will surely find the info you just posted very useful - hope you’re problem gets solved asap! :slight_smile:

I looked again in the local files and saw this:
stonehearth.txt (1.6 KB)

I think this is the general “log” they want?

Still no crash report file anywhere to be seen.

It may just be it, not so sure. Staff will be able to use it surely.

Let me hail in the ‘Engineer’

“Kirk to Scotty, come in @jomaxro

Sorry, to call you like this, jomaxro, but this guy really needs help, not sure if I did the right thing in getting your attention like this tho (sorry)!

No need to apologize, that’s what we’re here for.

@Kenton_Ethridge, I’m out with family at the moment and away from a PC. There’s quite a bit of conversation here, so I don’t want to give suggestions until I can read the full topic and review your log. Should be able to respond in a few hours. If any other @moderators are online, they may be able to assist sooner.

1 Like

No hurry. Quality time with the family is priority. I work tomorrow and
Monday so I may not be able to do anything but answer some questions until
Tuesday. Thank you for your help!

1 Like

Hmm…couple of questions:

  1. What was the last version of Stonehearth that worked?
  2. You mentioned that you tried deleting local folders and then uninstalling the game. You navigated to .../steam/steamapps/common and deleted the entire Stonehearth folder before uninstalling in steam, right?
  3. What exactly happens when you launch the game? Absolutely nothing? The log you shared (which is correct) is incredibly short and thus doesn’t provide any useful details, unfortunately.

As per what @jomaxro said, in order to see is anything at all occurs from between clicking play, till the next few minutes, start task manager (ctrl+alt+delete) and from it observe both what programs pop up (Stonehearth may for some time appear) and also observe your ram usage. The ram should change a significant amount, more than when the PC idles so you should notice something there.

Good morning jomaxro and LGG,

  1. I wish that I could say for sure. I first experienced this problem early last week. Prior to that it had been perhaps a week (maybe two?) since I was able to play the game. Previously I had the game set to allow unstable updates. So, I’d guess what ever unstable version was in play three weeks ago?

  2. Yes, that is correct. I did not attempt to save and replace my save files as I thought they may be corrupt.

  3. When run, the application flickers on and off the bottom task bar(~1sec). It does the same in task manager. I “think” I see a black window perhaps 3"high and 4"long flicker in and out on the desk top. …but happens so fast, it seems like my imagination. haha

  1. Ok, thanks.
  2. Save files aren’t “touched” until you explicitly try and load them, so even if they were corrupted (unlikely), they wouldn’t cause the game to fail upon initial load.
  3. That sure sounds like something is trying to inject itself into Chrome. Do you have an antivirus or firewall installed?

I have Avast and windows firewall active. Both were active prior to problems, but when I did a third delete/re-install yesterday to make sure I did it correctly, Avast threw out a threat found/blocked message to which I clicked the ignore option.