Crash on startup, please help (plugged webcam doesn't like the game?)


immediate crash to desktop, no mods, deleted the entire steam stonehearth folder and re downloaded.

stonehearth.log (3.0 KB)

doesnt generate a crash.dmp

Versions and Mods:
latest unstable, no mods, deleted everything.

System Information:
win 7, external monitor, 1060 8gb, intel 2500k, 8gb ram


[Any additional useful information]
it all started yesterday after meddling with my mod( i thought that the settings i made in my mod (fiddling with the worker crafting UI, ask max he saw the thread) was the culprit. but after turning it off in the user config (still crash) removing the mods from my steam uploads folder( still crash) and removing the user settings and verrifying integrity of cash (still crash, oddly enough steam doesnt say missing file, wtf)
i just gave up and nuked the entire folder and verrified> still a crash. all it generates is
user_settings.txt (193 Bytes)
(but ni json form) and its driving my bonkers. whatever i try: it keeps exploded and unplayable, even in default form :confused:

on a more recent try the log looks slightly different
stonehearth.log (2.6 KB)

i can only think about uninstalling from control panel and then reinstall :thinking:

Hard to tell from the logs, but try unsubscribing from all mods rather than just deleting them. Otherwise it may try to reinstall them.

wasnt subscribed to any, just removed my own from the steam uploads folder (because you dont subscribe to those, but the game might trry loading them-even if disabled)

Not sure that it will help but try to install/reinstall 2013/2015 c++ redistributable

1 Like

just tried this, now it says something new!
seemingly, stonehearth ran out of memeory?
edit: also tried as administrator, stil explodes.

tried installing latest graphical drivers, also did not solve it.
any more “why are you exploding?” things i can try?

You can try manually saving a dump after it crashes. While the program is in the state shown in your screenshot, go to the Task Manager, right click on the Stonehearth process and select “Create dump file”, then zip it up (it’s gonna be huge) and upload it somewhere where I can take a look at it.

1 Like

well you werent lying about it being ruddy massive… 600 MB :’) please hold, finding somewhere i can dump it

@max99x Stonehearth.DMP

Downloading, but it’s taking a while. Might be faster if you compress it into a ZIP or RAR. Dumps tend to compress really well.

Ah, was wondering about that but you didn’t say anything so I assumed it had to be uncompressed, I’ll see if I can make it smaller

:stuck_out_tongue: Besides, this sort of compression is lossless, so it wouldn’t ever have to be uncompressed.

1 Like

-facepalms at missing that step-
rarred it, now its 1/6th the size, dropboxing it atm…

now, smaller, and with less stupidity:

Hmm, it isn’t obvious what’s causing it, but I did notice that the dump includes an AVG antivirus DLL, which could be messing with things. See if the game runs with that disabled.

Also, if all else fails, try adding "force_32_bit" : true to your user settings.

1 Like

neither turning off AVG, or forcing 32 bit worked :confused:
could the registry fuck itsself over somehow? could that be it?

well ive tried telling steam to uninstall, running CC cleaner, and installing without toggling the latest version on and just taking the stable version, still crash. at this point im kind of losing hope of stonehearth working again >.<

tried this for good measure, no jazz.

This is unlikely to work, but another thing you could try is changing the compatibility mode of Stonehearth.exe.

1 Like