[Res] Furniture being dropped than placed anyway

Just pointing out a bug that when I placed my table and chairs my villagers will put down the furniture near where its placement is and than place the furniture anyway. In the Example in the picture below I had made only 4 tables total and when I tried to place the mini versions it would just move the already placed furniture instead. leaving permanent clutter.

3 Likes

I can confirm it’s happened to me too.

1 Like

I had this happen in my game today. If you move ‘misplaced’ furniture, the clutter will disappear. The only problem is then you’ve moved the table you wanted placed and have to move it back into the correct place. I’m sure this will get cleaned up in the future but you can work around it for the moment.

I’m having trouble reproducing this. Anyone know how to make it happen explicitly?

m afraid not :confused:

it might have to do with placing the same piece of furniture directly from the stockpile multiple times. im not 100% sure but i think that may have been the cause of it for me a few alphas back.

I’m having problems placing fences, kind of related to this bug. I will place fences till I can’t place anymore in ghost vision. I already have some fences placed somewhere else. I will finish placing fences for a new pen and I’ll go look at my field and there will be a move sign above one of the fences.

Hello, this happens to me too every now and then. I am not 100 % sure on this, but it might occur when a Hearthling gets hungry while carrying the piece of furniture to its destination. As soon as his belly rumbles, he seems to drop anything in his hands to make room for an extra serving - which is perfectly understandable from my point of view :wink:

After all, one has to have clear priorities in life, right?

1 Like

I haven’t been able to reliably reproduce this either. It seems to just randomly happen. It seems like it’s some kind of visual bug showing the item like it hasn’t been placed , although it has been placed where you wanted.

So far, it’s only happened when I’ve built a building with pre-placed furniture. I haven’t had it occur while placing things directly in the world.

I’m having trouble reproducing this. Anyone know how to make it happen explicitly?

The easiest way for me to make it happen is:

  1. Have the carpenter set to keep “in stock” 5 chairs and 2 tables.
  2. Let him/her build those items.
  3. Build a (game default) dining hall.
  4. When the floor is done, the Hearthlings will instantly place those already made items. As new items are made (now that the stockpile is emptied), the bug appears more often.

Note that this only sometimes work, not always.

Thanks! I tried this a few times, but still couldn’t get it to bug out.

When this happens in my games, I am putting 10 - 14 beds at the same time. Most of the times, 1 or 2 of those beds will end up like this. This happens also when I am placing fences.

Also, I noticed that this only happens when you are placing the items next to another item or the wall of a cave. But that could be a coincidence.

1 Like

@yshan just fixed a bug that had these symptoms, so this should be taken care of in the next patch!

3 Likes