Northern Alliance, no Traders/Merchants?

So I’ve made an observation. Unless it’s seasonally biased I suppose(?) traders and merchants don’t seem to favor the Northern Alliance. Alternately maybe it’s because I’m playing the NA in their specific biome. So far I’ve been playing for a little bit and the only merchants I’ve seen stop by are the ones who sell a single type of wood log. I might have once earlier gotten an artist or something, I seem to recall the Goblins demanding the painting I had purchased and never used.

I’ll admit it could be a mod interference of some kind, but I thought I’d get the general consensus first. Is it odd that I can’t seem to attract any merchants? My town value is, after modification from the special hearth, over 20k I think? I even built two merchant stalls and tried summoning a merchant at both of them…and nothing popped up. If I can’t get a merchant to show up I don’t think I can finish the Font of Summer since I can’t get the wheat otherwise…without cheating…which I already did to spawn a bunny statue for lulz.

The entire shop is just one item? That would be wrong.

Shops are thematically, each one offers a group of items with a theme (woodcutter, pets, food, etc…)

You should have a notification, probably buried behind other notifications if you didn’t cleaned them

Gave the game a little break over the weekend and I think something must be wrong on my end. I’ve tried using my stalls a few times today and nothing happens except the “call merchant” button gets greyed out. I’ve progressed to the point of getting two members of Clan Amberstone to join me so I’m really being blocked from progression…except in the case of that wheat. I DID have one new merchant show up randomly, a potter, after I loaded the game, but days have passed in game and after that I’ve seen someone selling logs (and again, only one type of log) once. How would I go about uploading info for some trouble shooting? I’d kind of hate to lose my progress and start over, but I’m willing to do that too. It would be sort of like re-embarking, just without taking any of my stuff with me.

Did you checked the notifications? Traders appear there when you call them

In what version did you start this savegame? What mods are you using? What specific market stalls are you using?

@Alexander_Harvey, here’s how to upload the savefile (the info that @paulthegreat and @BrunoSupremo ask for will be useful to know too) :

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

The only notification that should be present in my notifications log is the one for building the Font of Summer. What version did I start with? Umm…that’s a great question. Shortly after launch I think? The earliest save I have for this game is from August 6th. My mod list is;

Archipelago Biome
Armis Maximus
Better Storage
Box Command Tool
Canyon Biome
Hearthlings of Many Faces
Home Sweet Home
Locks of Many Hair
Lodewell Lights (Continuation)
Lorkis Biome
Miner Profession
Primitive Armory
Sacred Grove Biome
Settlement Decor
Yangz Yings

All subscribed via Steam Workshop. I do not have any mods in the Mods folder manually installed. I’ve got two of the basic blue fabric market stalls from the carpenter located inside my main gate wall, near the rabbit statue that I spawned in on day one of the game.

Hope that covers enough information for you guys :slight_smile: If the best course is to just start fresh or remove a mod or something I can do that. There are a few things I’ve learned since starting this game anyway…like how I really should have made a fisherman early on so my hearthlings had a bit more food.

I’m not downloading and running all those mods, but when I load up the game and click on your two market stalls, I see one of them is on cooldown and the other isn’t. When I click “Call Trader” on the one that’s off cooldown, the trader window properly pops up (in this case, it was Gannor’s Breakfast Foods Trunk with a variety of breakfast foods for sale. I just tried it again (reloading the game and clicking the same market stall) and got Vert Greene’s Verdant Greenery with a variety of seeds, etc.

Edit: There’s a whole lot of z-fighting (the graphical flickering) going on with the floor of your main fortress structure. Did you insta-build that by any chance? It seems that the terrain for the foundation didn’t get dug out so they’re overlapping.

Edit 2: I let it run on speed 3 for about a day so the timer on the other market stall would reset, and successfully used that as well. One thing to keep in mind is that if you have a dialog open, like the daily update dialog, the alert and dialog for the trader won’t pop up until you close the other one.

That does imply that it’s some kind of conflict with a mod I suppose. Yes, I did insta-build the big structure. For some reason after designing it and laying it all out the hearthlings insisted on building the very top-most beams of the roof first and if I tried to build a ladder to get them up to that height it would just highlight some other thing that they suddenly couldn’t figure out. Thanks for your input thus far!

1 Like

As a side remark, it is good to know that insta-build can be used for such cases :slight_smile: With the skylands mod, there are many situations where it will be useful.

Possibly found the problem as sad as it is. I went through and disabled, one at a time, the mods on my list. At least, the ones I thought most likely to have an effect on merchant generation. So no biomes were touched, nor the Many Faces and Many Hair, and I left the Miner Profession alone. I saw no improvement until I disabled “Signery”, but that may well have been a fluke as when I waited a day and used both stalls again I didn’t get a merchant from either. Then I got down to the last one, Yangz Yings, and with that one disabled my merchant stalls called merchants as anticipated. When I sped up time to make sure and try them again I even had two more merchants show up independently.

Ok, I have no idea what’s going on and I’m going to bed. Just to double check I left Yangz Yings enabled and started a new game with Rayya’s Children and the Debug Tools enabled. I spawned in four clay merchant stalls. When I used those to summon a merchant an actual merchant NPC spawned near the camp and I could use the stall again to open their wares menu. But all of them were just basic resource merchants, so they each had exactly the same amount of stone and logs. Then I spawned in two of the carpenters merchant stalls. Both of them acted as anticipated, no NPC spawn and they generated a merchant. I think the first one was furs and leather goods and the second was a potter.

As a clarification, in order for the stalls to spawn the random shops, a certain encounter must have triggered (it triggers automatically in the afternoon of the first day). In addition, you must have at least tier 1 (the banner) so that the game knows which shop tiers are unlocked.
Otherwise, the default Basic resource shop plus trader NPC will spawn, which is the behavior you noticed when you used debug tools.

For the shops that spawn automatically (not summoning via a market stall) you need to have at least 500 net worth first.

Let us know if you find a way to reproduce the shops not appearing issue without mods.

The quest for the broken mod continues! I took what @Relyss said into consideration so when I started testing today I have made sure to wait until after I have chosen my banner, and until the following day for safety, before spawning in the merchant stalls.

First I tested all the mods active with Rayya’s Children in the Desert biome, everything seemed to go fine. I started to think maybe it’s just an odd bug with my particular game. Started a new game, all mods active, with the Northern Alliance in the Tundra biome (where my original game is located)…and now the merchants don’t work anymore. No error messages thank Monkey, but no merchants either. I followed up by disabling all of my mods (except debug tools of course) and trying again. All tests now will be exclusively Northern Alliance in the Tundra since that’s where I seem to be having the problem. With no mods the merchants are fine. I added back in all the biome mods next and that’s all fine. I next added back the mods that don’t add any items (to my knowledge at least) and the merchants are still fine. Tomorrow I guess I’ll have to start adding them back one at a time and see what breaks it…again, I’m really hopeful it’s not Yangz Yings. I like some of the stuff they added, like the longbow for my NA Archers.

1 Like

Minimal testing before work. Re-enabled every mod except for Yangz Yings. Everything seems to be fine without it, I was building a house before adding stalls and I started getting traders after my net worth reached 500 gold. Uncertain then, since my only alternate testing was Rayya’s Children and the Desert, if the catalyst is the Northern Alliance or the Tundra biome. Is there a way to check the code for an error of some kind if I make a game, use the stall, and no merchant arrives?

Another super quick pass here…and I think I’ve more or less confirmed that, at least for me, something is wrong with Yangz Yings.

1 Like

I played singleplayer with a few mods and there is no trader appearing, not even when I use the market stall or the “call” command. When I use the “call” command, then it say “error” : “could not dispatch [funktion fn:some-random-number route:undefined]”

Steps to reproduce:
I have no clue… just use the following collection of mods I guess?

Expected Results:
Traders apper randomly and when using the market stall/ “call” command

Actual Results:
No Traders Appear

It Also doesen’t work in Multiplayer, even tho I have different mods there

Attachments: (5.6 MB)

Version Number and Mods in use:
1.0 (newest Version without the beta-branches)
Steam Collection: Steam Workshop :: Multiplayer mit David

Your savefile includes Yangz Yings mod, which is the mod that was causing this issue in the report I linked in the reply to your other post. This mod has some mixintos to the spawn shop files, but they might not be correctly setup.

The user in this thread: Northern Alliance, no Traders/Merchants? confirmed that removing it fixed the issue.

OK thanks :slight_smile:
BTW just a small note.
When playing rround with the “Martial Trained” Trait from one of the mods i realised, that bows are one-hand weapons

1 Like

thats correct! they dont block the second hand because normally an archer cant use any melee weapons, that trait from @kaimonkey’s mod just opens up that can of worms :stuck_out_tongue:


I see nothing wrong with this :stuck_out_tongue: