[MOD] City planning with pegs (version 5.0)

yay for building planning tools. thanks! will report back if i find any issues!

1 Like

great idea for a mod! good job @nikosthefan :merry: :

I never knew I wanted this until I saw it… but holy butts this is a brilliant idea!

In the past, I’ve used a trick I picked up in other games to get a similar effect: a stockpile with the filter set to ‘nothing’ to mark out the floorplans of larger/more elaborate construction projects. Of course, Stonehearth is a bit easier to work with than other games I’m used to since you can create your building as a blueprint and then start construction at your leisure, but having too many blueprint ghosts active can still cause problems.

These pegs are great as little markers, and very thematic, so they actually add to the story of the town. They go beyond a simple reminder that something will be built there, they actually imply construction and growth in progress – your town is making plans to expand, not just you as a player but the townfolk themselves know that they’re building up something larger over time.

I love this mod to bits!

2 Likes

Thank you all for the compliments. :slight_smile: I am working on version two and making good progress.

1 Like

Version 2.0 beta

download
at the first post


This version adds in a set of clay pegs and a set of stone pegs. I also fixed the bug where the items showed up with an unidentified category name in the “place furniture menu”. The pegs now also mark territory.

why is it beta?
I have found another bug I need to squash. The models of the medium stone peg, the medium stone peg iconic and the small stone peg iconic are not showing, for some reason. Edit: It was that the models had voxels on different layers. It has been fixed for next patch.

Version 2.1

download
at the first post


This version fixes a the remaining bug where some models weren’t showing correctly. The mod should now be bug-free

Version 3.0

download
at the first post

This version adds peg piles. Scince you can get multiple pegs out of one lump of material, you now need to craft a batch (read: said piles) of pegs, instead of the pegs themselves.

how to install the mod

  1. put the downloaded folder into the stonehearth/mods folder.
  2. start the game

how to update the mod from v2.1

  1. Delete all big pegs (big pegs are not anymore in the mod, they are large pegs now.
  2. Cancel all peg-crafting activity. Pegs now need to be crafted in batches, so all those individual-peg recipes will not be there anymore after the update.
  3. Install the mod as detailed above.

feedback
If you have any feedback about the balancing or capacity of the piles, the feedback is welcome. Especially feedback about how many you typically need to store all the pegs you use in a playthrough, is especially valuable.

4 Likes

My first mod is finally complete :smiley: YAY. Here is the new version of it:

City Planning With Pegs. version 4.0

Download v4.0
at the first post


In this update, I added the ability to pile pegs together in amounts which are useful for storage. The earlier piles where balanced around how many pegs a crafter could make out of one wood/stone/clay resource.
The new stacks are either multiple piles, stacked on top of one another (as seen in the picture), or a new model altogether (which is only for large piles). I tried to keep the amount of extra models and recipes small with that move.
I also made the mod translatable and polished it up here and there.

Changes in v4.0

  • added stacks of pegs, the bigger variants of peg piles, balanced around storage, rather than crafting. These were only added for large pegs.
  • make the piles for small and medium sized pegs look like a shelve when stacked. This whay, ‘stacks of pegs’ are not necessary for these sizes like they are for the large pegs. (Also, thanks @BrunoSupremo for his help with this.)
  • restored all i18n() references. All texts (descriptions, flavortexts etc) are now read from the locales file.
  • removed references to big piles related to harvesting piles
  • changed the model_origin for uncentered models (its center being a seam, and not a voxel)
  • removed invisible voxels (from different layers in the voxel editor)

I hope that this will be useful, and that you have fun using it. :smiley: Please let me know if it came in handy.

5 Likes

Hello i love this mod for multiple reasons, planning out the first floor of a building, being able to train crafters while sacrificing very little in terms of resources, being able to profit off of the pegs i have them craft. etc However i must say it’s very frustrating to see “batch of large clay pegs” listed in the crafting list but the normal singular large clay peg is NOT there in the crafting menu, which is required to craft the large batch. Also i can’t craft ANY single sized peg on it’s own. none of them are available in the crafting menu. Is this an error or on purpose? why are the batch of pegs listed twice? from what i can tell one of them is meant to be purely decorative and nothing more while the other is meant to be functional??? am i correct? wrong? and why isn’t the single pegs listed?

oh, I think this is a disconnect between what I know and what the player knows. oops :sweat_smile: Here is an explanation:

  • The reason that you can’t craft a singular peg, is that a carpenter can create way more than one peg out of a wooden log. Pegs are so small that a carpenter could make a batch of them out of one log, hence the “Batch of Pegs”.
  • These batches are basically log piles, but then pegs and a different amount of them. To get an individual peg, you do the same as when you’d want to turn a log pile into a buch of individual logs, by placing down and harvesting the pile. (don’t do this when a peg pile is stacked on top of another, it might break, i think)
  • The two recipe’s actually ‘point’ to the same item, that same batch of pegs. However one, found in storage, piles individual pegs up into a batch, while the other, found in building parts, crafts a batch out of some resources.

So in short,

  1. you need to craft a batch out of resources first (recipe in building parts)
  2. then you need to take the batch apart (harvest like you would a log pile)
  3. then you can repack them to a batch again (recipe in storage)

When I made this, I thought it made sense (I even dropped hints in the recipe descriptions of the crafted batches), but that doesn’t say anything cuz i made it, so of course I would understand. Thanks for letting me know, I will try to think of a more explicit way to say what is what.

2 Likes

I must be doing something wrong because I can’t get this mod to work ^^’'
I dragged the unzipped folder into the Mods Folder then in the main menu of the game I go to settings. Then I go to the mods and try to check “[Add][Model]Peg_Planning_mod” but when I hit Okay, nothing happens. If I go back to the menu, it is back to being unchecked.

you should not unzip the download, just rename it to .smod instead of .zip, then it should work :slight_smile:

You can do both way, you can unzip it or just renamed to smod.
That is not the problem.

The problem is the name of the mod. It has symbols that mess with the UI, like blocking the ok button.

I wonder why there is such a batch of new mods that are insisting in adding brackets and other symbols into their names. Not only it bugs the game, but it looks bad and is less readable…

2 Likes

:sweat_smile: … my bad … :sweat_smile: sorry

I thought it was a good habit to put those labels in front. The idea was that it would function as a self sorting mechanism in the mods directory, using the fact directories sort their folders in alphabetical order. In practice it should group all biome mods together, if the same labels were used.

I will remove it from all my mods, seeing as it bugs out the game.


Having said that, I am curious as to which characters (that are easily available on the keyboard of course) will cause problems with the engine.

I assume I can’t just change the file name myself XD probably would mess with the code right?

Maybe not. Try it. If it was not working before, the worst thing that can happen is it keep not working.

1 Like

When I rename to file where I changed the extension, I get the message “Invalid Manifest” in the mod tab.
If I rename the folder that I unzip, it can be checked but the mod is broken once in game.
Ah well, I can just wait until the download is fixed ^^

@nikosthefan I hate to bother but is there any kind of ETA for the updated mod? I’m super to excited to give it a try and I would edit all references to the file name but I don’t know how to ^^’’

What do you mean by ETA, I don’t know what the abbreviation is.

ETA = Estimated Time of Arrival

Oh, ok. Well, I don’t know how much time it will take. I need to fix all three of my mods, and some have more problems/things I wanna add than others. First on the list is the name change of ClearSky, which should be very easy to do. Then this mod is on schedule. I need to do the name change, and I want to try something I found on the forum to make the peg crafting process easier.
I think it will be done within a week (I’ve also got college to attend), but it is always tricky talking about release dates, so keep that in mind.

2 Likes

I finally found some time to look at this one again. :smiley:

City Planning With Pegs. version 5.0

Besides the necessary changes to change the name (so the engine won’t freak out), move the mod (so the forum won’t make the engine freak out) and change the mod format (so the engine won’t freak out, man I’m sensing a theme.), I found out that I can make one recipe produce more than one item.
The hack I had in place for it earlier used the stonehearths pile-mechanics as a proxy for this effect, but it was very confusing/unintuitive for y’all. But now I know there is a better way, I’ve fixed it.

In short, no double recipes, no more double-tiered crafting and no more engine freaking.

Download v5.0
At the first post.

Changes in v5.0

  • implemented a feature where one recipe can produce multiple pegs. This fixed the hack where I used piling mechanics for this. This:
  • made peg crafting more intuitive and,
  • removed the double recipes
  • removed symbols from the mod name that the engine didn’t like me using.
  • changed .zip to .smod
  • moved file to github

:warning:For those who update from earlier versions:
The name change will force you to delete all pegs from your worlds when updating. The game will be searching for pegs with the prefix [Add][Model]Peg_Planning_mod, but it won’t find any, scince all are called Peg_planning_mod:…. You can choose not to delete them, but then you’ll be stuck with errors of the game swearing that those damn pegs were here just a minute ago. Sorry for this.

4 Likes