Home sweet home 🏡


Damn, this update is looking amazing (as always), @pingu - good job!


Thx, finally also the Cook Entities works properly for both Kingdoms ^^


Sorry to be the bearer of bad news but the wooden shelf still disappears when I have both your mod (which I love the additions to btw!) and settlement decor active. If I disable settlement decor it reappears. As I said previously i’m not a modder so I don’t know what is causing this one item to still conflict. I tested it with a new game save. I really have no further ideas on how you may be able to solve this but I really hope you can. :smile:


ahhh no problem ^^
i will try it myselft at home with the other mod installed. I hope to find the bug :wink:


About the mod conflict:
Having the same name is not a problem! I for example have a tree:palm and so does the default game. The thing is everything is prefixed with the mod name, so it is actually stonehearth:tree:palm, and mine is archipelago_biome:tree:palm. There is no way to have the same name in different mods.

What is probably happening is the same name in recipes lists. Those can be repeated and override. Take a look at that.


Yes i think that this is the problem! Changed it already and i will test it on my PC :smiley:

Thanks for the Tip!


So i updated the smod file. Tested it also with the active decor mod. Everything seems to working now. Thx for the report @dal_24!

If someone find other problems let me know.


It’s working for me also. I’m really pleased you figured it out.:smiley:


Perfekt!! Thx you for the report again :blush::blush:
Bruno was right. It was a recipe name


I spoke to soon. When you try to place the models for the herbalist library and the crockery shelf the image in game is missing. I’ve got it to work but I had to change some lines in the .json and _ghost.json documents in :entities/furniture/shelf_herbalist_library and shelf_cook. It still just reads shelf/shelf.qb in those documents. Thought i’d make you aware of this and hope my description helps.:smile:


Ohh shit :no_mouth:

Have to cerrect it as soon as possible


New Update online

Made some Bugfixes that causeD model problems and also some problems with other Mods.

Downloadlink in the first post :arrow_up: :arrow_up: :arrow_up:


Today I tried out the RC stuff for your mod but something odd happened. I had the potter make a pottery shelf and the RC ceramic plates but now I can’t seem to get that recipe. All the recipes seem to have reverted to Ascendancy. So now I can only make the Ascendancy stuff. This seems to hold with the herbalist and the cook as well.


Uhm ok. Have to look at the code today. Can you give me some more inputs?

Witch mods are active for example


Blacksmith and Carpenter have the same votes. So now please just say me witch one of this to should be the next

  • Blacksmith
  • Carpenter

0 voters


Canyon mod and terrain colors were installed alongside when I first noticed this so I tested.


1.Removed all the other mods except this one.

  1. Played through until I got a cook

  2. Confirmed herbalist, Cook and potter all had the right recipes.

  3. Saved game

  4. Reloaded game.

  5. Cook, potter, herbalist all now have missing recipes.

Bug confirmed for loss of RC compatibility in HomeSweetHome after reload for all workstations.

Here’s the save1506250854778.zip (5.2 MB)


And you played with the same mod version right?

Sorry can’t open the save game file (need a zip file)

Will take a look at this error. Any other players have the same Bug?


I uploaded the most current version. And I fixed the filetype for you.


Thx @Averest,
i see the error now. Tried to recreate it myself and i have the same bug :frowning:

Have to take a closer look at the MOD Files to find out why this happens. Maybe takes some time.

@BrunoSupremo, i have used your Rayya Lua file for this Mod. Maybe i forgot something in the Code Files?


One thing I’m also noticing is that books and dishes don’t go into the stockpile unless it’s universal. It looks like they’re set as decorations from what I can tell from looking at them with debugtools but don’t stockpile as such. The shelves seem to work fine.

Sorry, I’m a huge fan of this mod because it gives some much needed love to RC. :sparkling_heart: