Heartlings stopped building my crates

I built a huge storage, but right at the end, my hertlings just don’t want to put the last 4 crates. I have them at my inventory.
It’s anoying, cause it were already 10+ in game days that i sent them to build, and still no response. I tried restarting the game but it didn’t help at all.
Here is the pic:

[1]: http://i.imgur.com/25Xckjj.png

1 Like

hey there @deathx91 welcome to the discourse :smile:

i’ve embedded the pic for you.


Thanks you very much, sir @8BitCrab :smiley:

no problemo, thats what im here for.

are your hearthlings frozen, or actually just idling?

No, they actually do evertything they should be doing. When i send them to build, mine, pick items, or anything else, they do it. They are just ignoring those 4 build requests.


hmm… maybe the pathfinder is having trouble, perhaps try building ladders up to those spots.

1 Like

Nope, nothing at all. I also tried changing the build location to ground level, but still no response from workers.
Here is the PIC

strange… they can access the stockpiles where the crates are, right?

Yes they can.
I found something. Just didn’t pay attention to the Error window. It’s repeating like 4-5 times per second the same error over and over again.

> release-453 (x64)
> ...tonehearth/services/server/build/ladder_builder.luac:130: assertion failed!
> stack traceback:
> 	radiant/modules/events.luac:68: in function <radiant/modules/events.luac:65>
> 	[C]: in function 'assert'
> 	...tonehearth/services/server/build/ladder_builder.luac:130: in function '_start_build_task'
> 	...tonehearth/services/server/build/ladder_builder.luac:80: in function '_update_ladder_tasks'
> 	...tonehearth/services/server/build/ladder_builder.luac:34: in function 'add_point'
> 	...tonehearth/services/server/build/ladder_manager.luac:14: in function 'request_ladder_to'
> 	stonehearth/services/server/build/build_service.luac:287: in function 'request_ladder_to'
> 	...earth/services/server/build/scaffolding_manager.luac:128: in function '_update_scaffolding_region'
> 	...earth/services/server/build/scaffolding_manager.luac:91: in function '_process_changed_scaffolding'
> 	...earth/services/server/build/scaffolding_manager.luac:80: in function 'method'
> 	radiant/modules/events.luac:14: in function 'self'
> 	radiant/modules/events.luac:80: in function <radiant/modules/events.luac:78>
> 	[C]: in function 'xpcall'
> 	radiant/modules/events.luac:78: in function 'trigger'
> 	radiant/modules/events.luac:97: in function '_update'
> 	radiant/server.luac:19: in function <radiant/server.luac:17>

And here is the PIC of the error window.

if thats the case then its a loop, if i’m not mistaken, even if you click “close permanently” it will continue to fire these errors, the only way to stop them is to close the game… :confused:

Ok, after getting the error counter to 3k+ the game stopped responding and needed to close it. When opened the game, the error appeared again. But i would bet that the error is pointing to another bug, not related to the crates one haha.
As the stack tree keeps repeating “ladder” and “scaffolding” i would say that it’s related to [THIS][1]

[1]: http://i.imgur.com/NyGZYp6.png

1 Like

so from what i can tell, those are all buildings that werent finished for whatever reason, correct?

if so, you could try using the ib console command to insta-build them and see if the errors go away.

In regards to them not placing the chests, pathing is not an issue. You’re have the Ghost Item issue. Something a lot of people are dealing with. It renders the items completely useless. On phone so can’t very well ramble on.


Ok, aparently after creating a new game, and then loading the old one, unstuck the ladder and scaffolding error loop.

That’s so sad :cry: It means i have 4 useless crates.

1 Like

Agreed, definitely ‘ghost’ crates. They are visible in the ‘Place an Item’ menu but if you look through your stockpiles and your hearthling’s inventories you won’t actually find the crates anywhere in your game. They’re just gone.

It happens with crates more often than any other item IMO.

1 Like

Yea, just used the “destroy” command to delete them, then crafted more, and placed then non buged ones. Hope it gets fixed so we dont need to worry about items we actually don’t have xD

1 Like