Glassworks [1.2.2]


#41

Take your time! There is no rush


#42

Hey Dani! Loving the mod a lot but I had one weird issue. I tried to place a green glass cup on a stone table but it placed next to it. Now I can’t select the green glass cup to move it off /and/ it says the table is in use. Here’s a screenshot. I had to teleport the table to move it.


#43

Oh totally forgot about this mod :smiley: need to revisit someday soon


#44

Taking a look at all those major Glassworks issues, I have good news.
I found the issue with the Bench - and why it was so weird to reproduce/find it! Apparently the collision box had issues but it only behaved wrongly on certain directions. If placed on a different direction, it worked fine - so only certain placements of it caused issues.

It is fixed now :slight_smile:

Also, about the obsidian…
It was probably a typo. I need to test now to see if it is working - but there was indeed a typo in the manifest :slight_smile:

@Averest
I fail to reproduce this, I can put the cup there indeed but it seems to be clickable and movable nonetheless. And if I place them on the center of a table, they are also placed normally. I’m unsure what could be wrong, but I’ll keep investigating.

Also, I did notice that when I click the cup I can’t REMOVE it, just MOVE it. Which is weird, and I’m not sure why, but if I give the move command it works. Removing doesn’t. :thinking:

And finally, glass stuff do not have the “white contour” when you mouse over them but you should still be able to click the cup nonetheless, just hover the mouse above it and click :slight_smile:

I’ll finish testing/experimenting and will post an update later :slight_smile:

EDIT:
Update

Apparently I found what broke the obsidian. It was never broken, actually. Apparently some recent (not so recent) update like Northern Alliance (maybe?) changed the mining table a bit… and made the rock dropping ratio be based on a very high “nothing” weight (10.000). I remember it being less than that, maybe 1.000 or even 100? (?) not sure now. The thing is, as you can see the problem is that obsidian was VERY, very rare since that got changed. Like… super duper rare. So it wasn’t broken, it was just mathematically almost impossible to get it :joy: so I’ll be fixing that to make it less rare. It should still be rare (the best way to get it should be mining Gold Ore veins).


#45

GLASSWORKS updated to 1.2!

Not a big update (again :expressionless: ) but a very important one since it solves two very game breaking issues that were definitely plaguing the mod.

Here are the official notes:

September 23rd; v1.2

  • Fixed the issue with the Glassmith’s Bench where it would sometimes stuck the crafter.
  • Fixed the issues/typos that were preventing mining drops to function as intended. You should now notice a much increased dropping rate of everything; sand, salts and Obsidian. Please note that Obsidian is intentionally rare and will very rarely (if ever) drop from regular rock. For more promising prospects of finding it, you should seek Silver and Gold ore veins. They have a much increased chance of dropping it.
  • Added three new pieces of storage/furniture, one for each basic crafter (Potter, Mason and Carpenter). These new shelves can hold up to 128 items but only salts or flakes, becoming a very efficient way to storage your overflow of salts. Please note that they require glass pots to be crafted.

I’ll be updating the non-steam download soon.


#46

“not a big update” every update is an update


#47

I love mods / base functionality which adds to the economic complexity (resources chains, etc). This fits right into the description.

Are there any other mods that synergize with this in terms of increasing the economic complexity?


#48

Dani’s Trapper+ mod does as well, I believe.


#49

Just posting a warning. Lorkis biome, as pretty as it is, doesn’t play well with glassworks. Sooooooooooo much stuff drops. It generates an incredible amount of hauling jobs. Just digging out two rooms and selling the sandpiles and salts has netted me 1000s of gold.

Oh! And speaking of sandpiles, I’m getting them spawning above ground where you mine at least in Lorkis and as I found out today, Tropic of Unicorn.


#50

Do you mind posting a picture of the issue you are having with Tropic of Unicorn? That is my mod. I’m not personally getting any weird stuff going on, but I will look into it and try to correct any bugs on my end! Thanks for posting so I can try to fix it!
-TacocaT


#51

Sand does drop from dirt, and on some biomes it will drop from surface tiles as well (like the Desert and any maps that uses the desert mining tables as mixin - like Canyon).

I made sand quite common because I’ve heard from a lot of people that their Glass productions were mostly halted due to the lack of sand - since ash is something you can craft at will but sand isn’t so easy. You can always pack and sell spare sand if it’s too much :smiley:


#52

I don’t think it’s specifically your mod but this is what happens when it and Glassworks are together. I have to test this to see if it happens on normal maps.


#53

Ahhh! I see the issue.

I think it is a game issue. I think that when a tile from the “roof” of your tunnel is mined and there is no empty space below it - it “ports” to the nearest empty space above. Probably happens with my sand piles due to their nature, being the iconic of a placeable (and henceforth having collision info) instead of a regular item with no other entity forms.


#54

Yeah it does it on the normal maps too.


#55

Yep, I figured it would. It must be indeed a game issue, not related to any mods but how the game handles the item drops


#56

Still I am having some trouble with all the materials being generated by Lorkis biome, which Is like hitting the easy button since it seems to multiply the mining drops until you realize Hearthlings have to handle every item even if you destroy it all. I compared all the custom mining tables but I’m not certain what I need to change. I assume I should change the overall weight number.

This is a LOT and it’s all stacked multiple pieces.


#57

@Averest - do you terribly mind if you get the other drops less as well?

If not, I could offer you a version of the biome mod to try that might fix it.


#58

btw, could you lower the chance of packed sand? I mined something (made of dirt) and got like a total of 70 sand, but only 12 clay and 5 stone


#59

That’d be great Kitty! Honestly it was too much but I love the terrain generation.


#60

If you’re using the Steam version:

  • Navigate to: xxx\Steam\steamapps\workshop\content\253250\1359762368\data\biome

  • Create a copy of this file (as a backup):
    lorki_mining_loot_table.json

  • And extract this version into the folder:
    lorki_mining_loot_table.rar (727 Bytes)

If you’re not using Steam: LorkiBiome.smod (248.1 KB)

I think you should be able to just drop that into your mods folder.


What I did:

  • Multiplied the “none” drop by 10
  • Multiplied the original drops by 5

In theory, this should thus make the Glassworks drops 90% less common, and the rest of the drops 50% less common.