Glassworks [1.2.2]


#61

Thanks Kitty! I’ll give it a try when I have more time today.


#62

My pleasure! Let me know how it works, and if it needs any further tweaking in either direction.
It’s essentially the inverse of the changes I made at one point when the drops were too low for my Plains biome, lol.

(…I wonder if I should update that mod…)


#63

Looks great so far! The drops are far more reasonable. Thank you so much! :merry:


#64

Glad it’s working out for you; happy to have helped! :smiley:


#65

Hey i posted on the steam workshop page about my hearthling running around the workbench not knowing what to do after hitting 100% of the crafting stage when attempting to create a door. Just thought i’d post here too in case you come here more frequently than the steam workshop page. As i said the update didn’t fix it for me. I’m still having the same issue and i saw you said to remove the workbench and build a new one in it’s place. well. i did. and it doesn’t work still. Will this update not apply to my current save? will i have to start all over again just to make this work?


#66

Just removing and placing again won’t fix it. The bounding boxes (this was the issue) are saved per instance of the object so even if an update “fixes” the bounding boxes of determined object, that instance will always have broken boxes.

The only way to be sure is by completely destroying it (ctrl+c to open console, select the bench, type ‘destroy’ and press enter) and then make sure you have no other glassmith’s bench in the game (placed or iconic). If you do, destroy all of them.

Then craft a new one and place it. That should work.

If it still doesn’t work, then your mod might indeed be out of date. Try removing it from the game (unsubscribe, etc) launch the game to make sure it is not there, then subscribe again :slight_smile:


#67

Hey, I’ve done everything you’ve suggested to fix the dancing worker bug, but I’m still experiencing it. I unsubscribed, launched, resubscribed, and started a new game and my worker still won’t finish anything at the bench.


#68

Including destroying all glassmith benches in the game and then crafting a placing a new one?

Edit: sorry, if you started a new game and it’s still happening in a new game, that sounds equivalent to having destroyed all instances and placed a new one.


#69

Yes, I can confirm the bug still happens for different reasons now :sob:

I’ve been somewhat busy but I’ll try fixing it as soon as I can :flushed:
Sorry!


#70

No worries, it’s good to hear you’re attempting to fix it :grinning:

This is one of my favorite mods for Stonehearth because I love glass crafting. I have ever since I started playing Dwarf Fortress years ago.


#71

hey my glassmith is stuck again! I don’t know what to do! I thought you had fixed this issue :frowning: but it seems as tho it hasn’t been fixed fully. I tried crafting Green Forest Crown Wooden Door and after reaching 100% on the crafting status he drops the resources required on the floor, the crafting progression remains at 100% and he just kinda waddles around the crafting bench not knowing what to do as if he’s trying to reach a place he can’t get to :confused:

Update! So apparently forced ending the task makes the crafting task finish some how. That’s annoying because that means every time i craft something with the glassmith i must wait for it to reach 100% then delete the task for them to finish it.


#72

GLASSWORKS updated to 1.2!

November 11th; v1.2.1

  • Fixed the issue with the Glassmith’s Bench. Again. Hopefully for good this time! :jubilant:

I hope that will work this time around :smiley:
It did on my testing at least.
Once more, for it to certainly work, you need a new bench so just completely destroy your old one and craft a new one :slight_smile:


#73

I’m having an issue finding titanium salts to make the obsidian bars - I’ve mined a 32x32 section of mountain & not one titanium salt drop - I’m using Lorki’s Biome so not sure if that’s the issue although I’m getting plenty of everything else.

Any suggestions? I know something like this was mentioned before on steam but I didn’t see any answers.

Love the mod! But I would love to be able to use the great armour as well :smiley:


#74

I am having a blast with this mod, love the new items and doors/windows.

Just one question: where on earth do I find Chromium and Titanium Salts? I’ve tried all the different ores and terrains but nothing drops them it seems?


#75

Add: Can’t find Cobalt Salts either it seems!


#76

@SJ_Vermeulen what biome you are using? :smiley:

Salts usually drop (more often) from actual ore nodes, I think these are from silver and iron nodes :slight_smile:
If you are not seeing any salt however, that might be an issue with the mining tables!


#77

I am getting all salts but Cobalt, Chromium and 1 titanium miraculously showed up at some point, but can’t seem to find more, tried all the ores several times but nothing. It is just puzzling me, and I want my pretty windows T_T


#78

I probably need to review all the looting tables at some point ;-;


#79

Thanks for the updates!!

One thing I’ve noticed it the hotbox for the table is shifted over one space from where the table is actually placed


#80

Table seems to be fixed now btw!