Game crashes, Hearthling stuck in oblivion


#1

Hi there and Merry Christmas,

decided to start anew with Stonehearth over the holidays. Right now I am havin the somewhat dubios problem of a hearthling stuck in the middle of Nowhere, which either crashes my game (UI stays) when clicking on it or just after a short time in my latest save. I tired to read a bit, but neither reset or teleport seems to help. (Ed. -> reset seems to crash game)

I guess this part from the log might help:


2018-12-25 20:00:08.328051 | server | 1 | simulation.remote_client | started buffering client updates. (seq:2350 ack:2321)
2018-12-25 20:00:09.356391 | client | 0 | renderer.mob | mob: current position for object 885721 became NaN. Skipping render mob’s Move() update.
2018-12-25 20:00:09.414237 | server | 0 | simulation.pathfinder.astar chase entity(src) | (4729567 Amelia Baub) | could not find subspace for starting point (-2147483648.00, 2147483647.00, -2147483648.00). EVERYTHING IS BROKEN! =(
2018-12-25 20:00:09.463597 | server | 0 | simulation.pathfinder.astar chase entity(src) | (4729567 Amelia Baub) | could not find subspace for starting point (-2147483648.00, 2147483647.00, -2147483648.00). EVERYTHING IS BROKEN! =(
2018-12-25 20:00:09.511603 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:2350 ack:2335)


I like the “Everything is broken” part. Any way to salvage my save game?

Thanks

Kobold

Edit: So it seems I do have two “Out of Bounds” Objects, both of which are footmen. Where in the Object properties can I either edit coordinates or just delete my brave footmen?

Edit 2: In fact the “mob” component is empty for both of them, compared to normal objects, which amongst other things, gives also object coordinates.

Edit 3: Ok, destroy_immediately works, however, not a really nice workaround. Any suggestions for better ones. Again, reset and the like just crash the game


Game world freezing
[ACE] Pre-Release 0.9.2 - Out now!
Sp game freezes with high ipf
My game freezes when I am in battle!
The game is "off"
Time Freezes then ram increses till my pc freezes
Game freezes after a while every time I load the save
#2

Merry Christmas Kobold :slightly_smiling_face:

Some questions: the hearthlings stuck in the middle of nowhere, did you dispatch them by some quest from the rabbits? Or are they just stuck on top of some building / inside a cave?

Could you upload the savefile?

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
    1. Right click the folder (should be named a long set of numbers).
    2. Left click on Send to in the menu that appears.
    3. Left click on `Compressed (Zipped) folder).
    4. (Optional) Rename the folder to something different than the default set of numbers.
  3. Upload the save.
    1. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
    2. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

#3

HI and Merry Christmas Relyss,

Concerning your question: No rabbit related quest for sure (even though the rabbit quest is running already). I think I did put a move marker (the green flag?) for them a while ago, as these belong to a patrol, however I think they did never move there. If I click on either Amelia Baub or Alton Nonac I am basically stuck in blackness and the game is messed up. Playing around with debug tools also dos not give ANY coordinates for them, e.g., as mentioned before, inspecting the “mob” component of the heartling “object” shows that it is totally empty.

1545689990678.zip (7.6 MB)

Thank you for looking into this!

Kobold

P.S. I also have some slightly earlier saves from that day, where everything is still ok, if something like that might help.


#4

Ok,

not funny. This time it is the cleric. Will now try to see whether making my patrol defend a certain area will stop this. Fortunately I will only lose about 15 minutes playtime.

auto_save.zip (9.2 MB)

Best

Kobold

Addendum: Ok, so far havin them defend town center seems to work… grrr.


#5

Ok,

keeping them at a fixed Location seems to do the trick for now.

Something else:

UI error (Reload UI works)

release-947 (x64)
Uncaught TypeError: Cannot read property ‘property’ of undefined
TypeError: Cannot read property ‘property’ of undefined
at Object.l.property (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:8:6356)
at j (http://radiant/radiant/js/external/jquery-2.1.4.min.js:2:26925)
at Object.add [as progress] (http://radiant/radiant/js/external/jquery-2.1.4.min.js:2:27234)
at Object. (http://radiant/radiant/js/radiant/trace.js:201:20)
at Function.each (http://radiant/radiant/js/external/jquery-2.1.4.min.js:2:2936)
at SimpleClass._expand_object_properties (http://radiant/radiant/js/radiant/trace.js:170:12)
at SimpleClass._expand_object (http://radiant/radiant/js/radiant/trace.js:93:25)
at Object. (http://radiant/radiant/js/radiant/trace.js:120:58)
at j (http://radiant/radiant/js/external/jquery-2.1.4.min.js:2:26925)
at Object.fireWith [as notifyWith] (http://radiant/radiant/js/external/jquery-2.1.4.min.js:2:27738)

Best regards

Kobold


Time Freezes then ram increses till my pc freezes
#6

I ran the save file. It seems to be a replica issue of Time Freezes then ram increses till my pc freezes
Even when resolving the issue and teleporting entities 885721 and 5327548; the issue replicated it’s self during the next ‘game day’. Seems to be an issue with patrolling. When turning off the ‘job’ check, the issue does not replicate. Looks to be caused by ACE. When ACE items were removed and the mod disabled, it does not return


#7

Dear Nikia,

thanks for looking into this. I have a small BUT: I did not turn ACE on, however, most interestingly, this issue only cropped up after ACE was installed, i.e., I started the game on that day with no “ACE” in the starting menu, had the crash issue first and after restarting ACE was in the start menu.

However, I again want to stress: ACE is NOT activated for me! Also my PC does not crash only the game.

And for all others: Just making the patrol defend a certain location solved the problem completely. I know this is probably not really feasible for games with lots of enemies cropping up.

Best regards

Kobold

P.S: I also find it interesting that teleporting seems to work for you. For me any interaction with one of those units invariably crashes the game, the only thing which worked was “destroy_immediately” in the console, even the normal “destroy” command crashes the game.


#8

No worries Kobold. Paul and I spoke in the other thread, that I linked, and it may be an issue with how Stonehearth integrated the ACE mod into the game files. Whether or not you have it active.

What I mean by teleporting is that I wait for the game to lag out / blackscreen / crash, go and look at the stonehearth.log file after the game is closed out, and find out which hearthling caused the problem. Then, I load the game back up, and before even pressing play, I do CTRL+C and type in teleport 29128723 but I replace that number with the hearthling that caused the problem.

This is just a temp fix and needs to be done every time it happens. It does seem to be a repeating issue around your chests area. I even moved the chests to the open space to the left and it did not resolve the issue, because it repeated it’s self shortly afterwards.


#9

Hi Kobold! I had the same issue and I wasn’t able to do the teleport or destroy before the game was going. I started my game hit 1 to pause it then I did ctrl + c, teleport [entity id] then I clicked on a spot by me hearth. I had to do it twice but I got my footman back!


#10

Summary: I have a town with 24 heartlings, yesterday I saved the game for the last time, after that I started to build a ranch and cut some trees. After a while the game freezed and I closed the process. Every time I start the save the problem still come up after few minutes.

Steps to reproduce:

  1. Load the save.
  2. Try to build something or simply wait a few minutes.

Expected Results: The game shouldn’t freezes.

Actual Results: The game freezes.

Notes: I saw an high percentage of “ipf” in the usage bar. I do not know if it has to do with it, but usually “idle” was the higher process.

Attachments: https://drive.google.com/open?id=1ESpk2i0OVcUdYB4dDH88N1RmG6P58xZY
I also made a video showing the problem: https://youtu.be/n-ZTXrLvwME

Version Number and Mods in use: I’m running Stonehearth v1.1.0 and have few additional template mods.

System Information: Windows 10 Home 64 | Intel Core i7 8750H | 16GB System memory | NVIDIA GeForce GTX 1050 Ti


#11

Ipf is the path finding for the items.
Since i don’t have access to your link where i am, i can only guess you have too many items to haul at the same time.

If you look around here there are a subject about that a few day ago…

EDIT : Here it is

In the worst case someone may repair your save.


#12

I tried to pause all the heartling’s job except hauling and they stay idle doing nothing. Yeah I think I have too many items around the map.


#13

It seems to be a similar problem than in the linked thread. Thank you so much for the savefile, @Lorenzo97 !

There are a couple combat units at 0,0,0 in your map. I’ve tried teleporting them but bad things happened anyway. :disappointed_relieved:

I’ll keep looking into this.


#14

Thank you so much, I’ll be wait :slight_smile:


#15

Ok here’s a patched savefile: 1546625744964.zip (8.4 MB)

Still can’t figure out where’s the source of the problem. The values might have been saved wrongly :thinking:

Do you remember if your archer and footman were missing before you saved?


#16

No, but they fought against some enemies and a hearthling was almost dead.

Thank you :slight_smile:.
If you need anything else to understand the problem I’m here.


#17

I do not know why this error occurs.
But when choosing to check the notification:
Lee Rayene can’t find food
The whole world is repainted gray and the buttons for selecting the save and setting menu are blocked.
This is not the first time for me.
Usually this error occurs when playing on one card for more than a year of playing time …
No alerts appear during this.
No error notifications appear.
The game works until you select a notification.

The latest version of the game on Steam.

T8A7DyO3ivM

a725YSIhgl4

From mods:
warehouse improvement
map size 64x64


#18

I would wonder if Warehouse Improvement isn’t causing this issue, I know issues with mods have caused very similar visual issues.

I also found this :slightly_smiling_face:


#19

Thanks!
I will try to use this advice
but still there is a problem and I hope the developers will fix it in the near future


#20

That Hearthling that is selected in the 2nd screen just needs to be teleported. Go to your Stonehearth.log file in this folder: C:\Program Files (x86)\Steam\steamapps\common\Stonehearth

When you open up the stonehearth.log file, you’ll see that Lee Rayne has caused multiple errors in the log. Next to their name will be an ‘Entity ID Number’. Copy that number.

Launch up Stonehearth, load the save file, press CTRL+C to bring up the console. Type in:
teleport 19827312
(replace my 19827312 with the number of your hearthling’s entity id)
Press enter and you’ll get a red flag banner for a cursor. Left click your cursor anywhere on the ground. Press the play button for the villager to teleport. Save your game immediately on a New Save.

This is currently the only way to resolve that issue as of right now @Cheochenit