[A20 r699 (x64)] Hearthling Location Bug?

So at some point a hearthling Archer fell into the water and was there long enough to starve.
I only noticed this because my cleric occasionally walked over to heal him from the water ledge.
After building a ladder, the hearthling refuses to move and continues to sleep.
So then I tried teleport, reset, reset_location, ai_reconsider, make_full and finally I changed them back to a worker.
I tried refreshing my UI with F5 because one of these caused a bug with it.
I don’t know of a command that is like add_buff stonehearth:buffs:wake up! :scream:
Nothing worked.
Am I forced to go back to a previous save or is there something else that can fix this in my current game?

1485314626390.rar (7.7 MB)

Well I sort of found a solution. Just delete this guy and add a new hearthling and promote them back to archer 6 and set their stats to be the same. Although I still haven’t figured out how to make the new hearthling level 6

An earlier save before all those attempts would have been better, I think :sweat:
He’s behaving as if he was still bed ridden, although he seems to have finished the recuperation state already.

It’s as if he was dropped there while rescuing him or something. Wait, did you move the bed where he was resting, perhaps? But that doesn’t explain why he was in the water :thinking:

This reminds me of some recent reports about sudden deaths after rescuing.

1484782763400.rar (7.2 MB)
well here is my earlier save, but I don’t think it will help, somehow this all happened during this play session. yeah I was upgrading my beds to fine ones, and there was also a massive fight were I had like 5 hearthlings that needed to be rescued and only like 3 free beds, so I was constantly picking them up.

I wish the game had like 5 backups of previous auto-saves, because I might have had it, but maybe not, this wasn’t very long after I started to play and I was using high speeds

1 Like

Wow, this is so weird.
Thanks for that savefile, it was very useful!
Look at this:

The knight is forcibly rescuing the archer, and the archer ends up bed ridden and teleports himself to the water because he was following a different path and ends up underground, thus teleporting to the nearest terrain layer.

I can’t find anyone to be rescued in the savefile, but some combat units are definitely performing rescues :confused:


oh, wow! haha :jubilant:

I thought something strange like that could have happened. glad to help, hope this is fixed sooner now :merry: