Can't place down town flag?

Alright… I cant post a picture because its hard to show it… It doesn’t show any error… But when I click the town flag banner to place my settlement, and I click again, it cancels the flag placement and I’m back at Square 1… I can’t continue because of this… At first I thought it was my mods so I uninstalled them and got a fresh install of Stonehearth. But it continued to do this… I don’t know if I forgot a command or if my controls have been switched somehow. But id love to get help asap.

Welcome to the forum, @Thomas_Krankvich.
It seems you were playing fine the past days, according to your other posts.

Are you playing with the latest version, then?

This is hard to reproduce… If I click the banner and when I want to place it I right-click, it sure goes back… But you’re telling that you can’t place it in any way :sweat:

Which were the places that you’ve tried to place the banner on?
Which faction and biome did you choose?

1 Like

It does the same thing as if I rightclick when leftclicking. I click the bottom banner, try to find a place to set it down, and when I left click it cancels it… :L And yes I’m playing with the latest version.

1 Like

I did Acendency, Forest biome. And places near mountains and near a lot of trees.

1 Like

If you’re running by Steam, can you check the integrity of the game caché?
(Right-click Stonehearth on your library, click on Properties, go to the Local Files tab and you’ll see a button for it).

I can… But I just got a fresh install of the game so I don’t think that would be the problem…

All files were successfully validated. Trying the game now.

Nope. Still having the issue. I don’t know if this will help but I’m on Release 489 (x64)…

It’s just one of those unlucky things…

When you did the reinstall, did you delete completely the Stonehearth folder or did you remove it via Steam?

Remove via steam. Should I delete the whole folder?

Yes, you can try removing manually the folder and redownloading it (I don’t know if you can do it with Steam opened, I’d close it just in case).

Anyway I’m going to page Albert and yshan to take a look at this weird issue, but they’re still on deserved holidays, so I’m not sure when will they read it.

Alright thanks <3 Much love

HEY IT WORKED :O! It seemed that the game had something in the folder that was causing issues? Maybe a file the update caused a weird bug that rarely makes people not be able to place their town banners down? I don’t know… But after deleting the local data and deleting the folder, I re-downloaded the game and started it and now I’m able to play again! :smiley:


I’m glad it worked :smile:
Sometimes Steam doesn’t delete all the files, and there might be something corrupted left on the folder.