[Res] Help! a bug with mods or somthing!

When i make a new town all seems fine until i place my banner… Thats when it happends… As normal people spawn but only thier heads spawn!!!

Here is the bug code thingy:
release-453 (x64)
stonehearth/components/ai/ai_component.luac:7: assertion failed!
stack traceback:
radiant/modules/events.luac:68: in function <radiant/modules/events.luac:65>
[C]: in function 'assert’
stonehearth/components/ai/ai_component.luac:7: in function 'obj’
radiant/modules/events.luac:15: in function 'self’
radiant/modules/events.luac:80: in function <radiant/modules/events.luac:78>
[C]: in function 'xpcall’
radiant/modules/events.luac:78: in function <radiant/modules/events.luac:70>
[C]: in function 'create_entity’
radiant/modules/entities.luac:9: in function ‘create_entity’
…h/services/server/population/population_faction.luac:59: in function ‘create_new_citizen’
…ices/server/game_creation/game_creation_service.luac:96: in function ‘_generate_citizen’
…ices/server/game_creation/game_creation_service.luac:77: in function <…ices/server/game_creation/game_creation_service.luac:63>

@LukeHearth22, this seems very similar to [NaB][Dev 2513] Error message in map overview and mini Hearthlings. Did you by any chance install a mod and/or try to change some of the Stonehearth files? The solution in the linked thread was to delete the game and reinstall it without any mods.

I did use mods.

I’M USING STEAM. I dont wanna loose what i payed for

[quote=“LukeHearth22, post:3, topic:16976”]
I did use mods.
[/quote]hmm… that could be the cause then, first of all i would suggest removing all the mods you’re using, and if that doesnt fix the problem then i would suggest re-installing,

dont worry, if you un-install something from steam it remains in your library, you just have to re-install it to play the game again.

i would suggest doing a clean install, by manually removing the stonehearth folder, rather then just letting steam take care of it, as sometimes steam doesnt actually clear everything out.

how do i uninstall it then???

in your steam library right click stonehearth, select “remove local content”, this will uninstall the game. then to re-install its just click the little “install” button where the “play” button normally is.

nvm! I figured it out! It was all one of the mods but now i fixed it. Thanks for the help anyways :smile:

1 Like

so it works now? which mod was the problem?

the zulser mod was the problem

1 Like