Building a building wont complete


Whilst playing Stonehearth, I builded a custom building. It worked well. I then saved the building and built a duplicate next to the first one. The building is pretty much done, except one thing. They won’t fit the door. I tried to demolish the building and build it over. Still stuck on the door.

Really, I don’t know how to reproduce it.

Picture of the cottage and the duplicate with a bug. On the picture you can see that the first one has been built, yet the second won’t build

the newest version - alpha 19 I assume (Bug started on 21-11-2016)

Windows 10,
New PC, equals new processor (i7) and mostly everything is new - except a 2 year old GTX 970 4GB MSI Graphics Card

I hope this is enough information - if not I will be happy to answer any question you might have!

Welcome to the forum, @Jakob_Jensen :slight_smile:

Some questions:

  • The fences are part of the building or they were placed afterwards?
  • Did you place anything that touched the bugged building while it was being built?

Could you upload the savefile so that we can take a look at it?

To upload a save, locate the folder in
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

I placed beds and tables inside the first time it was being built. Not the second time though.
The fences were placed after the building.

I tried building it a third time. This time i moved the position. Also, when placing the building, I deleted the door, and placed it again. Now it works. Unfortunately, That also means I probably cannot upload the save :frowning:
I JUST did it, and i haven’t saved yet, so maybe i can save on another file and give the old save to you. I will try, and post another post with the file if I succeed.

1 Like

My saved_games folder where the bug has been "saved"

1 Like

Ok, now I can see clearly what happened.

Do you see the ladders on top of the pile of logs and the fence?
Those are unreachable. If you manually build some ladders to allow hearthlings to reach there, they will remove them and start tearing down the remaining scaffolding, and will place the door eventually.

We need a better way of alerting the users when these scaffolding issues happen, or even better, prevent them from happening. Thanks for reporting anyway!


No problem! Happy bug hunting :slight_smile:

ZOMG!1! Thank you so bloody much @Relyss!!! For 3 days now I’ve been fighting this damn game to try and get the second story of my building to build, all with it freezing at the doors. I even went as far as removing the furniture from the design. But after reading this, and placing ladders EVERYWHERE there might be a problem, they finally built it.



1 Like

Since I see people have problems with this a lot, I wrote up a quick guide to help find these troublesome ladders.

1 Like