Bug - Building will not finish

I have a custom 2 storey building that cannot be finish due the doors not being put in. The windows have been put in. I think that it is just the doors however there is still scafolding around the building so intially I thought it was a brick missing but I cannot see any missing. It might be due to some of the doors leading to open air on the 1st floor but none of the ground floor doors are put in either. I planned to connect more buildings at some point which is why the door leads to open air.

They can reach the inside of the second flor? If not, just add a temp ladder to it, they probably are waiting for one of the items there to be placed.

And what about the roof? Is there something they want to do there? If so, add another temp ladder leading to the top.

Yes they have built the stairs inside

If you want, send the save file, so we can check if there is anything we are missing.

I have tried to upload as a .rar as an attahment but it says “Sorry, new users can not upload attachments.” Is there another way to send the files?

You can for example upload to an online storage and paste a link to access it here.


Hopefully this works
message back to confirm either way

Love the game thou :smile:

Sorry, I didn’t find why the build stopped and couldn’t find a way to resume it either.
Though, trying to build a second one (saving its template and placing it again) worked fine.

Sometimes I think buildings won’t build because of the way they’re cut up. If you move them or rotate them they’ll break into chunks differently and thus not be consistent in the way your Hearthlings will build them.

@Dave I just uploaded the file. On the second floor remove the ladders on the inside at the corners. They should finish tearin’ down the scaffolding and add the doors. Not quite sure what the issue there was unless it was somehow blocking scaffolding that was next in line to be torn down.