Ehmm i thought this was nearly fixed?

What i need to say here is that my Hearthlings are really building the easiest building EVER but… They are not building it -.-!

1 Like

Oh wait a sec, it is fixed a restart helped but now i started the game again and see if it was fixed if getted a sort of scaffholding bug? Here it is:
develop-3002 (x64)
stonehearth/components/scaffolding/scaffolding.lua:228: attempt to index field ‘_blueprint’ (a nil value)
stack traceback:
[C]: ?
stonehearth/components/scaffolding/scaffolding.lua:228: in function 'get_blueprint_region’
stonehearth/components/scaffolding/scaffolding.lua:213: in function 'recalculate_scaffolding_blueprint’
stonehearth/components/scaffolding/scaffolding.lua:123: in function '_add_region_trace’
stonehearth/components/scaffolding/scaffolding.lua:99: in function <stonehearth/components/scaffolding/scaffolding.lua:96>

I get them too, buildings that they would easily build in 16 they act like I’m asking them to build the Hubble telescope

I’ve had this bug too, it’s a problem with the scaffolding not being raised so the Hearthlings cannot reach the desired height to continue building. Reloading does indeed reset the calculation for where scaffolding should be so they can continue working, but this only works once and when the hearthlings stop building you have to reload again.

It’s not that your hearthlings fail to build your design, but they fail to correctly adjust the scaffolding so they can’t continue

1 Like

Can confirm, had this as well. Happens also on completed building were scaffolding needs to be taken down.

Edit: At this point I can’t build anything complex anymore. Everything I tried to build that isn’t box-shaped, they either won’t complete or stop taking down the scafolding

Right, unfortunately unstable alpha 17 is quite unplayable. I’m like opening steams every few hours waiting for an update!

I have a few questions that would help me better understand what issues you are running into.
What specifically is the building you are trying to build? Please upload the template for the building and the save that the building is failing on.
Does the building fail to build even on a brand new save?

As always, the unstable build is for brand new tip of development speed updates, and is meant for us to find bugs and squash them before the new alpha is released to the general public. So there might be some hitches in building correctness until we get it to a good state. Any building templates and saves would greatly help us in getting these bugs resolved. So thank you all for playing and reporting issues! :smile:

the building i want to build is one of the tier 2 buildings,
And this buildings:

And i got a sort of scaffholding bug because they dont delete the scaffholding :(.
With your second question i dont really understand you sorry.


The last two buildings I tried to build, they wouldn’t take down the scaffolding. Reloading didn’t help.

I have build the tower already, as you can see in the save , they won’t finish removing the scaffolding. I did need to place some ladders so they could reach it, but that should not impact their ability to remove it.

The second building, it is the wall below the surface. I managed to complete it in a previous attempt, but there they wouldn’t remove the scaffolding. In this one they won’t even complete it.

Templates: (14.5 KB) (17.9 KB)