Bugged talismans/furniture

Hoe Stockpile Move Bug

Hearthlings refuse to move, destroy or loot a hoe that was placed in a stockpile which was removed.
Placing a new stockpile elsewhere does not prompt idle Hearthlings to move the hoe, sparkles on hoe
also dissapear.
The Town Hall Inventory Tab however shows the hoe as normal but no matter what commands are used the
hoe persists to be immovable.
Even promoting a Hearthling does not seem to do the trick, they stand idle. The only way to allow the worker to
be promoted is by crafting a completely new hoe.
A Screenshot Of the Offending Hoe :stuck_out_tongue:

Alpha 11 Release -453 (x64)

1 Like

After some testing I have found that this is the case with multiple different tools, for some reason occasionally tools will bug out disallowing Hearthling’s to be promoted. The tools cannot be moved, stored and they are not recognized as an interact-able item. This has happened with both a Hoe and a Sword and I am inclined to believe it not to be tool specific. It could be the promotion mechanic not fully removing the tool after a promotion??

I have noticed similar behavior with a hoe as well. It seems to also be persistent through save, so below is a save file where there is a bugged hoe:
https://onedrive.live.com/redir?resid=C924F899663F3703!137866&authkey=!ANCggwLHtWcUtH8&ithint=file%2Czip

Steps to reproduce from the save:
Notice at the large stockpile at the bottom of the hill, there are two hoes in the stockpile.
Promote two more hearthlings to be a farmer.
One hearthling will pick up a hoe and become a farmer.
The other hearthling will never pick up the other hoe and will continue on as a worker.

No matter who you try to promote to a farmer, the last hoe in the stockpile will not get picked up.

1 Like

had this happen with a fence today, made a separate thread in case someone else notices it with fences but pretty sure it was the same thing, showed up in stockpiles and inventory but could not move or place down. It was completely stuck in ghost form.

Come to think of it, I have noticed other stockpile items become useless as well. It only becomes noticeable when dwindling down to the last few pieces of a resource and the crafters/workers won’t make use of them. Wish there was a way to consistently reproduce this bug.

1 Like

i have this great little hearthling. she’s brave, and strong and completely stupid. (sorry Orsa Mont, but its true…) i tell her to be a stone mason. BAM!! she’s a stone mason. i tell her to be a farmer. BAM! she’s a farmer. i tell her to be a foot soldier. BAM! nothing happens. i promoted Miss Mont a fair dozen times. nothing.

i gave up and tried promoting anyone else to being a soldier because of Miss Mont’s stubborn streak (perhaps your smarter than i gave you credit for…) and nobody else would promote either.

i saved the game, and reloaded. the problem persisted.

i exited the game to desktop, started the game again, and reloaded the kingdom of ‘Error Bait’. the problem still persisted! damn and blast!

i didn’t give up there, i made a new wooden sword. low and behold, Miss Mont ran up and claimed her weapon as if it was her birthright. damn… funny thing about the sword that would not promote anybody to its profession… i put it in the queue when i didn’t have the carpenters workbench made yet. i wanted it to be the first thing i made.

earlier i also queued up a forge when i didn’t have the items. the forge would not place. perhaps these two are related? maybe its just coincidence.

hmm… perhaps related to this bug,

though its interesting with the fact its only items queued before you have the workbench… i’ll page @yshan as she might want to take a look at this…

1 Like

the sparkles on the wooden sword are not gone, attempting to move it to another pile.

the sword will not move. good call 8BitCrab

looking into duplicating this bug on a new save.

tried twice to reproduce this. no luck. the town of error bait and i shall continue with doing many things in a random order in the hopes that the universe will come crashing down on us. good luck.

2 Likes

reproduced. but not in the way i would have imagined.

appears to have nothing to do with the queue. its almost like the item is aging out or something.

i have a save file for examination if someone would like to take a look at it, but i cant post it here due to size restrictions. any takers and desired delivery methods?

screenshot of me trying to delete the item using the clear button.

symptoms recap.
item does not promote to footsoldier.
item is not movable
item is not removable by normal means.

how to replicate bug:
i have no idea. make a sword and wait to use it for 10 minutes or so?

im sure that TR will want to take a look at it, paging @sdee @yshan @Albert,

[quote=“wrath_lamp, post:4, topic:16790”]
any takers and desired delivery methods?
[/quote]well seeing as its too large for the discourse you always could just upload it to a file sharing site such as googledrive or dropbox (just to name a few), and then provide us with the download link.

1 Like

@wrath_lamp, I can’t do anything with the save file, but @Albert, @Ponder, or @sdee might be able to. Typically save files are uploaded by being saved to Dropbox, Google Drive, or similar cloud service, and then a link is posted here in discourse.

Edit: Sorry @8BitCrab, we must have been typing at the same time, didn’t mean to duplicate you…:wink:

1 Like

no worry’s, i get ninja’d all the time, though i must admit you explained that much better then me :wink:

i messed up my saves folder >.< now i have no saves to give to anybody. errortopia, you were so new, so fresh. you left us too soon.

1 Like

i do had a similar issue with a mean bed, that is clearly visible in stockpile. yet i cant interact with. i mean i can in ui, click and place it and it is shown in inventory and furniture place menu. but the hearthlings act as if it wouldnt be there. so i cant use it for a comfy bed and it will not be placed either.
i thin this might be the same bug.
an item in stockpile simply ceases to exist for your hearthlings. even though it’s clearly there.

1 Like

have you tried removing the stockpile and then placing it back down?

no i have not. when the bug presents itself again, i will try that. this bug is the same as the other one that you linked to. same symptoms, and i’m betting the same root cause. has happened to other objects as well.

i vote for merge with the other thread

1 Like

okay, just a moment…

edit: and merged :smile: i also updated the title.

We’d like to know more from those of you who are experiencing this issue. Is it always the case that the uncooperative item in question was crafted well before you tried to use it (IOW, is the problem with “older” items or fresh ones or both)?

3 Likes

The item is always old. at least 15 minutes old in my case. i have an example of such an item. two of them actualy… i have a tree in a box somewhere that refuses to plant. i have a rug somewhere that refuses to be placed, moved, or anything else.

Save: Free File Hosting - Online Storage; Upload Mp3, Videos, Music. Backup Files

Error log: Free File Hosting - Online Storage; Upload Mp3, Videos, Music. Backup Files

the rug is next to the standard and the campfire, right next to it is a rug waiting to be picked up.

another thing with the rugs… every time i try to surround my campfire with rugs (cause my hearthlings are big pimpin at the campfire you see…) a worker will come and put them in a stockpile or a crate.

another error in this save. you will find a road intersection missing 4 pieces. i removed those pieces because i had an overlap in roads and that section was off color. so i told my hearthlings to get rid of said stones. they did. but now i cannot place anything where those road bits were. food for thought.

another thing you may notice is the music. whenever my … ‘neighbors’ come into camera view, or move close to my base, the battle music starts. i’m ignoring them this round, but the battle music starts and stops so often it may as well be the crankshaft in a car engine going up and down. we’re going in TPS for this measurement. ‘themes per second’

well… i er… i didnt expect this post to go quite this direction… er. um… enjoy?

thanks 8bit :grinning:

wow. i just looked at that error log. those goblins really hate being on the other side of an impossible wall… last time this happened i was taking care of goblins as they spawned.

let me know if there is something else i can do for you.