Bug: Footmen cannot decide between fighting and eating

Hello everyone,

I’m new to this community, so I take the opportunity of this first post to greet everyone :smile:
I tried looking through the forum and did not see this problem anywhere, I’m really sorry if that’s a repost.

I created a party with both my footmen to attack the goblin village nearby. Everything seemed to go according to plan, until I realised one of the goblins was stuck just above their fire pit. My footmen were ignoring it. After trying a few times to have them kill that last goblin, I gave up, removed both footmen from the party and disbanded it.
And that’s when the crazy dance started ^^ They got stuck halfway between my village and the goblin camp, going a few steps one way, then another. Everytime they tried to go to the goblin camp, the fighting music started, again and again, playing some kind of neverending (and pretty annoying) canon.

I tried lots of things (putting them back in a party and giving them orders, having all the hearthlings on defense mode, etc.), nothing worked. They resumed their dance after a quick nap.

I wanted to see if quitting, then reloading the game would work, but everything crashed before I could save (and take a screenshot, I’m sorry…).

Steps to reproduce : it never happened again

Expected results : when disbanding the party, the footmen should go back to the village.

Actual result : they got stuck halfway going a few steps back and forth

Version and mods : I’m running Humble Bundle’s Alpha 9, no mods

System : Win 8 64bits, CPU Inte i5-3570, 8 Go RAM and GeForce GTX 660 Ti

hey there @Rachne … welcome aboard! :smile:

you didn’t by any chance notice an error message at any point, did you? something similar to this one perhaps?

No, nothing, disbanding went fine (at first…). I had read this topic before, so I had removed the footmen one by one before disbanding the unit.

and thanx for the welcome :slight_smile:

1 Like

Does it sound more like this one?


(4th paragraph, right before the first screenshot)

Exactly! Argh, sorry, I missed this thread. Thank you very much for finding it.

It sounds like a variant on my post. I didn’t have the music going on over and over when they got stuck. In the end I think I just had to wait until the goblin got off the fireplace and attacked, at which point my soldiers slaughtered the poor goblin and proceeded to obliterate the encampment.
Your problem sounds more like its bugged on the part where the goblin wants to get off the fire pit, but can’t…
On which note, I think that the main deviating feature seems to be that you removed your soldiers from the party. Which could have invoked the battle music bug.

If you encounter the issue again, the best option for the time being is just to wait for the goblin to get off the fire pit in his own time. (i.e. wait for it to raid your village)

P.S. Welcome to Hearthling Society! :smile:

Not sure if anyone mentioned this yet but you can click on the goblins firepit and “Undeploy” it which drops the goblin down and the soldiers should then proceed to kill it and go back to business. I had this issue yesterday and that is how I fixed it.

Squargle

1 Like

@Wuelfe , @Squargle : thank you for your answers, I will try everything you advise should that little bug make a comeback.

P.S: I’m thrilled that the game runs smoothly on 64 bits systems now! It used to crash everytime I would try and play, but thanks to the Alpha 9, I can finally discover the game and look forward to more features!

1 Like