Assertion failed while loading save game. (wine/linux)


I’m playing Stonhearth via Wine (1.7.55-staging) as I’m on Linux (Fedora 20). The game starts fine, but after some unspecific time the game will eventually crash. (Saving suddenly goes superfast, but nothing is writen. Saving is then broken). Restarting the game and loading the last save sometimes works. But sooner or later it will start failing to load with the error message:

Assertion Failed: c > 0 && c < ReadBufferSize(C:\rb\ihome\root\SH-OB0-BUILD\stonehearth\source\include\protocol.h:138)

Every time I start a new game it seems to end like this. I just tried loading again my old save and on first try it crashed at 50% of the loading screen (same error) while the second crash (more common) was right after 100% when my village started showing up for the first time. It is always the same Assertion Failed message.

I uploaded two screenshots, the log and crash.dmp to this place.

It seems I’m the only one to whom this happens. Any one have an idea what could cause this? Any help appriciated.

Hey there @meikomeik, welcome to the Discourse! First, let me preface this with the following: Linux is not currently supported, and while we will do our best to help, there should be no expectations that we will be able to get it working. Linux support is planned once the game is out of Beta.

That being said, I have not seen that error before, nor do I currently have Fedora on my system. I am currently downloading Fedora which I will install in a VM and test.

A few questions: how did you install Stonehearth? Did you download via Steam and use one of the guides here on the Discourse, or get the zip from Humble? Did this work in previous versions of the game, or is this your first attempt to install this?

Hi Jomaxro,

I used PlayOnLinux to install Steam first. I already have a few game that run in there. From there I installed and created a shortcut to Stonehearth and have been playing like that since December.
In December (Alpha 13 I think) had a lot of problems for me. Most of them are now gone.
The game got much more stable with Alpha 14. As I said, was able to play for more than an hour without bigger issues. (This was new). Sometimes a crash but I could at least load the game. But for my 2-3 tries it always ended up in exactly this Assertion Failed error after a longer play session. (Crash while loading the save game).

I recently found the trick on how to download Stonehearth from inside the Linix version of Steam. I could try to setup a clean new Wineprefix (in Playonlinux) and just copy the data in there. Might try this tonight when I get home. (in 9 hours from now).

I tried different versions of Wine: Mainly the 1.9.2, 1.7.15 and 1.7.55-staging. I didn’t have any impact for loading the game (same result).

If there is anything else I can try, please advise.

Versions and Mods:

Stonehearth version 0.14.0 release 523 (32bit) without any mods.

Today I created a new, empty wineprefix via playonliux and copied the game from my linux steam account. Started playing around 20:00 and all worked out nicely for 2 hours. Great game. But then it crashed. I uploaded files to:

So the first crash after a long play session was this one:
1stcrash_20160216_22:33:27.png with 1stcrash_backtrace.txt, 1stcrash_crash.dmp, 1stcrash_stonehearth.log

The backtace indicates something with dsound. If it was sound related then this was probably some kind of edge case?! Sound on linux is also not the cleanest thing to exist. Well, don’t know.

So then I tried to load the latest save. I found out that the auto_save, and the last save that I did manually, were both empty directorys. :frowning:
Here is a list of all the save files that were made during my play.

drwxrwxr-x. 2 meik meik 4096 16. Feb 19:58 1455649129221
drwxrwxr-x. 2 meik meik 4096 16. Feb 20:02 1455649374394
drwxrwxr-x. 2 meik meik 4096 16. Feb 20:16 1455650164819
drwxrwxr-x. 2 meik meik 4096 16. Feb 20:30 1455651049473
drwxrwxr-x. 2 meik meik 4096 16. Feb 20:35 1455651310971
drwxrwxr-x. 2 meik meik 4096 16. Feb 21:08 1455653307012
drwxrwxr-x. 2 meik meik 4096 16. Feb 21:34 1455654876845
drwxrwxr-x. 2 meik meik 4096 16. Feb 21:40 1455655248731
drwxrwxr-x. 2 meik meik 4096 16. Feb 21:55 1455656114843
drwxrwxr-x. 2 meik meik 4096 16. Feb 22:07 1455656872440
drwxrwxr-x. 2 meik meik 4096 16. Feb 22:24 1455657871994
drwxrwxr-x. 2 meik meik 4096 16. Feb 22:27 auto_save

The first two (1455649129221 and 1455649374394) load just fine.
For all others I get my: Assertion failed.
See: second_onload_crash_20160216_22%3a42%3a12.png

I uploaded all my saved games. Not sure if it helps you. I would be interested if they work for someone else, or if they provoke the same crash. Is this just me?!

I just quickly tried release-524 for my save file as there seems to be a bugfix for loading files.
Unfortunately, I get still the same result. :frowning:

Thanks for the update. I have not gotten the chance to install Fedora yet…unfortunately it might not happen until the weekend looking at my calendar for the week, sorry! I will look into this, can’t promise it will be speedy…

Hi Jomaxro,
were you able to load my save game on a Windows PC? I don’t have access to one and am mainly wondering if the save files are corrupted (reproducible not loadable) or if they are fine on other platforms. This one would really interest me.

Also, I could upload my complete wineprefix directory (1GB) if it would help debugging things. Tell me if you’d like to have it.

Beside these things, I’m running out of ideas on what else to try. Will wait patiently for any update here.

Have a nice day