Assertion error on startup, can't play stonehearth :(

Everytime i try to start a game on stonehearth, (just got the game so don’t have any saved files), it gives an assertion error and i have to click ok and then the game quits out. I’ve tried so many things, changing screen resolution, updating graphics card, checking drivers, you name it, I’ve probably done it. someone please help, i really would like to play this game…

I’m on windows 7
Toshiba laptop, model: Satellite L745, processor: Intel Core i3-2310M CPU @ 2.10GHz
Stonehearth Alpha 15/16, no mods
video card just says Intel HD Graphics Family

this is the error message i get everytime
Assertion Failed: status == GL_FRAMEBUFFER_COMPLETE_EXT(C:\rb\ihome\root\SH-OB-BUILD\stonehearth\source\horde3d\Source\Horde3DEngine\egRendererBase.cpp:1266)

hey there @Tighr, welcome to the discourse :smile:

sorry to hear your game is crashing, lets see if we can figure out the cause and get it working.

first off, have you looked through this thread,

http://discourse.stonehearth.net/t/crashing-on-start-read-this-updated-november-29/13297?u=8bitcrab

1 Like

Yea, that’s the first place I went, tried everything on that page and another for the past two days and looked up some others and none have worked so far

alright, could you attempt to start up the game and have it crash, then go to the stonehearth folder and locate the stonehearth.log and crash.dmp files and upload them here to the discourse?

if you need additional info on uploading them just ask.

1 Like

I can do that tomorrow when I get home from school, I don’t really know how to do that but I think someone explained it on one of those threads

1 Like

how do i upload my .log and crash.dmp? it’s supposed to be a link right? and is the crash.dmp in the .log file?

i found both but i don’t know how to upload them…

@Tighr, when you reply, click on the arrow button:

Then you can select your files and click on Upload (make sure to wait until it has finished uploading before posting).

1 Like

stonehearth.log (20.5 KB)

crash.dmp (135.3 KB)

1 Like

alright, thanks for uploading those, hopefully they’ll help determine the cause of the crash. i don’t think i can be of much more help, so i’ll page @Albert (one of the devs) for you.

thank you so much! :slight_smile:

I think that this…

sysinfo | Memory Stats: Fatal Exception

miiiight be where things went wrong. I wonder what caused it tho…

Hi! It appears (from the log) that your video card drivers are out of date. Can you make sure you’ve gone to Intel® Driver and Support Assistant and run the utility there to update your graphics card drivers to the latest version? I think that ought to fix the problem. Thanks!

2 Likes

It says that there are no drivers detected for my product…

Yikes! Okay, let’s see. From the Toshiba website, it looks like these are the latest drivers available: http://cdgenp01.csd.toshiba.com/content/support/downloads/tc70115900e.exe

They’re a bit newer than the ones you are currently using, but still quite old (Toshiba has not been certifying new drivers from Intel for this laptop for quite some time, for some reason). It’s very possible that installing these newer drivers might not fix the problem, but it’s definitely worth a shot.

From the log file, I also notice another issue (a “shader compiler” error) that is new for alpha 16. Does this same crashing also happen in alpha 15?

Thanks for your patience!

1 Like

yes it happens in both 15 and 16

that last link you sent me actually let me download and for right now at least, i’m able to actually play stonehearth so thank you so much! :smile: I’ll let you know if anything goes awry

2 Likes

everything is really big in my world and my citizens are tiny, like ants, is that normal? the trapper’s knife is like 5 citizens tall

that would be this bug

http://discourse.stonehearth.net/t/item-size-has-increased-greatly/21413?u=8bitcrab

Fix coming very soon! It’s just one thing after another, isn’t it? :slight_smile: Glad everything’s working!

2 Likes