Alpha 22.5 PC Slowdown


Awesome this fixed the weird system slowdown from previous unstable version :heartbeat: keep up the great work!

Actually it was not fixed it was normal the first time but second time it slowed down my entire pc to the stoneage :confused:

[DEV] Alpha 22.5.2: We Half Moar For You

The problem i have with system going to stone age slow the entire pc starts lag is related to full-screen probably something since 22.5 when you guys made it into full-screen window mode something got wrong.

If i launch it Window Mode there is no system slow down.
If i switch to full-screen while ingame it also gets pc slow down until it goes smooth again 10-20 seconds later


Thanks for adding these details. I haven’t been able to reproduce this yet, after trying on several machines, and haven’t seen any other reports of it. Can you post your DxDiag (Start -> Type “dxdiag” -> Enter -> Save All Information -> upload the file it creates)?


There you go :slight_smile: hope it helps.
This only happens with Alpha 22.5 not with 22


Very confused about this issue tbh.
Today i was playing around a lot with AMD Drivers because they been weird latetly with overclocking so i have not been able to overclock my AMD 7950 for a long time now because weird downclocks.

So just now i installed the latest Beta Driver AMD 17.8.1 and currently there is no slow down with fullscreen when starting a couple of times. Perhaps the other AMD Drivers 17.7.2, 17.4.4, 17.1.1 ect was broken with this latest Stonehearth 22.5.2 will let you guys know if anything changes


Thanks, Banto. Will keep it in mind if this issue is reported again.


This has started to happen to me again recently with the same AMD driver and with the newly updated 17.8.2 again.
No idea really what’s causing it with the latest stonehearth alpha’s.

It only happens with Stonehearth. First time when i launch the game after installing a new graphics driver it launches the expected normal fast way but second time it makes PC sluggish until it starts.

Noticed a process called GameBar that seems to be a part of Windows 10 DVR Game recorder which i dont use and i have disabled everything related to it but it still starts with Stonehearth. Thinking that maybe it has something to do with that thing on Alpha 22.5 but not with Alpha 22.


maybe it could be something related to anti-virus software. i tried AVAST just to see if it would be better than windows defender and it reported crash_reporter.exe as harmful. Maybe Defender is doing this to and causing these slow downs but not reporting it. I know that Windows Defender is a lot more quiet about things compared to those other anti-virus software.


Still exploring the cause. Not sure anymore if it’s the AMD GPU drivers.
I just visited my bios settings and Enabled Intel Speed Step again i run my i7 920 overclocked but i had it disabled.
I also activated ACPI 2.0.

Right now it seems that the problem is gone.
Update later again if anything goes bad again.


and the Slow down is back after the release of the Stable 22.5 :frowning:


maybe it’s Windows Defender controlling for virus everytime. is it not possible for you guys to fix so that it does not count them as a virus?


If you add an exception/exclusion for the game in Windows Defender, does that help with the slowdown? (If not, then it’s not that, either).

I’m afraid there’s little we can do. We sent our files to some of the AV companies so that they would whitelist them before the release in case that helped, but it’s their idea of “suspicious file” what makes them act in the end (for example, some AVs consider files risky if they have been downloaded very few times - which might be true for the first downloads after a release, but not when everyone has downloaded the game). It was very weird when we started having many reports about specific antivirus for some of the builds, since we hadn’t changed anything in the crash reporter (some complained about it). The Stonehearth.exe does change as we develop the game.


Exluded the Stonehearth.exe but that did nothing for this issue.
I have also reinstalled my PC fully with same results.

It only happens after the fullscreen was changed to the new windowed fullscreen.

If i launch game in window mode it does not happen


I still have these slow downs with most drivers later than AMD 16.11.5 Beta and this is the only game it happens with.
I run these old drivers atm because i dont want the slow down but would love to run this years drivers for my graphics card.

Not sure if these issues are for all AMD users or only people with for example AMD 7950 or 7970.
Feels like it’s not everyone considering i don’t see anyone else reporting on this.

This defiantly has something to do with driver, stonehearth and that generation of graphics cards since it started to happen after Stonehearth made the new borderless fullscreen and with later amd drivers.

Launching the game in Window Mode don’t cause these issues.

I also tried playing music while starting with the slow down when launching Stonehearth and the music keeps playing just fine in the background with no lag.

Would love to help in anyway to solve this once and for all :slight_smile: !

Let me know if you need any more information than i have given already


Another strange thing is that when i use DDU “Display Driver Uninstaller” and clean out all old amd drivers and install for example the latest 17.11.1.
First time i launch it’s fast and smooth but any other time after the first time i started the game after clean up and new driver install it takes a long time to start and cursor moves super slow.


I would suggest messing with vsync settings and if that doesn’t fix it at may be a bad OS install. when I had a similar problem a few months back, the OS was the issue. thought it was fine for a long time but this game actually helped me find a problem. it was normal otherwise.


Tried messing with it both through the in game vsync settings on and off but i normally run it off for all games. Tried to change it through AMD’s control panel with same results.

Tried reinstalling PC about 3-4 times does not seem to help anything for me :frowning:
This is also the only game i have these kinds of problems with and it only happens with drivers after AMD 16.11.5 which more than a year old now so prefer not to use it anymore.

With 16.11.5 i don’t get these issues but not sure if its up to AMD to fix it or Radiant. I don’t think AMD will since they have not fixed overclocking ect for the 7xxx series card since they broke it a year ago and its same for 16.11.5 with overclocking it works with this driver also but windows wants to auto update to 17.1 and break it again :confused:

Most games i play don’t run with OpenGL so perhaps this window mode full screen is messy with my graphics card + new AMD drivers.

It worked with drivers that was newer than 16.11.5 until Radiant Released the new window mode fullscreen. In the past it was true full screen and no problems.

Would love to see this fixed but i don’t see many people reporting on this so maybe i’m one of very few.

Monitors Perhaps?
Also been considering if it could be things such as i run 120hz monitors. Maybe that will differ on things. Perhaps another thing could be that i run a multi monitor setup that bugs out with Stonehearths Fullscreen Windowmode.

Running 2 Monitors at 120hz.
Left Monitor 1680x1050 120hz
Main Monitor 1920x1080 120hz

Disconnecting left monitor made starting up the game a tiny bit faster. Mouse cursor was not as extremely slow and laggy when moving it around and it started a tiny bit faster.
Changing from 60hz to 120hz did nothing.
Tried monitor the mhz on the graphics card on start up but i saw nothing weird.
Seems it was 2D clocks until game was at the start menu


Noticed also something strange that Bandicam says the game is running at 1920x1081 in fullscreen.
Not sure if this could cause issues or not but seems strange


you can check fps through steam overlays
also what kind of vsync are you using? triple buffering and fast vsync or is it adaptive or what? some games still have problems with fast and adaptive


i used the ingame vsync setting and tried with AMD to have it forced on and off.
Just the normal old basic vsync.
But i just did a fresh reinstall of pc again just to see if it helps this time or not :slight_smile:

My fps was good before but starting the game in fullscreen took longer than it should and mouse cursor lagged like crazy until the main menu came up.

If i had music playing in the background tho it was unaffected by the “lag” cursor thing tho