Video drivers crash

as I say in the subject Stonehearth always crashes after 10 minutes on my pc

I always get the video drivers crash error…
The first time happened while trying to build a cottage but, after the updates, it happens just 5-10 minutes after starting playing…

i can’t uplead my dxdiag becaused it says that i’m new but my driver are updated…at least based upon my dxdiag


I can see the future…

You have an AMD Graphics Card, and your drivers aren’t actually the latest ones available from Download Drivers.

In all seriousness, please could you give us a little more information, such as the GFX Card make and model and the version number of your driver. I appreciate that you cannot upload your DXDiag at the moment, but providing the above information manually will help us to help you!


Well…i donwloaded the latest driver last week so I think they’re up-to-date…but everything is possible.

However i forgot the cut/paste option…so…here’s my dxdiag

If you don’t want to read everything i’ve got an ATI Radeon HD 4850 (at least i think)

Hey, thanks for getting back to us:

Latest driver is Display Driver ver. released 10/15/2013 available here Legacy

According to your DxDiag your driver is Driver Version: 8.970.100.7000 released 11/16/2012.

Give it a shot, and let us know how you get on :smile:

ok i’ve updated my driver to the latest and after 2 tries i keep crashng.

The first after like 2 minutes…the second one after like 15 minutes…


Do you play other games on your current pc and have similar issues, Or is Stonehearth the only game you play or are other games fine?

Is your graphics card dusty or overheating?

Also check for viruses, and updates for other things, Drivers can crash for a load of reasons, E.G overheating, Not updated (You’ve said you updated the driver so probably not a driver update issue), Pc overloading causing programs to close Ect.

I hope this can help in some way.

1 Like

Stonehearth only is giving me this problem.
Maybe my video card is dusty and yes i’ve got some overheating but other games (e.g. game of dwarves, natural selection 2) give me this kind of problem but only Stonehearth crashes.

I’ve made a defrag and scanned the whole pc but everythinbg is fine.

Throws a pokeball in to the thread

I choose you @not_owen_wilson!

In the meanwhile, if you upload your gfx.log and stonehearth.log it may shed some light. You can find them in your stonehearth folder.

Also, what alpha version are you running?


I just snorted… loudly:blush:

in the event you need the path for your SH files:

Q. Where are my Stonehearth files located?
A. Steam: C:\Program Files (x86)\Steam\SteamApps\common\Stonehearth
A. Humble Bundle: C:\Program Files (x86)\Stonehearth


Steam: C:\Program Files (x86)\Steam\SteamApps\common\Stonehearth

did I butcher the path? or were you just confirming that you were able to locate your SH files? :smile:

sorry i was with my smartphone and the touch came crazy and auto-self replied then crashed :slight_smile:

however my sh files are in steam apps :smiley:

1 Like

Just want to chime in and add that I’ve also had the same problem with any version of Stonehearth to date. Playing through Steam. No other games on my PC have been giving any sort of video trouble.

Also running a Radeon 4800 series card on a Win7 64 PC with the most recent drivers from 2013.

Sometimes I can play for up to 10 minutes, other times it’ll die right after naming my town.

Not able to upload any logs that I’ve gathered (account too new).

happy to hear i’m not the only one with this kind of problem…

1 Like

I have the same problem. I start game without problem but after few minutes the game crash my video card drivers. I have Radeon 4870 and i have no problem with any other game. And yes i have latest drivers for my GPU. I updated it when Dragon Age Inquisition came out.

Phenom 2 X4 2,7GHz
Radeon 4870 512MB
Win 7 PRO sp1 64bit

1 Like

with the new alpha it runs a little bit smoothly but still crashes…

ok all of you with an AMD card please try to disable the pinned memory ^^

not owen wilson

i searched in the forum and put the “disable_pinned_memory” : true into the user_settings.json

here’s the whole file

still not working…after 5 minutes the game still crashes…

1 Like

ok try 2 settings - first after the true you need a “,”, second try to disable the shadows with “false,”

now it doesn’t start and gave me this error

i just changed “enable shadows” to false instead of true.

Am i missing something?