Crash within a few moments of playing

Hello I need some help my game keeps crashing when I start a new world about after a minute or two is there a fix to this? Thanks for helping.

Hey @Bot125. Can you give your System Specs? The likely culprit in this scenario is that you need to update your Graphics Drivers. That has been an issue a lot of the time.

Yes I can

AMD Radeon HD 8570D Graphics Card

AMD Elite Quad-Core A8-6500 Accelerated Processor

Dont think you need anything else if you do just ask

hey there @Bot125 … welcome aboard! :smile:

just to get a few more details, would you mind providing your OS and memory as well?

which client are you using? Humble Bundle or Steam? have you tried both?

At the moment I am using both and I have a Windows 8.1 and 8GB DDR3 system memory.

1 Like

Please also report the version of your AMD drivers!

1 Like

Processor: 6.3.9600.16384

Graphics card: 13.152.1.1000

This is what my computer says it is so if its wrong I have no idea what the version is…

Alright I have been looking around and such for solutions and I have Uninstalled/reinstalled Stonehearth and all my drivers are up to date. I hope the devs fix this because I really want to play this game

Here is one thing you can try. When you load the game, go to the “options” in the top right of the screen and turn your graphics settings way down (or off). I found that helped with some crash issues I was having with my nVidia graphics card (seems like when I zoomed out, it wouldn’t be able to handle the graphics anymore and would crash).

1 Like

I have already tried this sadly it did not work

Hi there,

As it turns out, your drivers (version 13.152.1.1000) aren’t actually up-to-date (you have to go to AMD’s website to get the latest, not HP’s). Here’s a link to the latest drivers, which should fix the problem: Desktop . Let us know if that fixes your issue!

3 Likes

Oh yes it worked thanks for your help! And thanks for the other people trying to help but failed!

1 Like

Whenever i start to play StoneHearth my game suddenly crashes in about 1 minute. If you can help please tell me i have a AMD Radeon HD 8400 graphics card.

hey there @finnstermcl … welcome aboard! :smile:

your post has been merged with this similar report…

Just updated my drivers with the link in this thread, restarted, and had my fastest crash yet. Before I could even place my banner.
AMD Radeon HD 4890
AMD FX-4130 Quad-Core Processor
MSI 970A-G46 Mobo
8GB DDR3 RAM
Not sure what other information you’d need? I was just moving the camera around with WADS to pick a location.

Edit: I’ve just been running from Steam. I’ll try the humble bundle installer and report back.
Edit2: same result.

I also is having the same problems. my game crashes and exits within 2 second of trying to continue my saved file.

OPERATING SYSTEM:
Windows 2.6.1.7600
CPU TYPE:
Intel® Core™ i7-4770K CPU @ 3.50GHz
CPU SPEED:
3.52 GHz
SYSTEM MEMORY:
17.11 GB
VIDEO CARD MODEL:
AMD Radeon R9 200 Series
VIDEO CARD MEMORY:
2.89 GB
VIDEO CARD DRIVER:
aticfx32.dll

Okay, time to bring out the big guns. @kizoku, @yellandrebel, I’m gonna need some help (and some time) to figure out what’s going wrong here. A couple of steps.

  1. Locate the directory your ‘stonehearth.log’ and ‘user_settings.json’ files are in. These should be in a directory like ‘C:\Users{your user name}\AppData\Local\stonehearth’ .
  2. Open your ‘user_settings.json’ file in a text editor (notepad is fine).
  3. Replace the entire contents of that file with the following:

    {
    “logging” : {
    “log_level” : 9
    }
    }
  4. Run stonehearth until it crashes.
  5. Go back to that directory with stonehearth.log and user_settings.json. You’ll see a very big stonehearth.log file. Send that to me in a private message! (You should be able to zip it to make it smaller, I think.) To send me a private message, just click on my portrait in this message, and you’ll see the option there.
3 Likes

as they are both new users, hopefully they won’t have an issue sending PMs… :pray:

some free file hosting sites may be an alternative…

Sweet, thanks!

Also: The first person to make an ‘over nine (thousand)’ joke is banned. Forever.

1 Like

Ooookay I didn’t even make it to the screen and it crashed. Twice. Started loading the map and then before it even finished loading the program stopped working. Going to send the file over now.
Edit: “Sorry, new users can not upload attachments.” On to tinyupload.
Edit2: Here it is.

1 Like