Game Crashes after several minutes

Whenever I start up Stonehearth, it loads fine, everything runs normally, and the game plays smoothly and well… For about a few minutes, then stops, and crashes. I am not using any mods, and bought the game on steam recently. I am on Windows 8.1, and have tried everything from running as admin, turning off fulscreen, turning off antiviruses, even updating graphics cards and such. Any reason why this is happening or how to fix it?

Crash Log

1 Like

Can we have your actual version and also your PC performances (processor, memory, video card) ? :smile:

The Log says version, so I’m going to assume that.

As for the rest,
Processor: amd a10-6700 apu
Memory: 8 GB of RAM
Video Card: AMD Radeon HD 8670D

Hope I listed these right

Don’t know the performance of AMD stuff ; anyway let’s call our loved @moderators

Hey there @SteamingBullet, welcome to the Discourse! Based on your log you are running the game in 32 bit mode, and it appears to be crashing when it runs out of memory (32 bit mode limits you to 2 GB despite having 8 in your system). Is there a reason you enabled 32 bit mode?

Yes, actually. It was originally on 64 bit mode, and the same thing happened, but I read somewhere that setting it to 32 bit would help, which it didn’t, and that was when I decided to post here.
Would it help if I were to get a log with me set to 64 bit?

Yeah, 32 bits is known to cause more bugs than 64 bits
Here’s a log of the game crashing while it was set to 64 bit

That’s not 100% true. There is close to no difference with “in-game” bugs between the two versions. There are, however, some crash related differences that have been seen, particularly with game launching.

Unfortunately I am not seeing anything that catches my attention different between the two logs. Both seem to crash 2-3 minutes after loading the save.

It is possible that something in this particular save is corrupted. Does the game crash after a few minutes when creating a new game?

1 Like

This happens even if I start a brand new game. I bought the game a few days ago, and this has been happening since the start. If I save before it crashes, then load it up, the game plays normally and coninues fine for another 3 minutes.
If there’s anything else I could provide to help solve this problem, I’d be willing to help, this seems like a fun game and I’d like to know how to solve this.

Hey there @SteamingBullet, I don’t have any other suggestions at the moment, you will likely need to wait for the devs (like @Albert) to come take a look. One last question, if you have a crash.dmp file located in the same location as your logs, can you upload it here? It might contain some useful info for the devs.

I’m grateful you at least tried to help, hopefully it’ll be fixed in a later patch, as it seems others are having these problems.
Unfortunately, I do not have a crash.dmp file anywhere in the folders, so I’ll just play the waiting game till then.
I do appreciate the help given to me, even if it wasn’t successful

1 Like

I have experienced this before, and it goes away after a while, but yes, it is quite peculiar…

By “go away” do you mean the more I play, it’ll eventually go away?
Welp, better get used to saving every minute!