Alpha 22.5 PC Slowdown


#21

Reinstalled PC with the same results :confused: i even installed a fresh Stonehearth in a new folder without any mods at all just fresh windows with fresh stonehearth with fresh steam and still this.
AMD Driver 17.7 installed by Windows


#22

with those two monitors and that old graphics card I bet it just can’t handle it. try unplugging one of them maybe


#23

It handles it fine with all other games except with Stonehearth after they changed their fullscreen with alpha 22 or 22.5 if i remember correctly.
AMD 7950 is capable of more monitors at the sametime i lose max 2fps for using 2 monitors.

This all started to happen after Stonehearth changed how their Fullscreen was made. The fact that AMD 16.11.5 driver works with Stonehearths new fullscreen with that old AMD driver is enough evidence that the graphics card is not an issue for those monitors
AMD Drivers that was more up to date worked with Stonehearth also until Stonehearth updated so it’s probably on Radiants side is my guess to fix it.

Multi Monitor setups are not very demanding if you don’t game on them at the sametime in eyefinity that would be a big difference.

What i think is doing this which is just a guess is something with how Stonehearth creates this new fullscreen window when they changed it from their previous true fullscreen into borderless window.
Perhaps the OpenGL that Stonehearth uses is outdated or perhaps AMD’s OpenGL that comes with it is outdated but i dont know. Might contact AMD also if they ever respond to see what they say.

Feels like i tried everything possible atm also tried the disconnect monitor in posts above with no fix.
I might just have to use an 1 year old AMD driver if i can’t help Radiant or AMD fix this :frowning:


#24

When i launch the game there is also not really any load on anything not on CPU, GPU, SSD or Memory.
I think it’s also very strange why Stonehearth creates the fullscreen in 1920x1081 when the monitor is 1920x1080


#25

Tried another 100% reinstall format C entirely and the strange thing with Stonehearth is the very first time i launch Stonehearth it’s fast it’s smooth like you’d expect it to be but second time i launch it the sluggishness is back.
Is there some files perhaps in the configs that configures the launching wrong?

Refuse to give up fixing it :smiley:

Not sure if this file helps with anything
stonehearth.log (4.6 KB)


#26

the reason I suggested it is because it may not be detecting your monitor correctly since it was off by a pixel. it may be the monitor thats the issue.

as far as responsiveness, you would have to disable (if you are on an SSD) or enable (if you are on a HDD) prefetching / superfetching

also you can defrag your HDD and its freespace

plus you can optimize some registry for gaming


#27

Tried messing a bit with the stonehearth.json and changed so that “enable_gl_logging”: true,
instead of false for as i understand it opengl logging whats happening when launching and to me without having much knowledge of this it seems it’s throwing alot of errors about opengl

Here is a short few lines
"2017-12-04 01:57:57.943418 | client | 1 | game_engine | Creating OpenGL Context
2017-12-04 01:57:57.943418 | client | 1 | game_engine | Finished OpenGL Initialization
2017-12-04 01:57:57.943418 | client | 1 | horde.general | Initializing GL2 backend using OpenGL driver ‘4.5.13492 Compatibility Profile/Debug Context 22.19.677.257’ by ‘ATI Technologies Inc.’ on 'AMD Radeon HD 7900 Series’
2017-12-04 01:57:57.943418 | gpu | 2 | horde.general | glGetIntegerv parameter has an invalid enum ‘0x87fb’ (GL_INVALID_ENUM)
2017-12-04 01:57:57.943418 | gpu | 2 | horde.general | glGetIntegerv parameter has an invalid enum ‘0x87fb’ (GL_INVALID_ENUM)
2017-12-04 01:57:57.943418 | gpu | 2 | horde.general | glGetIntegerv parameter has an invalid enum ‘0x87fb’ (GL_INVALID_ENUM)
2017-12-04 01:57:57.943418 | gpu | 2 | horde.general | glGetIntegerv parameter has an invalid enum ‘0x87fb’ (GL_INVALID_ENUM)
2017-12-04 01:57:57.943418 | gpu | 2 | horde.general | glGetIntegerv parameter has an invalid enum ‘0x87fb’ (GL_INVALID_ENUM)
2017-12-04 01:57:57.959043 | gpu | 2 | horde.general | glGetIntegerv parameter has an invalid enum ‘0x87fb’ (GL_INVALID_ENUM)
2017-12-04 01:57:57.959043 | gpu | 2 | horde.general | glEnable parameter has an invalid value ‘15’: must be less than 8 (GL_INVALID_VALUE)
2017-12-04 01:57:57.959043 | gpu | 2 | horde.general | glDisable parameter has an invalid value ‘15’: must be less than 8 (GL_INVALID_VALUE)
2017-12-04 01:57:57.959043 | gpu | 1 | horde.general | Error generating mipmaps while uploading texture data: 1281
2017-12-04 01:57:57.959043 | gpu | 2 | horde.general | glGetIntegerv parameter has an invalid enum ‘0x87fb’ (GL_INVALID_ENUM)
2017-12-04 01:57:57.959043 | gpu | 2 | horde.general | glEnable parameter has an invalid value ‘15’: must be less than 8 (GL_INVALID_VALUE)
2017-12-04 01:57:57.959043 | gpu | 2 | horde.general | glDisable parameter has an invalid value ‘15’: must be less than 8 (GL_INVALID_VALUE)
2017-12-04 01:57:57.959043 | gpu | 1 | horde.general | Error generating mipmaps while uploading texture data: 1281"

game_engine | ignoring duplicate screen resize to (1920, 1080)

Here is the logged file
stonehearth.log (26.5 KB)


#28

With AMD 16.11.5 that has none of these issues my stonehearth log says this

stonehearth.log (25.6 KB)

perhaps it helps :slight_smile:

this does not exist when i use the 16.11.5 driver but with drivers later than this driver it does
"ignoring duplicate screen resize to (1920, 1080)"


#29

Hi Everyone,
I am having terrible system slowdowns as well. Performance has been on a downward slope, actually. Formerly I could build many ornate buildings and have 12-14 inhabitants and still get reasonable performance. Now I have trouble building even simple buildings (today it gave an error trying to build a simple fence as the start of a new game.)

I know my system is older, but last month I was sliding down pyramids in AC Origins, so… DxDiag.txt (68.9 KB)

It is honestly getting to the point where the game cannot be enjoyed anymore, and that’s a shame, because I used to really like it. Please prioritize performance in your next couple of updates.

Thanks!
Edwin


#30

Still unable to repro this, but thanks for the extra info. The 1920x1081 resolution is possibly relevant but expected (it’s a workaround for Window on the main monitor blinks · Issue #527 · glfw/glfw · GitHub). FWIW, we have never used “true” fullscreen. It has always been a borderless window, but until 22.5 we didn’t prevent auto-minimize on focus loss. We did however update our version of the GLFW library in that patch, which is almost certainly related.

One thing to try is to switch is running the 32-bit version of the game, which can be forced from the Settings -> System menu. Does the issue still occur?


#31

I will give 32bit a try later again but i’m almost 100% that i have tried it and if i remember it just made it worse for me. I will give it a try soon again tho to be 100%.

What rig are you guys trying to repro my issue with?
Hardware, Software and Graphics Drivers?


#32

I had two ideas.

While I’ve never had the problem with Steam, Ubisoft DRM controls sometimes interfere with game play. Is it possible that something about that connect is causing a problem? Are you guys connecting through Steam when you test?

Or

Could I maybe need a fresh install? I’ve been playing the game quite a while, and there have been many updates. I tried it myself, but the game kept all of my old saved buildings, so obviously I missed something.

Thanks!


#33

If you experience a lot of slowdown when you play the game and start to design something and it drops fps very low or freeze the game you might have to put your building templates in a backup folder if you wanna use them again. I had that problem when i got many templates that it would freeze the game everytime i tried to design a house. Hopefully they find a way to make so we can keep our templates later on no mather how many :slight_smile:


#34

I’ve tried making all new templates, thinking there might be compatibility issues, and it hasn’t helped.


#35

Hey i have been running on the 16.11.5 AMD Driver for a while which i know been working normaly.
I today gave it a chance to install the latest 17.11.4 AMD Driver. This time i upgraded frm 16.11.5 to 17.11.4 instead of cleaning out driver which normaly is the best thing to do.

Playing on the latest Alpha 23 Release 766 right now with 17.11.4 Driver and i have not experienced the slow down after starting the game 4 times.

Not sure if anything got fixed for my issue in release 766 or if it has to do with 16.11.5 upgrade to 17.11.4 instead of a clean 17.11.4 install.

Thought i let you know :slight_smile:


#36

yay! software magic


#37

I’m happy it works fine now :slight_smile: would be nice to know if it works because upgrading the driver instead of cleaning it first then getting the exact same driver or if the latest alpha fixed it so i wont get that again or someone else :slight_smile: i like software magic :wink:


#38

FWIW, there were no major graphics-related changes between release 765 and 766, so it’s almost certainly the drivers (or possible antivirus - those things never make sense).


#39

Turning off Windows Protector made a huge difference. I re-read the thread and saw your suggestion to check it. It was taking 30-60% of CPU while the game was running, but went back to less than 1% after closing the game. Wanted to pass that along.


#40

I also turned off the third speed, and started using the first speed more. On the third speed, many things would simply stop happening at a certain point, but by turning it down to the lowest setting I can get everything to function properly.