[0.22.5.758 (x64)] Black Screen

Haven’t played in a few updates and now I get a black screen at the start.

DxDiag.txt (42.6 KB)

yes this is using an old driver, but it doesn’t seem to matter as I’ve tried the latest one as well as 2 older ones. Other games unaffected.
stonehearth.log (3.2 KB)

1 Like

According to that DxDiag you have 2 display adapters, an ATI Radeon HD 4250 graphics chip and an NVIDIA GeForce GTX 960. The log shows that it’s using the GeForce GTX 960, but perhaps something in the initialization sequence is getting confused by having both adapters active. I’ll look into it.

3 Likes

thanks!
yeah I am using the integrated graphics on my second monitor. haven’t gotten around to buying a new cord to plug it into the gtx960
it actually flashes white for just a second, but thats about it. music still plays, and cursor icon was working sometimes but nothing seems to render, mouse still moves around just fine and steam overlays are working and I get a crazy 2300 fps…

after doing this:


the game is more consistent in flashing to white and the cursor icon loads every time.

Did you try forcing the game to run on only one of the cards?

1 Like

No I didn’t try that. What would you suggest the best way to do that is? Not sure if there is a steam launch option or what…

One way to attempt that is to force fullscreen. You can do that by opening user_settings.json in the Stonehearth folder and changing the value of "enable_fullscreen" to true, as in the screenshot below.

1 Like

I really don’t think thats the issue though. I have checked the gpu usage on the GTX960 and its definitely being used, there is just nothing being rendered.

	"renderer" : {
	"run_once" : true,
	"use_high_quality" : true,
	"enable_ssao" : true,
	"enable_shadows" : true,
	"msaa_samples" : 1,
	"shadow_quality" : 5,
	"max_lights" : 250,
	"max_shadows" : 16,
	"enable_vsync" : true,
	"enable_fullscreen" : true,
	"screen_width" : 1920,
	"screen_height" : 1201,
	"draw_distance" : 500,
	"last_window_x" : 30,
	"last_window_y" : 30,
	"last_screen_x" : 0,
	"last_screen_y" : 0,
	"window_width" : 1920,
	"window_height" : 1148
}

here is a screenshot of gpuz. disabled vsync so I could see the usage

image

here I enabled gl logging
this .log should be more useful I think
stonehearth.log (12.6 KB)

Well, the only major difference between your config and working ones is having multiple graphics adapters, so that’s the best clue we have as far as I can tell. Your graphics driver is not the latest, so updating it is always worth a shot, but it’s recent enough that I doubt that’s the issue.

The gl logging option is an old flag that only enables a few things. You can turn on all renderer logging by adding a logging section as below.

1 Like

well just to be sure I went back to the latest driver. I’ve tested this on 4 different drivers already, all of them recent enough and worked with previous versions of stonehearth, besides this latest one. so this really has to be something done with an update to the game.

anyway here is the log
stonehearth.log (122.4 KB)

also just to be clear I haven’t played since alpha 21 and it worked. wanted to wait for the new conversations to be completely done before I gave it another play

here is the non-beta log alpha 22
stonehearth.log (252.6 KB)

1 Like

In 22.5 we updated to a newer version of one of our window management / platform abstraction libraries, and changed how windowed vs fullscreen initialization is done, so this is definitely related to that. Currently the choice of which monitor is rendered to depends on the initial position of the window. Something to test is to use windowed mode, make it start small by adjusting window_width and window_height in user_settings.json, then trying to have it start on each of the monitors by changing last_window_x or last_window_y (depending on how your monitors are laid out). It could work on one but not the other if they are not connected to the same graphics device.

2 Likes

24 hours later~ I am wrong again lol
turns out I do actually have a program that can force applications to load on a specific monitor, just didn’t realize it until now

really though, after some strange series of events…sigh… what happened, I think, is a combination of a bad system restore a few months back and some of my registry files regarding my drivers got corrupted during a backup and system restart after a windows update more recently. it may have been that I also used a registry cleaner at the wrong time as well, not sure. I probably did something silly though because I just reinstalled windows 7 and the game is running fine now. I still have to reinstall again tho, because I think the .iso I am using may also have some issue, that and installing windows updates too quickly causes bugs apparently. so even though most things are running fine, I can’t create a backup .iso which is the one thing I actually wanted to make sure is working so I don’t have to do this again. didn’t do it last time I installed windows and I now regret it.

really the update to the game just revealed a problem that I may have missed otherwise, as things seemed to be as usual

anyway sorry for the trouble, and thanks for the help.

2 Likes