Workers dont do job

They just dont do their job what can i do about it?

What exactly do you expect them to do? Are they idle? Are they busy with other tasks?

for example if i mark job only they are idle the supposed to do their job or am i wrong its the blacksmith spesific

I assume you did give him some orders. Strange. I once had a carpenter who refused to do stuff from his list of oredrs. After I deleted it and re-entered them, it worked, though. Or does he start crafting, when you activate his other activities, maybe?

What items you order him to craft? Do you have the workbenches placed? Is he doing something else?

I deleted the orders a couple of times and gave him the time do to it but he won’t and everything is placed he is level 2 and isn’t even crafting the basic stuff.

Hello there,

ich had this under alpha 18, under alpha 19 i didn’t get this until now. Mhmm …

perhaps uploading the savefile? i’m sure someone could find out the problem :slight_smile:

hey there @Cedric_Daemen,

as @Doc_Brano said, could you provide your savefile? here’s how to do that,

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

hope that helps :slight_smile:

Hey! I’m a noob to Stonehearth and ran into the same problem tonight. My master carpenter refused to work for. like an entire in-game week! Could NOT find a reason why. He was set to job, haul and build.

Morale was low, so I was wanting to make comfy beds, thinking it might help.

  • There was no building going on
  • He was not stuck somewhere
  • There were plenty supplies needed
  • Obviously he was high enough level
  • I cancelled the job and retried several times

Nothing was working. He’d either haul food from the farm to storage, be idle or chase someone. oyyyy

Just on an odd whim, cause EA and all that… I was like, “Will he make yet another mean bed?” So I cancelled everything and tried that. He went right to work. For some reason after that, he decided “hmmm, not so bad to be back to work afterall” (I guess!) and started making the comfy beds.

Don’t ask me why or how, but try doing something lower first maybe and then try again?

I’ve had this problem before as well, but with farmers. Have about 6 fields, 1 with fully mature crops, 5 completely empty since they were already harvested and needed replanting, farmer was sitting next to the fire, idling. Disabling and re-enabling his job would sometimes fix it, but other times he’d wait for my cook to come start doing his job for him before he’d jump in and lend a hand.

I’ve had this problem in Alpha 19. I destroyed a building with an anvil in it. Then I rebuild a different building with anvil. Unfortunately, the blacksmith kept stucked on a task and I had to reassign him to worker job then blacksmith again in order to make him poll his queue task.