Citizens won't do there jobs

ive got about citizens now, and only 2 are doing there jobs, kinda, the mason is making stone piles and sitting them in the grass when i got plenty of storage, the blacksmith and carpenter have jobs queud and there not doing them, and i have the resources, the trapper has had a animal in a cage for days and won’t go get it. there is only one worker actually working.

Which version were you playing? How many in-game days had passed and how many hearthlings did you have?

This is a bug, but you could try resetting the AI (with F3 if you have the “enable_debug_keys” : true in you user_settings.json file) to see if it helps to unstuck your workers. :confused:

I have the same problem and others friends too.
I tried what you say but knowing the line “enable_debug_keys” doesn’t exist in my file I added it and got this error message :

I have some problems with my workers regarding complex building specially those using single blocks, are they any well-known bugs ?

@Relyss - Could you direct me to this .json file? I’ve been through every folder in my Stonehearth directory and I can’t seem to find a ‘user_settings.json’ file.

Many thanks.

It’s in the main folder : Steam/steamapps/Stonehearth/user_settings.json

Thanks @Druyk

I had, in fact, just found it right before you posted :slight_smile:

1 Like

After checking I realize I forgot a comma after the previous entry… (ennable_auto_save on my screenshot).
So I’m gonna try F3 the next time I have this bug.

1 Like

i got same problem and i started new game today for example the smithing guy wont smith and just stands still (got all materials) and sometimes he just stands on the blacksmith anvil derping like a boss no you know! :smiley: and im on day 15 atm i have unimployed and tryed again but he is just way to retarded to get things done smooooothly :3

For me when pressing F3, all the citizens just stops doing stuff, if you look at the workers tab you see “idle” on everyone, press F3 again and they start doing stuff again, but many times the issue (AI bug) is not solved by this.

Best way is to overwrite save, and load the game, always works

1 Like

10.5.10 64x and 10 hearthlings

i don’t know where to go to change the enable debug keys, can you help

@Sir_Broseph - Go to your steam apps folder (I assume you’re using the steam client), it should be something like this

C:\Program Files (x86)\Steam\steamapps\common\Stonehearth

toward the bottom of this list you will see a .json file named “user_settings.json”

open this file with a text editor (like wordpad or the like).
add this line
“enable_debug_keys” : true,

somewhere in the text. I added mine near the bottom (see the highlighted text)

I’m pretty sure that I added it in the right place.

I hope this helps :smile:
(Please bear in mind that I’m not a modder or programmer, simply a fellow tester and player who is trying to help).


then u just save the wordpad ?

The file was saved as a .json file. Make sure that it’s saved with the same extension. Most text editors (including, I think, Wordpad), allow you to save the file as a .json.

Thanks people, you all rock!

So this workaround

always works? I’ll try it if I encounter the bug. Might be more efficient, yes. The F3 thing I said it without testing it, you know. Just for trying to see if it could help. :sweat_smile:

Well, always worked for me when I encounter AI routing bugs or they get stuck

1 Like