Worker Randomly Stop Working


I figured out what was causing this bug in Alpha 9. I noticed a recurring pattern that with these saves in my current town of Avalon, the Blacksmith would always bug out upon loading the game before everyone goes Brain dead.

Then it hit me:

The problem was caused by having items in the Craftsmans Queue as I saved. So I went back to the save with the brain dead citizens, removed the items from the Blacksmiths Queue, saved the game again, and returned to that save to find there memories were no longer wiped!

Simply Put, I. Am. A Genius. :stuck_out_tongue:

So for those of you who have been getting affected by this bug, try this. ^


paging @ponder, @sdee

Definitely worth trying this (omg I’m running out of time these days) … So, if anyone can confirm, please :pray:

Thank you very much, @Vince5754 :smiley:!!

1 Like

A recurring pattern I’m noticing is that I can reload saves all I want
the day I make the save, but reloading the save the NEXT day it causes
everyone to get a free lobotomy.

When you say “day”, you mean a Stonehearth day, right? Or do you mean a meat-space day?

boggle. Wow, to be clear, does clearing the queue fix just the blacksmith, or do all the workers who were stuck also become unstuck?

I’m definitely taking a look at this once I get through some more crashing bugs. Thanks for doing all the hard research!!


Every Hearthling, Animal (And Goblin? I’m not 100% sure on that one, but I believe it affected them as well) would once again function as normal.

Happy to be of service to Team Radiant!

EDIT: When I was talking about “Next day”, I was referring to uh… “Meat Days”, As you put it.


That is totally bizarre!

Sorry to be obtuse. By “meat space” I meant like, actual real calendar days, (like, today is Saturday). Does it have to be a full day? If you just restart Stonhearth instead of loading from the same session, would they still get stuck? What if you waited an hour?

Thanks again!


brilliant stuff @Vince5754! as has been suggested, I’m sensing a new title for you on the horizon … :+1:


I could exit stonehearth, and open it back up and reload the saves no problem on the day the save was made.

For instance, I exited and reopened Stonehearth several times Friday, and it would always reload fine, I got off at around 11:33 PM and woke up this morning at 8:30ish. I started the game not long after to discover the “Lobotomy” they had received.

1 Like

hmm… thoughts on the new title? :laughing:

1 Like

Couldn’t have come up with a better title myself… Well okay I might have but coming up with my own title would make it less special!

Thanks Steve!

I would like to thank all the little people who lost their marbles this morning at 8:39 AM.


I’d have said Savior of Minds but Dr. Lobotomy sounds also special. :smile:

1 Like

Once again I got on Stonehearth this morning to my world Avalon and the workers stopped functioning, and once again removing items from the Blacksmiths Queue and reloading fixed them.

I’m going to try to recreate this bug using a different Crafter, otherwise its a Blacksmith who’s causing the problem specifically.


Your efforts to help us nail this are so so appreciated, @Vince5754! I’m still looking for the root cause.


yes, in your case for everyone going brain-dead. For me it doesn’t work for just a couple going brain-dead…

I did think that the whole “Several going brain dead” bug was something different… Hmm…

Also due to an unfortunate miscommunication a friend of mine has my laptop so I won’t be getting it back until at least tomorrow. :frowning:

Seems I won’t be testing that bug yet.

@Ponder So I’ve created two separate saves from the world I’ve been using.

One save I had ordered a Carpenter to craft Wooden Drawers, on load everyone was brain dead.

The second save I ordered a Mason to create some Tower Braziers, on load everyone was brain dead,

I did notice however that the Trapper would bring the retrieved items to the stockpile and place them, but would then become unresponsive, odd.

It would seem that its a problem with a Crafters code in general, not a specific crafter.

I have a another idea for a test I can try. I’ll let you know what I find out.


I’ve just got a game in r223 which is quite far developped, 15+ citizens atm, high level crafetrs and all. Now here it seems that when i leave the weaver and carpenter with stuff to do on reload. They don’t go brain dead. I’ll try with mason and blacksmith and see what happens.

That’s the strange thing, @Sweeck , and is something I’m looking into at the moment.

This morning I did a different test where I order a Carpenter to make items, and while he was working on that task, I saved and reloaded that save a minute later, and what would normally cause the lobotomy bug wouldn’t do anything. Which is why it seems as though it doesn’t actually cause a problem until the next real life day of that save.

i haven’t encountered the brain dead after mason and weaver either. I dunno if this maight be the cause but i imported a r230 save and updtaed it to a r233 save. IT would be highly unlikely, but in my clean r230 saves i did get the same issue you did tho… haven’t tried with a 100% clean r233 save (yet). Have you tried that @Vince5754 ?

SCRATCH that: I just reloaded again and this time it’s a 2 in 1 bugg…

I have been getting this bug for a long time now, and it appears that others are getting it as well. The bug symptoms are that when you load a saved game, the hearthlings drop what they are doing and will no longer do anything at all.

These are the steps that guarantee that my save game will become bugged.

  1. Play game and save at some point, even if you only play for one game day.

  2. quit game

  3. close out steam.

  4. Reboot computer.

  5. Your save game is now bugged when you restart.

So it would seem that restarting the computer is the main contributor. Either the game is not handling a dynamic ip, or something is not getting saved from memory to the save game file. Or maybe it has something to do with steam…

hey there @Tempered … welcome aboard! :smile:

your post was merged here, as it falls in line with the “brain dead” units syndrome… :wink: