Worker Randomly Stop Working

My worker randomly stopped working after the stockpile location was full so I created a new one (this was harvesting wood); so I had to save and reload and they started to work again.

1 Like

SOMETIMES… sometimes… it helps to put them in defense mode and then back to “peace” mode. Sort of re-triggers everyone to find a job. But like I said, I can’t confirm this works everytime.

1 Like

This is why the path finding needs a complete overhaul. Hint, hint. @RadiantEntertainment

They’re working at one thing at a time. Right now it’s more focus on the combat system and implement some more classes. I know they’re trying to support 64 bit version of the game which would help with making the game a lot better. As for now though Radiant hasn’t said when they’re going to come back to the system side of game. Just be patient.

Building a squad (I don’t want to call it an army) is fairly difficult when dudes just stop building stuff at 12 hearthlings.

@sdee @SteveAdamo here is a random save of people not working, just in case.
http://s000.tinyupload.com/?file_id=70724892698361644202

4 Likes

this has happend to me as well, i think it has something to do with the number of heartlings, its always the same amount of ppl that continue to work, getting a new heartling will eventually make one stop

I can confirm this happened to me too.

Some screenshots:



On the last screenshot, half of my villagers where just rumbling arround without doing anything. On the current task table it says “Idle” but there where lots of things to do.

Im no really sure, but this happened to me once after saving the game. It fixed itself after reloading it (without closing the game worked fine)

thanks for the confirmations, save games and screenshots folks! :+1:

[tagged]

1 Like

Apparently, after you keep playing long enough workers stop doing anything and just starve…
You can demote them but that’s it… Other citizens conitnue to function as they go…
There isn’t anything stopping them from reaaching food or anything, i have no idea why…

I know this has been around for some time, but all the other threads appear to be very old…

Had a similar problem where everyone just stopped working, once upon a reload and once mid game.

The guys at stonehearth know about these bugs, and it’s on their to do list. Did you try loading the previous alpha, the one that has less bugs? Those tend to have alot less worker problems compared to the relatively untested up-to-date patches.

I still say that this is caused by a deplorable lack of coffee in game. :coffee:

3 Likes

indeed… but a merge should blend all the recent feedback and get this original report to resurface… :+1:

guys i’ve been playing this since alpha and i rly am not gonna play the far behind ‘more tested’ version… I mean bugg reporting, fixing, finding, finding workarounds is just waaay to much fun.
The reason why i started again is because ast time i played i litterally reported all the buggs possible… And it seems they fixed all those which is AMAZING! So yeh, relaoding doesn’t help either btw :wink:

(sorry steve, just a habbit)

1 Like

Well in my case the stockpile wasn’t full. I believe that it indeed had something to do with the number of citizens i have already. My best guess is that currently the game can’t handle more than 12 citizens. In total i had 15, of whom 3 stopped doing stuff… They eventually just starve to death…
Now i also noticed that once you get passed day 10 the game gets really buggy i don’t know if this also relates to it…

I woke up this morning to play Stonehearth to discover an unfortunate bug:

Upon loading the game all the Workers and Craftsman stop any work they were previously doing and idle regardless of any order given. Soldiers still patrol, but they too don’t react to the town defense mode being activated.

I tried it with my other saves from this world, the same thing:

I would like some confirmation on this one from others on the forum, I didn’t see any reports of it so it may be a problem with my game specifically.

Have you tried giving new orders?
For workers:

  • Like ordering your workers to dig something or ordering them to gather something?
  • promote them to a new job if possible

For crafters + soldiers:

  • Try clearing their que and adding something new
  • demote them
  • move their working station

Could you link the save-file? I’d like to see if I can get them working again. I’m gonna try and put some time into it in the upcoming days, see if I can find a work around. Because for me giving new orders didn’t work, but i want to try finding other solutions.
Here’s my question to anyone: Is there a way/command to force a goblin attack?

1 Like

Well, game was running excellently with the new 210 Update, but once again I woke up to find…

All workers, including new arrivals from the Daily Update go completely brain-dead. A recurring pattern I’m noticing is that I can reload saves all I want the day I make the save, but reloading the save the NEXT day it causes everyone to get a free lobotomy.

That’s a shame too, I was finally starting to set up my Dwarf Fortress-esque town when this bug came with a vengeance.

how many days in game are you at?