Won't build a house with walls inside

I’m trying to build a 1-story house with 2 rooms and with a stoneslab roof. The roof shouldn’t be the problem as I’ve done this many times before the same way without problems.
As you can see on the picture below, I’ve made a similar building, but without a wall inside.

  1. Build a house.
  2. Place a wall inside the house, using the wall tool.
  3. :frowning:

Expected Results:
They should build the house :slight_smile:

Actual Results:
I get the error on the picture and a C++ Lua runtime error



House template:
house.7z (25.3 KB)

savefile.7z (3.6 MB)

Version Number and Mods in use:
0.15.0 Release 537 x64

System Information:
Intel core I7, 16Gb ram, Asus R9 280, Windows 10.

Hi there, if you have got any more houses that you can not build, please post them here:

In the meantime, did you try to place and build the saved template?
Destroy house,
place it again via template
try to build

Or just use instant build command via console

strg(ctrl) + c
and there type in
while having the house selected.

Yea, I thought about that, but I thought that thread was about templates that the hearthlings couldn’t complete due to weird placed windows or other stuff, but still started building. I’ll post it there instead then.

And yea I tried to remove template and replace/build. Then no error pops up, but they still don’t build it. Even in an entire new game. Still the same result.

EDIT: Instabuild gives same result. Error and when removing and replacing, no error and no build.

1 Like

It was, a long long time ago in a beta far far away.
But now you can post every template which you have problems with.


I’ve done it now. And thank you.