[Con] Can't erase building and build a roof

Hi, I’m tring to build my first house, but I can’t build a roof, so I tryed to erase the building but nothing work… I can’t post an image becouse I’m a new user. the error is:
Stonehearth/services/server/build/build_undo_manager.luac:3: assertation failed!
c++ exception: lua runetime error

id: 484d22d0-c337-11e4-99a5-002522f0d801


hey there @Cartaio … welcome aboard! :smile:

feel free to upload an image to imgur.com and we can embed it directly for you (until you have been here a bit longer, and are able to do it yourself)… thanks! :+1:


New bug: finally my worker start to destroy an under costruction building, but at the half the game crash down…


First time here searching for it, but I can confirm that this has been present since alpha 5 or so.

I can reproduce this about 50-60% of the time by:

  1. Placing a planed building such as cottage for two
  2. select the building
  3. press remove and confirm
  4. place another cottage at the same place

Placing a few more buildings before undoing one and placing something else on the same spot seems make it more likely to happen.

Workarounds: Once this happens I usually need to save and reload to be able to build things again.

Basically I put my floor down, then my walls (tried the grow walls tool and manually building walls) and finally I try to put my roof on but it comes up with errors in command box and then breaks my save so I can’t place any custom buildings down or even house blueprints (already made houses).

Sorry if this post has been sent in already it’s just I couldn’t see anything to do with it.


So is this a fix to the templates of buildings or the roof glitch?

I am having the same problem since the initial release of 2283. Mine sounds a bit different though. I can build a custom building with windows and doors but no roof, or I can add a roof but have no windows and doors.

I would like to upload my image for you so you can see what I mean and the error codes I get when I do so, but it says I cannot upload images as I am a new user.

thanks for the confirmation…

well, welcome aboard! :smile:

feel free to upload to imgur.com and we’ll embed the images directly for you… :+1:

Here’s the image, thanks for alerting me on how to post those. Haha, I may have a computer but that doesn’t mean I know how to use this magical box of wonders.

So as you can see, the house in the back has windows and will not allow me to place a roof, while the house in the front has a roof but will not allow me to place windows. Here is also the error message that appears when I attempted to build the house.

Thanks for the speedy reply Steve! Love this game, invested a lot of hours into showing it off for friends and other youtubers. Full release is going to be friggin amazing, each new patch you release is like being a kid on christmas.

1 Like

I’ve encountered this same problem in my games so far and it’s preventing me from making my own custom buildings.Steam Community :: Screenshot

this is the template for a cottage for two in alpha 13
and the roof won’t be build
I tried to build my own house and the same problem happened

I think Stephanie asked that any house problems could have the house template saved and put on here (the discourse)…i can’t remember if the building tool still has the option of saving the design as a template but it would be worth double checking or trying to find it if possible :christmas_tree:

1 Like