New wall won't build but I've already built 2


#1

Summary:
I’ve been working on a larger building, building in pieces when all of a sudden I received this assertion -

////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

1 of 2

release-549 (x64)
stonehearth/components/wall/wall_component.lua:377: attempt to index a nil value
stack traceback:
[C]: ?
stonehearth/components/wall/wall_component.lua:377: in function 'connect_to_columns’
stonehearth/services/server/build/build_service.lua:1172: in function 'init_fn’
stonehearth/services/server/build/build_service.lua:469: in function '_create_blueprint’
stonehearth/services/server/build/build_service.lua:1170: in function '_create_wall’
stonehearth/services/server/build/build_service.lua:1157: in function '_add_wall_span’
stonehearth/services/server/build/build_service.lua:986: in function 'visitor_fn’
stonehearth/lib/build_util.lua:696: in function 'grow_walls_around’
stonehearth/services/server/build/build_service.lua:985: in function 'grow_walls’
stonehearth/services/server/build/build_service.lua:957: in function 'cb’
stonehearth/services/server/build/build_service.lua:1450: in function 'do_command’
stonehearth/services/server/build/build_service.lua:956: in function <stonehearth/services/server/build/build_service.lua:954>

///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

2 of 2

release-549 (x64)
c++ exception: lua runtime error
stack traceback:

///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

Strangely I have already built the EXACT same piece (see attached screen shots below)!

Steps to reproduce:
1)Launch Release 549
2) Attempt to build several 300 voxel 1/4 circles (or load the attached game save below ha)
3) Observe at some the assertion shown above.

Expected Results:
Users are able to build whatever their imaginations can think of and definitely build a building they have already been able to build without issue.

Actual Results:
Building multiple carbon copy buildings does not result in any unhandled assertions

Notes:
I thought this issue was due to a piece of stone that sat kitty corner to a singular wall piece but after removing the stone the result was the same.

Also, on the 3rd attempt to use the wall grow tool, the wall actually made it all the way around, unfortunately when I tried to place my first door, I again received the same assertion as shown above AND the door did not place what-so-ever. Understanding there is currently an issue with doors, I have locked down the work-around as explained in ( Doors not placing ) and this is definitely different.

Attachments:
Game Save - 1458895324056.zip - Google Drive

Before selecting to place the wall using the wall grow tool.

After selecting to Place the wall with the wall grow tool. (You can also see the piece of stone I tried harvesting due to think it might be the cause of the issue(mentioned above) on the left of the wall just about in the middle.)

Previous Built walls verifying that at one point, this was not an issue. (Note- the completed wall on the inside is a 300 voxel quarter circle built in Release 543 & 547. The outer complete wall is a 324 voxel circle built in Release 547 & 549

Version Number and Mods in use:
Latest Release - 549 / None

System Information:


#2

Haven’t seen any traction here but here is a template that builds about 66% of the time and I have no idea why? In some cases I have gone ahead and removed the building and just rebuilt without issue. I know its not lack of material related as I did nothing to further gather resources as I made sure I had done that before building.

watchtower base.zip (2.3 KB)


#3

I can’t seem to build anything aside from seriously plain builds. It seems to get too complicated for the Hearthlings to do, so they just idle around the fire, idle at other goblin fires, or do whatever crafts or mines I tell them to. As for building…Yeah. A lot of templates I have from other players, if they’re too complex or something, I get all kinds of pop up messages of the template crashing or something. The game itself doesn’t crash, but I can never place down anything too complex when it’s a template. I even try to build something of my own design, and they’d rather do everything else BUT build. It’s very sad =(


#4

Hey Deathbysnusnu… love the name… anyways, yeah building is tough. I think they re-introduced the excessive scaffolding issue with the latest build. But a few things to check when building (obviously these are not always the issue but just something to double check)

  1. Hearthlings current tasks

1a. Make sure you don’t have a ton of items that need to be looted/picked up queued

1b. Are the majority of your hearthlings mining or eating/sleeping (sometimes you just gotta wait or suspend tasks)

  1. Space! Do they have room to work?

2a. This could be a number of things but if you try to place decorations in the blueprint and they go up before the building is done, 9/10 the decorations have gotten in the way. Refrain from placing decorations on your blueprints and add after building is finished.

3 Materials! This seems obvious right…? Well right now with the material requirements tab not showing the amount of wood needed for building ‘Just the Scaffolding’, combine that with the current issue of excessive scaffolding going up to build something, there is no way of knowing how much you need? Check your inventory and if you are even sorta low on wood, I would chop some more trees… For an example, the above tower needs a MASSIVE amount of wood for scaffolding but the building is something like 9 pieces of wood needed, ha!

Hope this helps


#5

Haa, thankies muchly =D And my Hearthlings have nothing to do when it gets to this point. They’ve finished clearing everything, they have plenty of room, and oh trust me when I say I am NEVER out of materials. xD I keep making new game after new game, and it’s still the same thing. o.o My Hearthlings just don’t like building things that are more complex than a simple four walls and a second floor. I make a flight of stairs and they build the stairs, but anything that goes beyond the stairs I’ve already had built, nope they don’t wanna. =(


#6

Can you drop a template? I’d like to see…

My tip with stairs… build them first and SEPERATELY!

Any time I’ve tried to do stair to a 2nd floor things get wonky. Currently I figure out where I want them, build them them, then blueprint around them.


#7

I can place a bunch of normal looking templates, but a lot of complex ones I get a crash window pop up and then I’m not even able to place it in the game. Also, with one building template someone made available for download, I can place the building template–it’s a fairly big house–and it places down fine, but the entire game actually freezes and then I have to ALT +F4 the game when I click “Build!” after it’s placed.


#8

Well, I’ll take a look if you want to drop a link to the template post location or just grab it from your -

Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_objects\stonehearth\building_templates