Error pops up when i try to build my custom buildings

release-453 (x64)
…nehearth/components/building/building_component.luac:246: assertion failed!
stack traceback:
[C]: ?
[C]: in function ‘assert’
…nehearth/components/building/building_component.luac:246: in function 'load_from_template’
stonehearth/lib/build_util.luac:44: in function 'load_structure_from_template’
stonehearth/lib/build_util.luac:48: in function 'load_all_structures_from_template’
stonehearth/lib/build_util.luac:170: in function ‘restore_template’
…th/services/client/build_editor/template_editor.luac:11: in function ‘_restore_template’
…th/services/client/build_editor/template_editor.luac:20: in function ‘go’
…rvices/client/build_editor/build_editor_service.luac:39: in function <…rvices/client/build_editor/build_editor_service.luac:39>

This is the thing that pops up when i try to place down a house i made. I don’t know why it does this, i’ve tried everything to try and fix it but nothing worked. hopefully it gets fixed soon but it kinda bums me out because i spent alot of time on that house.

Belated welcome, @jaxcalop, sorry for the late reply :sweat_smile:

Do you have by any chance that building template somewhere?
Or a screenshot of how it looked like?
Maybe it has some complex shapes that the game can’t handle when it’s calculating how to build it…