Designing buildings failing mid-design

Every time I see stonehearth update, I hop on and start building, usually just using the default houses to house my settlers since there used to be no option for a second story. As of recent updates, we can now build multi-story buildings, and I decided to start creating my own buildings, starting out with the carpenter’s building. However, once I start trying to build it, soon after creating the stairs, I get errors and visual bugs (leftover floating blocks everywhere), and I’m forced to undo the entire building. As of steam’s latest branch update, after this happened again, now not only did I have to undo the entire building, but now I can’t design a building at all, getting met with more errors.

(I’m not sure how to do a spoiler tag on here. if someone would let me know, I’ll edit this and put the error code in spoiler tags)
The pair of errors I get the first time are as follows:
Error 1: develop-2494 (x64)
stonehearth/components/wall/wall_component.luac:108: attempt to index a nil value
stack traceback:
[C]: ?
stonehearth/components/wall/wall_component.luac:108: in function 'connect_to_columns’
stonehearth/services/server/build/build_service.luac:231: in function 'init_fn’
stonehearth/services/server/build/build_service.luac:123: in function '_create_blueprint’
stonehearth/services/server/build/build_service.luac:231: in function '_create_wall’
stonehearth/services/server/build/build_service.luac:229: in function '_add_wall_span’
stonehearth/services/server/build/build_service.luac:196: in function 'visitor_fn’
stonehearth/lib/build_util.luac:251: in function 'grow_walls_around’
stonehearth/services/server/build/build_service.luac:196: in function 'grow_walls’
stonehearth/services/server/build/build_service.luac:185: in function 'cb’
stonehearth/services/server/build/build_service.luac:295: in function 'do_command’
stonehearth/services/server/build/build_service.luac:185: in function <stonehearth/services/server/build/build_service.luac:185>
Error 2: develop-2494 (x64)
c++ exception: lua runtime error
stack traceback:

The errors I now get when I try to design anything at all are as follows:
Error 3: develop-2494 (x64)
…hearth/services/server/build/build_undo_manager.luac:6: assertion failed!
stack traceback:
[C]: ?
[C]: in function ‘assert’
…hearth/services/server/build/build_undo_manager.luac:6: in function 'begin_transaction’
stonehearth/services/server/build/build_service.luac:294: in function 'do_command’
stonehearth/services/server/build/build_service.luac:50: in function <stonehearth/services/server/build/build_service.luac:49>
Error 4: develop-2494 (x64)
c++ exception: lua runtime error
stack traceback:

Honestly, I really could just make shared housing for everyone, as they don’t care about living by themselves or that their house actually looks nice, but this early in development, that takes a lot of fun out of it. I’ve seen some of the community builds, and I’d like to build things like that, but it’s hard to do that when every time I try to design a building I’m slapped with errors. not that I’m demanding that you “fix this right this instant!”, but I’d like to know exactly what it is I’m doing wrong. I’d like to make a 2-story building with an attached 3-story tower/staircase (for roof access), but as it is, I’m getting stuck at the 2nd floor. if doing the 2-3 story house is impossible and the whole house must be the same height, that’s fine too, I can deal with that for now, but as it is I can’t even do that. if you want text-based blueprints for the house I’m trying to design, I can give that to you, too.

ok, it’s been a week since I posted this, and the only update I’ve received was the addition of “active bug”. Should I take this to mean that, as of right now, I can’t reliably design anything, and should wait a while before trying to make anything fancier than the default buildings? it’s fine if that’s the case, I just want to know so I don’t have to check back every day to see if someone replied to my thread to tell me if I can fix it or not. I understand that the game is still in early alpha, and there are going to be many, many bugs. If it is too unreliable to design a building at this stage, then I’ll save myself the let-down and just play through what’s available with basic shared houses and stone walls (it really, really kills it for me to try and fail at making something fancy, though I can get around that by simply not trying).

if that is the case, then please let me know, and I’ll just look forward to a later update when building has been a bit more flushed out.

oh, and don’t take this to mean that I won’t play/bugtest at all without the ability to design. it’s just that trying to use the design tool and being incapable of using it kills my mood so much that I just close the game and do something else to bring my mood back up. if the tool is unreliable, then i can just pretend the tool’s not there in the first place, and I won’t have my mood spoiled at day 2, and I can continue with the rest that the game has to offer so far, jotting down bugs along the way.

1 Like

I have a similar issue that I’ve been experiencing to this. I was trying to create my own blueprints and when I went to add walls onto my building it refused to add one side onto the building and threw up an error on my screen. Past that point I can no long add anything onto the walls or make adjustments to the building without errors popping up. I’m tried adding doors, windows, and changing the floor plan. It will allow me to undo the floor plan but will not allow me to start working on the blueprint again without closing out of the game entirely. I’ve tried to attach images of the error but it isn’t allowing. I do have saved screen shots of the issues I was experiencing that I will be holding onto if needed though.

From the lack of a screenshot, I can only assume that judging by your description, the stairs are what is giving you problems. The general convention as of right now (Radiant is actively working on adding stairs), is to make your two-storey building with a “gap” in the second-storey floor, and after that part of the building is complete, use the slab tool to add in stairs.

For your attached 3-storey tower/staircase, I think this would have to be designed entirely with the slab tool (I could be wrong); and you should make this as a separate building as well.

So you’ll have have 3 different “constructions”:

  1. 2-storey house with a hole in the second floor
  2. the stairs after that house is built
  3. the tower taller than your 2-storey house (attach with the slab tool)

Hope that helped

(edit: oh yeah, don’t use the auto-wall tool for the second floor. use the one where you manually place it)

Post your screenshots to imgur or another file hosting site and we’ll try to identify the problem :+1:

The 2-3 story building was merely a plan that I was willing to concede on if it didn’t work, and I honestly didn’t expect it to work at this point yet. Rather than screenshots, I’ll just record and upload the footage and add it as an edit to this reply

the errors popped up around the time I was trying to add walls to the 2nd floor (apparently the walls are placed on top of the floor and not around the floor. that’s kinda weird, but ok), and I couldn’t add the walls manually due to planned blocks not counting as real blocks (unless I’m able to add them on top of the floor blocks and I didn’t try that, I don’t remember if I did or not). everything seemed to work out properly until after I made the floor to the 2nd floor, after which point trying to add walls resulted in the error. afterwards, I couldn’t make any blueprints at all, as trying to place any flooring resulted in the 2nd set or errors.

I’ll try to record me playing stonehearth through the designing of the building in mention and add it as an edit when I do. thank you for replying

Edit: sorry it’s taking me so long, I’ve been real busy, and college is about to start back up.

Yep, there’s a “free standing wall” tool that you can place ontop of the unfinished flooring on your 2nd floor.

Make sure you have no interior walls (I’m not sure if they work yet) or else you’ll get a bunch of errors

1 Like

after trying a few new things and playing around with the free-standing walls, I finally managed to build my house without any errors (although I did get some errors when I placed a wall inside the house to make separate rooms and tried to place a roof on that. separate rooms might work on the bottom floors, but definitely not the top floor), and I can still design stuff. sadly I can’t play with the roof as much as I’d like, and so the building doesn’t look as nice as I’d hope, but it’s still decent, as well as a 2-story house, which is good enough for me. however, now that I’ve got the house set up and building… wow… this is weird
I hope my house gets set up properly lol

it seems what caused the issue was using the auto-wall placer. using the free-standing walls allowed me to work uninhibited until the roof, at which point I get errors if I have any walls on the inside of my house.

(~20 mins later) hmm… for some reason, after going to sleep, they no longer want to work on the house. I’ve tried giving them new orders, pausing and continuing the building, and even saving/reloading, but they just don’t wanna build that house. weird

this is what the house will look like in the end:

hey there @Ridesdragons, though its a little late, welcome to the discourse :smile:

my apologies for not replying to your post before now, it must have slipped under my nose somehow :confused:

currently interior walls aren’t an actual feature, so attempting them right now can be rather finicky

[quote=“Ridesdragons, post:8, topic:14822”]
(~20 mins later) hmm… for some reason, after going to sleep, they no longer want to work on the house. I’ve tried giving them new orders, pausing and continuing the building, and even saving/reloading, but they just don’t wanna build that house.
[/quote]strange, though this could be due to the use of free standing walls, as the hearthlings sometimes refuse to build them

at first it seemed because I placed walls on top of walls, and placed pillars right next to each other. this caused the hearthlings to build a ladder next to the outside pillar, but they couldn’t reach the inside pillar from the ladder they built thanks to the pillar now blocking the way. I set up ladders on the inside next to the pillar, and they finally finished the pillars, but then decided they were done with the house and stopped working. there was nothing else they couldn’t reach, so I’m not sure why they gave up, but whatever. I’m pretty sure the reason why they even had this issue to begin with is because they give priority to pillars over the rest of the house, including the floor. it might also be because I placed walls directly on top of walls instead of doing wall-floor-wall, making the pillars stack directly on top of one another, but I would still think the hearthlings should give priority to the first floor before caring about the 2nd floor.

I’m gonna try some different designs with the houses, such as starting the house elevated and using porch/stairs at the doors, and separating the walls of the different floors by floors.

yea I figured it’d be finicky, although I still hoped that, since I got the interior walls to work at all, that it might work. they still might work so long as there is no roof over the interior walls (aka on any floor other than the top floor), I’ll try testing that out to see if that works.

I started using free standing walls because the auto-walls were giving me a hard time. I can try auto-walls again, as my build is not overly complex, but this time I’ll make sure to have the floor on top of the walls so that the walls don’t end up in the wrong spot like before. the free walls are definitely more handy, and if I’m doing something like building a town/castle wall, that seems to be my only option.

quick question: is it possible to design stuff under the walls? I set up a 3x3 stone “foundation” on the first floor where the doors would be, and made the free-standing walls go over that foundation, so that there would be flooring underneath the doors, and it would transition smoothly to road. I had some major issues before when building houses and roads at the same time, so I decided to err on the safe side and just set up the connection part as part of the house and not have to worry about connecting the house to a road.

I can’t wait for when we can design basements without having to dig a quarry where you wanna build the house before you build the house. being able to expand houses downwards would be great.

EDIT: ah, yep, it seems it was because I placed walls on top of walls instead of wall-floor-wall. by separating the walls with a floor, the hearthlings started working on more than just 1 wall. I’ll edit again if they finish building the house.

EDIT 2: nope. they build more walls this time, except they didn’t build the 2 walls they built before, or the walls with doors. stopped after building all the 1st floor walls except the 4 face outermost walls. didn’t build any of the flooring.

EDIT 3: played around a bit with peaceful trying to get the house functioning, tried using elevated flooring+auto walls on the 2nd floor (1st floor just tried placing the walls around my floor instead of on the floor /)_< ), tried to place a roof on that wall, but for some reason the roof was invisible, and clicking the walls ended up doing nothing. after undoing several steps and trying to rebuild what I undid, I was met with errors (sorry, forgot to copy the error log, but it was probably the same as error 3 in the OP). so now I’m under the impression that auto-walls breaks things, and I should avoid it like the plague.

erm… on second thought, it might be due to something weird with how the walls work. to place the walls, I simply made a skeleton flooring where the walls would go, and then auto-placed the walls on top of that skeleton, and then filled in the floor. that might have caused the game to place 2 walls on every block of the skeleton, as it treats both sides of the blocks as “outside”, causing the roof to be confused as both sides of the wall are treated as “outside” and neither side is treated as “inside”. that’s probably exactly what happened. whoops. that’s my fault.

hahah it’s all trial and error at this point, my friend. I’m glad things are started to work!

A way you can make interior walls is by using the slab tool (after the house is built).

You can use that same tool to make the roof you want; either make a flat roof and build on top of it once it’s complete, or don’t place a roof at all and mould it however you please! It takes a bit more time though, of course.

yea, at this point the only way I can get them to build anything properly is to give it to them step by step, floor by floor. I have to hold their hands through the construction. sigh well it’s better than not being able to build at all, I guess.

1 Like

Sometimes they just like taking reaaaally long breaks. Make sure you have enough resources!

But yeah, I find breaking everything down into parts makes it a much smoother process

I don’t even know anymore, man

these 2 are just sitting on a ladder hammering away at… something. nothing’s getting built, but they’re using a lot of wood. but whatever it is that they’re doing, they must be having a lot of fun, as they just sit there hammering away until their backpack’s empty lol

and trust me, I never have issues with having enough resources. at the very start of the game I typically end up with over 500 wood and over 100 stone just trying to clear out my starting point lol

1 Like