Bug: Building won't start building

Tehncically there are 3 problems. The first one doesn’t let me build a roof on the second floor , i got over it by deleting the second floor and placing it again. But now i can’t build the house at all. It doesn’t appear red. When i click the ‘build’ button it just makes a sound and that’s all. Nothing happens. I’ve tried building another house. Same result. I can no longer build any house anywhere as the build button does nothing.
Might be because i’ve saved the building template prior trying to build it , and it caused another bug?
And for the third. I can no longer place templates. Even if there is plenty of space it just doesn’t appear.

Steps to reproduce:

  1. Chose an accesible spot and design the house.
  2. Place the roof. Sometimes it gets red and won’t build so i have to delete the whole floor , sometimes it doesn’t.
  3. Rename the building. (Optional step)
  4. Save it as a template. (Optional step)
  5. Click build ,a sound is played but nothing happens

Expected Results:
When i click build i expect the hearthling to start building and for the house to change into “building stage”

Actual Results:
The house is still in design stage.



Version Number and Mods in use:
A24 859 x64
No mods in use or installed

System Information:
Windows 10 64bit - OS
Intel i5 6600k - CPU
AMD R9 290 - GPU

check if they are all the same building and not two(might be that your issue with the first roof)
press f5 and check if there is any engine crash
if a roof is red it’s because there is nothing supporting it
maybe uploading the save file will speed up any answer :wink: