Building won't build, no red blocks / UPDATE: It builds, but template does not work! / UPDATE 2: It works, but only latest branch!

Hi guys I was trying to build a template and in the end I tried building it (I had dev tools on to have enough resources, etc.) but it said it could not be built. I don’t find any red blocks and I made sure that all pieces are accessible when building the template (I do recognize that it is a pretty daring build).

I’ll try attaching the save file to this post. I saved the building as a template but I can not place it down.

1532431101455.rar (3.4 MB)


That’s such a great building! I’m really upset it won’t build now.

1 Like

This is precisely the reason for me to report this :sweat: I really wanted to finish this and upload it to the workshop, alas, here we are!

if you cant still set it to “build” try selecting it and open console to tip ib

Do you have any modded furniture or anything in it? Or base game? I had a building last night that wouldn’t build and I had to manually delete each piece of furniture until I figured out which one it was. In the end it ended up being the wooden shelf from homesweethome mod… I think… I have so many its hard to tell where it came from :joy:

I have no mods activated other than other templates I have designed myself and the dev tools - no modded content / custom content. This is the Beta version of the game (stable branch).

I know about ib, but I wanted them to build it.

Update: after using ib I noticed that a staircase was going through a floor it shouldnt be going through. This time I could press build, the dotted lines around the buildings turned yellow to calculate how to build it, but this time it said that the hearthlings could not reach certain points. it said “troublesome blocks have been colored red” but again, that is not the case. Anybody knows which part of this building could be causing problems? I am willing to make the changes needed.

1 Like

This is going to be a little bit of test and error. I would say try deleting the gargoyle and/or the flower beds. Go on with all different things until you find what’s causing the problem.

Good luck. It is a lovely building. Kyth.

I had this happen on the unstable branches for the new builder, but not since it went to stable. Try saving the blueprint, deleting the building, and replacing it from the blueprint. If that doesn’t work, you might have to rebuild the building from scratch like I did.

Delete the fences, it should work :slight_smile:

Does it have modded items? Delete those and try again. :thinking:

There are no modded items.

I originally had wooden fences, then I read that someone had a bug with them, so I went with stone fences, given that they worked on other templates. I will try deleting them and will report back.

Update: I removed the fences and it changed nothing :frowning:

Can you see that red colour on the lower floor in the area under the stair? Is it a decoration or an error?

Have fun, Kyth.

Hey Kyth! It’s a red rug. You can see it on my second and third screenshots.

1 Like

I see it now! thx.

If deleting the fences didn’t work I’ll advice eliminate any decoration that is by the walls. Start with the gargoyles, flower beds and those foot candle stands. Sometimes furniture gets in the way of scaffolding for some unknown reason. So, anything that is close to a wall (withing a block) may be a problem. Hit build every time you eliminate something.
Another possible problem is the stair itself. Is it a stair or free blocks? If it is a Stair move it away, literally out of the building or erase it. Hit build. If this works erase the stair for good and make one with free blocks. Then try again.
If this does not work I can’t help any further without looking at the template myself.

Good luck and have fun, Kyth.

Thanks for your tip. I will try it tomorrow!

Also make sure you didnt place items on a wall corner and then moved it making the item go into the wall, i had that happen, and took me hours to find it. It will not color items red

Hello everyone. Good and bad news.
First, the good news. I found the problem! Turns out the red rugs beneath the tables were causing all the fuss. It seems hearthlings can’t figure out in which order they are supposed to place them. After careful trial and error I found out that removing them alone fixed it all. The same template, without the 2 rugs, started building!

with rugs

without rugs!

Now, I decided to start the project. It started with no prebuit items (except some which must be bought from merchants. All the resources in huge stockpiles. peaceful mode, lots of food and 2 level 6 crafters (carpenter and mason) and a weaver helping a bit around. It started with 17 workers and through the progress of 3-4 in-game days, 4 more joined the town.
I know, these are controlled conditions, in a real game town you would have to take care of a lot more. These guys did not even have beds. But I wanted to test the build.
On game speed 4 it took them 20 minutes to finish the proyect.

Controlled conditions and lots of resources.

I only had one incident when testing this. One hearthling got stuck on scaffolding (I am surprised they did not get stuck inside the building, say, in between walls or roofs. However, I made sure that was impossible when designing the building). This means i had to build a short ladder to help him out, this happens on any template though, it means my building does not have any problems when built).

20 Minutes in speed 4 without interruptions and 24 hearthlings sounds possible. Definitely no small feat, however I am surprised that

  1. The Hearthlings built it without any problems, sometimes they had to wait for 1 hearthling to finish a roof, meanwhile 7-10 waited by the fire, but after this one hearthling had done his job they would all continue building.
  2. They did not need any outside help apart from that one hearthling.
  3. The game performance did not lower, it did not crash, there was not any stuttering.
  4. They did not need much outer scaffolding, since my building is pretty much a pyramid, the roofs were very useful to build higher levels.

Thanks for the help guys!


I can save the template, it looks like the building and everything. However, when I select the template in this save or in a new save, it can’t be placed. I select the building, the way I would select any template, but it does not show the “ghost” blueprints on my mouse. I can’t select it or place it down. This means my building is limited to this one save at the moment.

1 Like

I see you’re using the stable version. I tested in our internal version (which is the same than the unstable we pushed yesterday) and I could only build the template by first saving it, then placing it, then removing the rugs like you said (for some reason it didn’t want to build when I removed the rugs on the existing blueprint, could be related to saved data).

So this means in theory you should be able to save/place the template in the unstable build (we’ll update the stable very soon). Unfortunately, I don’t think the issue with the rugs will be fixed but you can try placing them after the building is finished.

And thanks for sharing, this is a gorgeous temple! :slightly_smiling_face:

Hey, thanks for your work!

This is the latest stable branch of Stonehearth (beta, not the unstable branches). I will try the template on a new, clean save, and see if it works (I will first remove the rugs and see if I can save the template like this).

I don’t mind the rugs, they were just a little bit of extra for the design. I am glad the structure works!
I will be uploading this to the workshop soon :slight_smile:
Again, thanks a lot!