Building Blueprint not working (THE CURSED TEMPLATE!)

Summary: With this building in Particular I have a small issue when trying to build it; an Engine error of some sort is bound to happen, and the building just turns int floating furniture and findows. Because of this, I can’t remove the building (Because technically there is none) And it kinda bothers me to see just floating props when there is supposed to be a building planning. I will upload the Template here, if ANYONE can help I would be highly appreciate it

dwelling ii

Attachments: None

Version Number and Mods in use: No Mods, Version 0.22.5 X64 build

System Information: 3,50 Ghz. 64 bit Operative System, AMD-FX six-core precessor. Windows 7 ultimate

dwelling ii - (38.5 KB)

Thank you for your attention!

1 Like

Stonestomach! So the good news is that this template is amazing. I believe the main issue with it is the crate under the stairs which initially caused my entire UI to crash. Once I moved it from underneath I no longer got an error and it builds more or less. For some reason it refused to finish the build due to the decorative rug not being placed even though it was. Some of the issue appears also to come from an intermingling of floor and slab type voxels.
My recommendation is to load up the template and take the furniture out and resave and also to ensure only slabs are in the chimney and other areas that are not specifically a floor. Hope this helps. Once again it is an awesome looking build.


Thanks mate. It’s not the only time this sort of thing happens to me, Buildings not reaching completion due to faulty furniture placing.

I have a little Issue with a building in specific Is another post I made having the same problem. So, yet again, thank you for your help and I’m glad you liked the Template. Keep it if you want to

It is a great build and already in use :slight_smile:

1 Like

The problem is, that I cant even load the template, so I cant even begin building planning

Let me see if I can fix it. Nope I can never seem to get it fully built. I don’t really know why. Attached is the template that will “almost” build.

dwelling ii (67.0 KB)

Everytime I try this it gets worse. I tried re - designing the building and whenever I place a structure it vanishes, it stops existing (That means I can’t even use the building editor anymore!) So, evidently, MY game is wrong, as It constantly has engine errors

I just tested it:
Place the building, the error will occur,

THen, you cannot use the building editor anymore

Actually, I’ve resolved a lot of my build issues by removing furniture from my templates. It seems, often enough, furniture is placed before the building is finished, and scaffolding can’t be built, or the building won’t complete if 1 piece of furniture is missing. When that’s the case, Hearthling’s won’t take scaffolding down. And it’s super annoying. Sometimes I have no choice but to “ib”.

The problem is another one. Read the whole post, because it is much more complex than that. My whole game just brakes, not only the building in question, but the engine fails whenever I try to make anything in thet saved game

I get engine errors all the time, but only once did it effect my editor. When you say “my whole game just breaks”, Does everything stop working completely? (besides the editor). Are your Hearthling’s still about their business? also, have you tried running in an earlier alpha? Details please :slight_smile:

1 Like

Please upload your stonehearth.log file. It might give us an idea what is actually occurring.

Yes, Hearthlings still mind their own business, Crafters keep on operating, and can begin building other buildings on a template, but the editor is completely useless, whenever you try placing anything on the ground, either it disappears or simply turns invisible, IDK. It’s like placing that template anywhere will result in inhability to use the editor on that saved game.

Certainly, One minute

Rosenfield Save (4.1 MB)

As you can clearly see, the building is placed. You then tell me if the building editor works for you
And yet again, thank you all your your attention

I downloaded your template and yes, it broke my build editor too. It kinda disables it.
Though I restarted the game and tried again, and they are building it fine now.

You should not save when the game throws an error. They get worse with time once one got in.

It is definitely an interesting error. I am building your original template in the save now. I will let you know if it finishes. I agree with Cody_Thomas and typically don’t put furniture in my templates.

And once again the building completes but I can never get all the furniture to register that the building is actually done. Recommend rebuilding it again without furniture and saving it.

Interesting. Do you get anything from the stonehearth.log file?