Why do buildings stop building

How do you post a screenshot

1 Like

There can be lots of different reasons but they’re usually fixable. Post a screenshot / savegame and people might be able to help you figure it out.

The big one is that hearthlings need space to get to the spots where the next block needs to go, so make sure there’s room to build scaffolding and no part of the building is blocked off and inaccessible.

Sometimes building ladders to the lowest built point helps.


I find that the odd building stops construction after I reload the game. Probably something to do with the AI or an observer figuring everything out again but I can’t reproduce it consistently.

If after an attempt or two, I resort to the console command ib for insta build! It’s a complete cheat as resources aren’t consumed but I tried playing fair at least once. It’s ctrl+c, on a Windows machine, to bring up the console. I use it only for debug purposes.

Images/Screenshots can be included in these posts just by pasting the image right in this box.

1 Like

How close is that house to the mountain? And do you have enough wood for scaffolding? It looks like the back wall isn’t being built, so mining some mountain off should fix it.

The insta build is not working

First I’d try some of the suggestions here just in case it is a placement or resource issue. But perhaps you’ve checked that to death which is why you came to the forums. :wink:

Insta build needs the house selected where you’d see the option to edit, pause or resume building. From your screenshot, the house isn’t selected so you may have ib’d something else or the game just tosses a “false” true when it has nothing to do - it’s not really wrong, it built nothing really well.

Select a component of the house, not scaffolding, like the roof and try ib again. I think that should work. It’s tricky the first few times.

they just stop doing that to

thank you so much it worked

You’re welcome.

Looking at the screenshot, I think Reedo was on to something. Your other two buildings weren’t as close to the cliff as this last one was - they both had a side with one deeper block for the hearthlings. At a guess, they wanted to get behind your house for more scaffolding.

I’m curious, do the roofs of the other to buildings touch the cliff? I wouldn’t mind trying to replicate this in a dummy game myself.

im done with this it just happens again and again and the ib dose not works on it ill be back when their is and update for this.

See you guys later peace :wave:

They don’t or it wouldn’t have worked :smile:

Mate, just keep some more distance to the cliff and you will be fine.

Do you mean wouldn’t have been possible to place or hearthlings would’ve gone stupid? I know the base of the building can’t touch a wall as the roof is one more block over, but you can get a roof to touch.

I’m a cave dweller for the most part, not too familiar with buildings outside of walls or structures for the sake of net worth. :wink:

The roof cannot touch either. There has to be space for scaffolding on the outmost points of the building. Easy :slight_smile: i think the game needs to communicatw this better though. New players like our friend here have a hard time otherwise.

1 Like

That’s odd. The game will let me place the building with the roof touching the cliff. ok. time to hit 4 on my keyboard and see if this sucker builds or fails!


they’re mid-build on a cosy cottage for two. Base is one block away from the cliff and the roof “should” touch if it completes. At the moment, hearthling Marianne may die of hunger as I don’t think she can get down from the back scaffolding: I’ll give her until morning to see if her friends save her before I place a ladder.

Oh, of course they start building. But you should see issues arising once they start on the roof :wink:

Got it to work. It wasn’t pretty though! Marianne would’ve died if I didn’t build a ladder inside the house so she could walk out; she even built it herself. Since she was stuck, they stopped building too.

Taking down the scaffolding took longer than building the house. I’d say that scaffolds shouldn’t rely on the ladder placement as it’s the ladder that is the make it or break it factor. If the scaffold just acted as a ladder mechanism on its own, the AI would be much happier I think and less dead. Some building issues may just be solved with more ladders as I noticed a lot of idle/building back and forth for the workers.

I give you my cabin touching the cliff:

I don’t care for houses myself though. I like being a cave dweller and the whole hobbits united angle. :smiley:

Cool! I’ll have to try this out some time, the devs must habe made some improvements. There was a time when you needed two spaces between roof and cliffside. Obviously it is much better now. Eventhough Marianne dying would have been sub-optimal.

I have a similar problem with some steps that i built myself, where each time I try to get them to build it they get so far and then stop, but each time they get to a different place in the build.

I think that part of the problem may be that I saved mid build the first time around. I tried pausing and restarting, removing and rebuilding again, but it never completes.