Buildings halted and ladders not beeing placed

I have a town where building are not being build, and ladders are not being placed.
I was just playing the game on peaceful, and first two building i made was build no problem, then on the third building i had to use the console command ib to finish the building, and now on my newest building the workers stopped building on it and i can’t get them to start again.
Also i tried to place two ladders in another part of the city, they are not being placed.

I have attached the save game where this happens.

Version Number and Mods in use:
0.17.0 Release 610 (9.0 MB)

** System Specs **
Windows 10, Intel i7-4770K 16 Gb Ram NVIDIA GeForce GTX 750 Ti

** Update **
Added System Spec, and also i tried creating a new town in Peaceful mode (The Ascendancy/ Temperate )
Build 2 x Shared Sleeping Quarters, 2 x Dining Hall.
On building 4 the Dining Hall, workers stops building and newer continues.

Even after today’s update to Alpha 18, buildings are still not being build.
Tried to remove the building and making it again, and workers start on the new building, but stops again quite fast.
And also still can’t place ladders.

Anyone reading this???

It would be nice to get some kind of feedback on my problem, would that be possible?

I am getting these errors too. Most of my buildings are not being completed. The doors dont get placed and scaffolding remains in place


I took a look at your save. Turns out your Hearthlings don’t have enough wood for whatever reason. Despite the building info screen giving hints to which resources are missing, it doesn’t take into account wood used for scaffolding. That means wood used in scaffolding still count as available resources when they actually aren’t.

Still doesn’t seem to really add up in your case as the unfinished building barely has any scaffolding to begin with and the info screen show 60+ pieces of wood available. Yet after cutting down some more trees the Hearthlings happily continued with building. So in short: Not really sure what the cause of the problem is in the first place, providing more wood seems to be the solution.

Edit: And I can’t find the specified amount of wood in any of your storages. Wonder where it is. Tried emptying every crafting cues to make sure that the wood isn’t sort of reserved but it didn’t do anything. Haven’t looked inside the backpack of each Hearthling, though, but it would be odd if they’re carrying it around without using it.

Hi SachieMF,

Yes cutting down some more trees seem to make them continue building.
But they still do not quite finish the building, now its missing doors, and lamps, and the scaffolding is still (9.6 MB)

Yeah, got the same issue. I noticed the rim of the roof is solidly colored. Maybe that’s a symptom pointing to a possible reason. While creating the template, did you do anything special? Offsetting the roof? Looks like the roof is merging with the wall.

No i did not do anything special with the roof.

I do get this error when i open my save game.
develop-3092 (x64)
…/components/scaffolding/scaffolding_project_flat.lua:99: attempt to index field ‘_scaffolding_region’ (a nil value)
stack traceback:
[C]: ?
…/components/scaffolding/scaffolding_project_flat.lua:99: in function <…/components/scaffolding/scaffolding_project_flat.lua:95>

The solid colour of the roof rim appears always depending on the orientation of the building. Design a new one. Build it with two different orientations and you will see it.

@Rudi_Hansen I’m also having that error. The worst of it is that I’m not building anything atm. I’m still trying to find out the cause. Let me know If you discover anything.
Have you disabled the auto-crafting of doors, windows and lamps? If you haven’t, may be, as there wasn’t any wood available the game cancelled it itself. Try ordering them yourself and see if they finish the building.

Have fun and good luck, Kyth.

Speaking about Buildings being “Halted” I’ve built buildings against stone before, more specifically actual terrain.

As my hearthlings build the building, they’ll sometimes go off to go do some random thing and never come back to finish.

Examples for this include but are not limited to due to memory.

1a. Hearthling is currently Building
2a. Farmer places down some food after harvesting.
3a. Hearthling stops building, then runs over to deposit the food and doesn’t go back to building.

1b. Hearthling is building
2b. Other command is issued Eg. harvest trees
3b. Hearthling stops building and goes off to harvest trees, then never comes back.

The list goes on.