Hearthlings have stopped building this house and will not continue... (Image Included)

All help is appreciated :slight_smile:

This kind of thing happens to me with some frequency when I’m working on bigger buildings. Typically, it’s just an issue with the scaffolding not reaching the next place where your workers need to access. Try looking around inside and outside the building for any unbuilt sections which are at least two bricks out of reach (e.g., a low wall two bricks off the ground with no scaffolding), and build some ladders manually.

There are very few building problems which can’t be solved with more ladders. And if all else fails, you could open the console (ctrl + shift + c) and type “ib” while you have the building selected to finish it.

1 Like

Is that a mountain directly behind it? If it is, I found when I placed my buildings directly near a mountain or cliff, without proper access to the base of the cliff or the back of the building inhibits them from building further at times.

I looked around my building and couldn’t find any obvious places that were unreachable so I think I’m just gonna end up using ib. Does ib use up resources?

The house is 2 blocks from a lake, not a mountain.

Instant build uses no resource. Keep in mind that your villagers need 2 spaces around a building to place scaffolting and to get there. Additionally they need 1 more row for each block you build as overhang

After you commented I built a bigger area around the house and they still didn’t start building. I have also build some ladders around the house and no luck :confused:

1 Like

have you tryed to save the template and build it somewhere else?

I have made building directly against the terrain walls and they just make scaffolding inside the houses. once there is open space on the out side they start a new scaffold there.

and if you feel you wanne pay for the building just make a crate/urn and let it fill with the materials you need and use the “destroy” command on it.

When my builders stop building, I often can fix this problem by saving and restarting. Close out the program and go back in.

I have been avoiding 2 story buildings while I wait for the next big building update but I think it is worth a try. Also, make sure you don’t have any resources lying on the ground. Some things want to be stored before they are used.

Let me know if you find a fix, I have a similar issue. Seems to be a A14-A15 issues.

I tried saving and reloading way too many times and it never did anything.

Yah I think I’m just gonna build 2 story houses from now on.

I ended up just “insta-building” it through the cheats console cause I couldn’t find a fix :frowning:
I guess that’s kind of a fix though? It doesn’t use resources but after messing around trying to fix it for 2+ hours I gave up :stuck_out_tongue:

Multi-story buildings are totally doable, without any real issues. This one is relatively complex and still managed to be built without any console commands… just a lot of manually placed ladders and babysitting.


I am finding this error as well. However, mine is accompained by 2 error messages.

develop-2972 (x64)...onehearth/components/building/building_component.lua:154: attempt to index local 'entry' (a nil value)stack traceback:
[C]: ?
...onehearth/components/building/building_component.lua:154: in function 'get_dependencies'
.../fixture_fabricator/fixture_fabricator_component.lua:163: in function '_are_dependencies_satisfied'
.../fixture_fabricator/fixture_fabricator_component.lua:202: in function '_start_project'
.../fixture_fabricator/fixture_fabricator_component.lua:41: in function <.../fixture_fabricator/fixture_fabricator_component.lua:39>


develop-2972 (x64)c++ exception: lua runtime errorstack traceback:

There is plenty of room around all the buildings and terrain (4 spaces). I think an object went missing somewhere which made them unable to continue working.

Here is the building file:
File on github

I am having a similar issue, though I am on the latest version (A24 I believe) and the main issue is they are taking FOREVER to get to work. The issue is not that they are unhappy and thus refuse to work, nor are they busy with other things or missing materials. I seem to get this error after I begin making complex buildings or I get far enough in the game. The error message I am getting is as follows:

release-821 (x64)[M]
…hearth/components/scaffolding/scaffolding_region.lua:1092: attempt to index field ‘_scaffolding_region’ (a nil value)
stack traceback:
radiant/modules/commons.lua:53: in function ‘report_traceback’
radiant/modules/commons.lua:64: in function <radiant/modules/commons.lua:58>
…hearth/components/scaffolding/scaffolding_region.lua:1092: in function ‘_update_scaffolding_size’
…hearth/components/scaffolding/scaffolding_region.lua:499: in function ‘fn’
radiant/modules/events.lua:288: in function <radiant/modules/events.lua:285>
[C]: in function ‘xpcall’
radiant/modules/commons.lua:73: in function ‘xpcall’
radiant/modules/events.lua:285: in function ‘trigger’
radiant/modules/events.lua:375: in function <radiant/modules/events.lua:374>
[C]: in function ‘xpcall’
radiant/modules/commons.lua:73: in function ‘xpcall’
radiant/modules/events.lua:374: in function ‘_fire_async_triggers’
radiant/modules/events.lua:452: in function ‘_update’
radiant/server.lua:67: in function <radiant/server.lua:64>

If someone has a fix, please let me know. The game is still playable, but it is really frustrating, I usually give up and just “ib” it after awhile. Thanks!

@Fawnzy23 Reading the error message, it looks like the scaffolding failed. The ‘_update_scaffolding_size’ makes it seem like they were supposed to build it higher and, for some reason, can’t. I don’t know if it’s manually fixable, but you might take a look around and see if there’s some uneven scaffolding around the build.

Thanks, although this seems to also hold some difficulty over buildings that don’t require scaffolding (roads), although eventually they’ll build it. Also, it’s been happening on several of my saves, modded and unmodded. If I were to destroy all the scaffolding on a specific building that’s having issues, should they try restarting with the scaffolding? Or would that break it more?

I don’t actually know. That’s one method I haven’t tried. I would certainly save the game before attempting it.

It didn’t really work :confused: please, lemme know if you find another fix :+1: thanks!