Weird Crashing bug


Steps to reproduce:

  1. Stonehearth Alpha 19 stable release
  2. i5 4460 and 8 gb g skill ram
  3. ?

Expected Results: Game without crashes

Actual Results: Crashing all of a sudden

Notes: i was just playing but it keeps happening if i play stonehearth for about 20 or 30 minutes it just crashes all of a sudden

Attachments: stonehearth.log (367.0 KB)

Version Number and Mods in use: alpha 19 and some of the community game enhancements mods nothing special

System Information: Core i5 4460 8 gb of g skill ram and 500gb harddrive intel hd graphics 4600

I am not an expert but it looks like you ran out of memory. If you look at the log, it says near the end that you’ve only got 200 mb of memory left. I think that’s about the minimum your OS requires to run properly. Have you tried running the game without any other apps in the background?

1 Like

Do you have force_32_bit enabled?
Sounds like you run out of memory while playing on 32bit (but I might be wrong).

Does the 64bit version work for you?

1 Like

no the 64 bit version still does not work like in last alpha i dont know why it’s not working but i lag alot more on 64 bit espcially those ridicoulus lag spikes are unhandable so i used 32 bit too fix a bit of the lag but seems that only calls for more problems it sucks that i cant play normally

and i dont run any programs in the background at all

On 64bit, do you get the spikes since the beginning or only after some hours playing?
Does saving and reloading / restarting help?

on 64 bit i get the lag spikes at the beginning and they get a little worse over time saving and reloading or restarting does not help

If you only get spikes on 64bit and they happen right after you start the game, then it’s another application interferring with the game.

Have you tried disabling your antivirus / firewall and seeing if it helps?

my firewall is off i have no antivirus because it glitches out my system and there is no background programs except for the one the computer and steam needs

I wonder what’s happening then. Paging @Albert for thoughts.

1 Like

Shot in the dark here: can you take a screenshot (or two or three) of your task manager Processes tab when Stonehearth is running? We might be able to catch something there that is interferring.

There you go and a small side note i noticed another weird thing if i click ok when editing my settings it does nothing i can only click cancel is that normal?

it’s the same with 64 bit

Not seeing anything that sticks out to me, thanks for posting!

I still suspect anti-malware or security software is interfering with the client-server communication. What is “Antimalware Service Executable” in the first screenshot?

That’s Windows Defender. I’ve never run into it interfering on my system before, but it’s worth a try adding Stonehearth to the exception list.