Warrior and Goblin Camp bugs

So I encountered three more bugs while I was playing a game (that I desperately hoped would last at least 20 days :stuck_out_tongue: Seems I don’t have the capacity for luck such as that. hahah.

In case this assists:
First problem occurred fairly early in the game, first few days.
Second and third problem occurred later, at day 10/11.

Anyway. First problem that’s occurred throughout this particular play through was that I had two of my three soldiers refusing to upgrade their gear (armour&weapons), however when goblins came and slaughtered all of my warriors and I proceeded to recruit new ones, the new soldiers happily went around upgrading (evidently they learned from their comrades demise that it was probably the smart choice)

For the second and third problems, they work in on the same scenario.
The scenario was that I sent my three new warriors to invade the nearby goblin camp. They charged in, massacred them, and I cancelled the attack command for them to go home. They ran halfway back, then ran back and forth between two grid squares until they got tired, went to sleep on the ground, then proceeded to resume (I tried putting in new commands, cancelling them, and it didn’t help the issue)
Here you see two of my soldiers doing the hokey pokey (the third is sleeping under a tree down the hill):

On top of this, as the third issue I encountered, attempting to loot the goblin village didn’t procure the results I was expecting… That being I could only loot their wood stash?.. While I couldn’t pillage that shiny golden chest, and nor could I rid myself of the encampment. There was a raider sitting on a skull fire pit and I couldn’t kill him either.
Here you see the Goblin encampment with that raider still loitering on the fire pit, untouchable. I got the confirmation message of killing the chieftain, and the stuff unlootable:

As before, I’ll keep the save game in my list in case extra details or screenshots are required.
On a side note: No active error messages were involved in these cases.

2 Likes

the issue with the hokey pokey i have seen one time in an older version but i could fix it with an new attackorder ^^

^_^; Like I said, fresh attack orders didn’t fix my hokey pokey. It was the first thing I tried in an attempt to fix it.
I assume it’s a path finding or order error of some kind.

2 Likes

I was able to make my soldiers return giving them a defend order near the town and then activating the defense mode. They ran to the point and when I turned back to normal mode they went patroling again.

Nevertheless, I got shocked when my soldiers seemed to put away their weapons and started to help the others instead of patroling. I thougth that they had lost their equipment, but it was just a scare.

Mayor problems (or not) was that when goblins appeared, they came indoubles: two camps at the same time and just on day 7-8. But then another bug happend and it was that one of them never developed, only appeared the chief, and the other selfdestroyed when, as I paused the game to read the message, I responded to it offering what they asked for, then I got another message tleeing me taht they were going to go to my town to get the materials, and just after it, another message telling me that the goblin camp had been defeated. All these happend messages while the game was PAUSED (the double appearance, the menssages and the self destruction) and I got red-error-windows. However, the goblin camp wasn’t destroyed completely, some buildings are still untouched, but I think this happend because the camp appeared half in one layer of terrain and the other half just below, as shown in the image.

1 Like
  • Potential Work Around

  • Thanks @Ogliath . I tried the defend order, which didn’t work for me unfortunately(but might for others). However, the goblin on the bone fire pit decided to raid my village shortly after, and then a couple more spawned at the bottom of the hill. (But no more spawned on the fire pit)

  • I gave my soldiers attack orders at my village to kill the invader (since they seemed to enjoy chasing the red flag), then I placed it at the goblin encampment, where they killed the remaining goblins that magically appeared, as well as the buildings, totems and barricades(I had to throw flags down for pretty much every single structure there). Shortly after one ran off to “Chase a large chest” as the game put it, while the other two had a veritable feast and a long nap at home. :stuck_out_tongue:

  • Now they seem to be working fine again. Still an unusual bug that needs fixing, but at least it’s able to be worked around I guess. ^_^;

  • Potential source of the problem

  • After looking at your post where you had a goblin encampment problem too, I’m wondering if my bug may have originated also from the fact that the encampment was on uneven ground? (i.e. halfway twixt a Hill and plateau). Which I imagine could quite easily disrupt the path finding if it wasn’t prepared to compensate for that or even disrupting the general proper function of the encampment itself which in turn branched out to cause other problems that couldn’t cope with the bug.

  • (Another reason this seems likely to me is that the encampments seem more structured and at home to belong on entirely flat ground, so I’m wondering if altered land levels weren’t accounted for in the initial implementation?)

Morning! It is Day 4 of Deepmun nigth in my new world and…

I have just got the self-destruction goblin camp error again. It is the first camp that appears, this time alone. It has happened again what happend yesterday: after a first message announcing the goblins arrive, I have paused to see where the camp is and read the message propertly, and a few seconds later the camp has desapeared leaving the two level crater shown in the picture and the third error of the world (the two previous one where lighting errors).

The only things that remain are some ores (the content of the large chest?) a weapon and the chief. In the pinture you can also see some logs, but before the error happened there was nine, so some of them have also been erased.

I am starting to think that the terrain has someting to do with this bug, because, again, the camp has apeared on two levels. Well, a very little part this time, but some area.

Unfortunely, I cannot take new pictures of this world bug, because I am playing on a laptop and it has overheated and turned off before I had saved the game :pensive:

1 Like

When I get the chance, I’m thinking of starting a couple of new worlds for an experiment of this issue. One in another area of uneven land, and another on completely flat land.
That way we may be able to ascertain if the problem is due to the camp spawning on multiple terrain levels or not. And if it occurs every time they spawn on uneven terrain.

@Ogliath , Care to join me in this experiment for more accurate results? :smile:

1 Like

@Wuelfe, I was waiting the computer to cold down a little and start the experiment :smile:

Let’s go!

1 Like

@Ogliath Excellent! I should hopefully have my tests and results in some time later tomorrow or the day after(Aussie time) if nothing comes up to prevent such! :slight_smile:

Okay, so I have an update after a couple of play throughs. Some work arounds, and some extra problems.
I’ll also throw it in as a summary for solutions I’ve found for the issues of my original post.

  • First Problem
    Referring back to my first problem mentioned, it happened to me again and I figured a fix:

  • Problem

  • Solution
    Changed occupation of all soldiers to standard workers. Then changed them all back to soldiers again. This fixed the problem and they happily upgraded themselves.

  • Second problem
    Solution to work around the second problem was mentioned in an earlier post.

  • Problem

  • Solution
  • In other words, setting new attack orders to destroy all of the goblins and camp structures tends to fix the problem if it occurs.

  • Third problem

  • Problem

  • Solution
    Wait it out, the goblins on the fire pit will eventually go to raid your village, leaving the fire pit and being free game to kill. After they’re dealt with, the soldiers will happily annihilate everything in the goblin camp.

As for Ogliath’s found problems, I still havn’t encountered the double camp problem (early days yet). Nor the self destructing goblin camps. ( @Ogliath Did you surrender to their terms for it to happen, or was it just as they appeared? )

I did come across a couple of new issues (well… One was more just an annoyance really…)

First one was when I decided to experiment with conceding to the goblin’s terms and give it tribute. I met all the requirements, had 3 Rabbit Jerky’s in my stockpile, but it only registered 1. Not sure what happened there…

Naturally I had to fight them due to this, so I went into Viking Berserker mode and charged their camp. Killed them all, destroyed them entirely and successfully.
Then I saved the game. Closed it to manage my screenies. Then proceeded to open it again and load from my last save… Resulted in an infinitely increasing number of errors (which all become the same calendar_service) error. Unsure if related, or just a completely random error jumping in. (My next game didn’t procure this error)

2nd game tonight. I managed to successfully get a multi-level Goblin camp. Other than one… annoying problem I encountered, nothing went wrong with it, or its destruction.
The problem that I did encounter was that one of the tents decided to become a tree house. :confused: I tried cutting the tree down, the tent remained where it was. So I had to build a full stairway to heaven to access the mysterious floating tent. :unamused:

(P.S. I know I said I’d post it later tomorrow… but… I got bored. :relaxed: )

2 Likes

[quote=“Wuelfe, post:10, topic:11497”]
As for Ogliath’s found problems, I still havn’t encountered the double camp problem (early days yet). Nor the self destructing goblin camps. ( @Ogliath Did you surrender to their terms for it to happen, or was it just as they appeared? )
[/quote] Well, the first time yes, I did surrender, but the second one I couldn’t: I didn’t even have time to read the first message they send you, they desapeared seconds after appearing.

Now I have been playing a flatter world and I have been able to deal with the goblins properly.

I have also found a trick to get better prepared to deal with them by acting like surrendering, but being actualy creating cool weapons and armors. :smirk:

They last quite long to ask you for the material and then wait another good time without been given it to them. I needed over half a day more to completely equip my soldiers and the goblins had no problem waiting for an answer :stuck_out_tongue_closed_eyes:.

I had the same, hahah. I had one warrior ready, made them wait, then suited up 3 more warriors with mauls, wooden bucklers and padded armour. Which was more than enough to total them. Heheh. :grinning:

I’ll have to retry the surrender and see if I can get it done without that silly bug.

Does the camp disappear when you surrender to their terms? Or do they sit there and occasionally demand more tribute?

They sit there and demand other things later (more or less depends, I got a first message asking fot 40 logs and 7 rocks, and them another demanding little food).

No, the self-destroying bug doesn’t seem to have anyting with choosing surrender or attack, I have try both in a previously stable camp and worked just OK.

I was playing a world and got to about day 27ish and the Goblin King came around demanding copper and wood. I surrendered to give it to him and he said he’d be back after awhile. When he came back however I was in the process of moving my ore and stone to a new location and I let the message sit up for a minute. Well will I was waiting for my guys to move it, the Goblin King died to Undead and I after that I couldn’t get rid of his message so I saved and restarted and when I came back the message was gone and I thought everything was all good until I tried to raid the rest of the goblin camp and my warriors just stood in the camp and wouldn’t attack and then alot of other goblin camps popped up and I couldn’t kill them either and then the goblin camp with the wolves came along and the wolves started to eat all my food and there was nothing I could do to stop them. I tried calling them to defend, I tried upgrading weapons and armor, and tried multiple attack orders still now fix. Can any one help me? :slight_smile:

1 Like