VoxelShop (Voxel-Editor)


Im trying to use voxelshop but it starts bugging out and the menus start appearing spammed across my screen.


@cole3050 Could you please give more details. Which operating system are you using? Are you using the native installer or the Java version? When do the popups appear, when you start the program or when you do a specific action? What do/does the popup(s) say? Without this information it’s unfortunate very hard for me to know the cause and help…


-native installer
-Its the menus, they were randomly glitch out when I hovered over the top of tabs and start following my cursor. It stopped glitching out when I ran it as admin.

[update]: nope even running it in admin It breaks.


Which operating system are you using? I’m assuming windows? Which version of wondows and 32 or 64 bit?


Yes, Windows 10
64 bit


Kk, would be interesting to see if the Java version has the same issues. I don’t have windows 10 vm to debug unfortunately… Let me see if there are any known issues for Windows 10 with jpct


Does the bug actually prevent you from using VoxelShop? After using the menu you need to rotate the view to restore it and it should just be a minor inconvenience?


Once it starts bugging out it doesnt stop till I restart voxelshop.


How well does voxelshop work with stonehearth model animations? I know stonehearth has a unique way of rendering animatinos and that they use 3DSMax


@cole3050 Even when you pop out the rendering window? (hold ctrl to bring back frames for floating wondows)


Animation is still not released with the latest version of VoxelShop. There are some other improvements I need to do before I tackle it.


Im trying to figure out what exactly is triggering the glitch.


That would be awesome to know! Maybe the help overlay?


no the help overlay has been fine.


Does only one of the views bug out or all (side views and main view)? Or does the whole program glitch? What happens when you pop out the render/view subwindow?


all of it, Im using it atm with no issues but randomly it will bug out.


Interesting. How often does it happen? Do you feel it happens less now? Have you tried restarting your computer?


It sounds like it could be related to the help overlay. I’d be curious if restarting your computer fixes it.


I tried that when it first bugged out, I also tried reinstalling it to see if that helped.


I looked at some things but still have no idea what might be causing it. Let me know if you have any more information!

Anyone else here having issues with windows 10?