VoxelShop (Voxel-Editor)


#223

also, just found another… using WASD to move, i get an error msg in the console, but it does not tell me why (although nothing seen happens and i can still use it)


#224

Hi @blackflux :wave:! Is there a way to erase multiple voxels according to their color? (for example, I clicked a single blue voxel and it’ll automatically erase all voxels with the color blue)

I find it hard and consuming to erase voxels when it is of large amount. I am making do with doing it manually and by using the select tool (X key). Thank you for reading :slightly_smiling_face:!

EDIT: Nevermind @blackflux :sweat_smile:~ I just found the tool that has the similar function I am looking for. I just did a quick look again in the UI checking their description and I finally found the one (Expand Selection by Colors). Why did I not see this sooner!
Thank you for the hard work you put into VoxelShop :sunny:!


#225

Getting really difficult problems with importing and exporting in Voxelshop. Not sure how responsive this thread is anymore… however:

I’m trying to create animations for hearthlings using blender and voxelshop.

So what i am doing:

  1. Importing body.qb into Voxelshop.
  2. Exporting (without editing or moving the original model) the model into a .dae file.
  3. Importing into blender, following the same process for the head.

The problems im facing:

  • The skeleton file from Stonehearth folder isn’t lining up with importing .dae file from Voxelshop.

Why i think it’s nothing but Voxelshop:

  • I have tried physically every setting to get the exported body.dae model to line up with the skeleton from the game and it is nowhere near.
  • I asked a friend to send me the body.qb file (exported out of Qubicle into an .obj file). Imported this into blender and it lines up perfectly with the skeleton.

Somehow the coordinates when exporting into .qb or .dae files from Voxelshop aren’t correct.

I don’t know how to go about animating without asking people to keep sending me my files exported out of Qubicle. I also get coordinate problems when exporting normal .qb files out of Voxelshop. When following the ‘suggested’ settings to export for Stonehearth under the .qb extension tab, i end up having to change the settings of the export so that i’m not messing about with all coordinates when modding.

I really find the workflow of Voxelshop quick, easy and intuitive. But when it comes to importing existing, or exporting current models, i get so many little problems that have to be tweaked when coming back into Voxelshop.

I hope you can figure out some of these problems because i really enjoy the Voxelshop program vs Qubicle.


#226

@Brandon_Carlton you should check Voxel Pirate videos in youtube
they are 4 years old but i tried last week and got some animations going :wink:
it has some things that are not exactly as said in his vids but really close
his links are not working as for what i remember but i found them here in the posts (cant remember which ones :frowning: )


#227

Trust me @No_Name. I have had animations working. I started making animations using .obj files which were exported from Qubicle by a friend. But when i try to export from Voxelshop, the body and head are in the wrong place and wrong orientation. Im not sure what the difference between these two exported files are. I dont know how to check either.


#228

@Unreal_Gam3er hey i know it was a month since you reported this

but have you tried with this checks?

Use origin as zero
Use right handed z-axis orientation
(i believe qubicle won’t be able to load them anyway but voxelshop can for me)

i’m using those two even if the first one says to be “unchecked for stonehearth”
btw using 1.8.02


#229

@Brandon_Carlton hmmm i have no idea about .dae
are you using some strange body or the heartling standard one?
if the standard one then just search for male.obj in the forum
otherwise i’m out of ideas :confused:


#230

See .dae is the only file Voxelshop can export that can be imported into Blender for animation. Or so I thought.

I’m importing the male.qb body into VS. Then exporting as .dae. Then importing that into Blender.

I would do that however. When it comes to me animating other models that I create in Voxelshop with different skeletons, I can’t simply browse the forum for my model in a .obj file haha. I’m simply trying to figure out what VS is doing differently to QBCLE.


#231

Have you looked at this thread already @Brandon_Carlton?

Also, @BrunoSupremo also mentioned a thing or two regarding VoxelShop .dae exports, when animating in Blender.


#232

@Stmpnk i read through as much of this thread as possible considering its 229 posts long. However being that voxelshop has had many updates since the majority of @BrunoSupremo 's posts, an updated answer to my problem may be needed.


#233

Hi, I believe your problems are the following.
First for the export settings for qb, the “recommended” setting are wrong. You should use only the “origin at zero” and the “right hand”.
To export for dae, you first need to flip the object… Make it face the opposite way. (not just rotate 180, flip it)

You can also try this software: A new free alternative to Qubicle
It is the closest to qubicle you can get when exporting, and it can export to .obj! (though I didn’t tested it yet to know if needs any trick like the voxelshop flipping)


#234

@BrunoSupremo I just tested its .obj export (Goxel’s) and when I do, it merges all the layers into one :confused:. Not sure if there’s an option I haven’t found yet.

EDIT: Might want to discuss this in a separate thread.


#235

Uhm, you are right… The obj is a single matrix, and it is rotated, like the hearthling was laying in his back.


#236

Hello! I’d be very happy to look into this over the weekend! Could you please provide: skeleton to import into blender, voxel file you are trying to export, Dea you are exporting and correct obj file (from qubicle?) and some Screenshots of what you are getting vs what you are expecting?

The problem is that model export is really complicated (it’s many thousand lines) and I have done a major rework at some point. Also stonehearth import might have changed since I initially put the recommendations for export.

There is a reason that voxelshop export is still superior to everything else out there quality wise. Even to qubicle. I spent month implementing export to dae (if you want to see the details I have some Blog posts up). I have plans to separat it out as a Web conversion tool at some point, but will have to find time for that.

Anyways, looking forward to your information here.


#237

Problem Files.zip (522.4 KB)

@blackflux I’ve supplied as much information as i can. I had to move the original body.qb and head.qb model in Qubicle to get it to export correctly. But thats minor compared to how Voxelshop is handling it.

Just to clarify i’m not trying to butcher Voxelshop. I understand it takes a lot of work to get things working and where they are today, and that things change and settings need to be retweaked. Im not slandering your program. I hugely prefer it to Qubicle.


#238

@Brandon_Carlton Thank you very much for the detailed information!

The problem is actual the import, not the export: Stonehearth uses a fixed size box that is zero indexed in one corner and all voxel coordinates are positive. The knowledge of how big this box is, is not encoded in the qb file. Hence on import the voxels all moved away form the center (since VoxelShop can not possible know about the box size).

The proper fix would be to either have an “import form Stonehearth” option in Voxelshop, which currently I unfortunately don’t have the time to implement or (for now) manually center the object after import.

I’ve moved the body manually into the center: Just use the select tool and select everything with your mouse, then use arrow + page keys to center it — you’ll need to do this twice to get all voxels.

How does this work for you: body.zip (6.8 KB)


#239

Didn’t voxelshop had an inflate option at some point? Or at least a scale option?


#240

@BrunoSupremo Only in the export settings IIRC. Im not sure exactly how inflate would work. Scale by multiple of a voxel should be relatively easy to add.