VoxelShop (Voxel-Editor)


#203

Isn’t that the “Use bounding box as matrix” option in the export settings for qb?


#204

:thinking::thinking::thinking:
Sorry my limited knowledge, but can u explain this “workflow” that u want? :sweat_smile::sweat_smile:
I did a quickly search :thinking: So u want to know how the model works in stonehearth and how the model works in qubicle?


@Relyss U guys create models at (0,0,0) in Qubicle cuz is more easy to use that in programming, isn’t? :thinking: Correct me if i’m wrong. It’s been 1 year that i’m not seeing the json files of stonehearth, so i forgot some things.



#205

Well, I’ll try to explain my point of view. If someone knows more than me, please feel free to add some points or correct me.
What I’ll explain is based on logic in what I saw, cuz I don’t have Qubicle, so i’m basing on images and videos that I watched and idk how really the Vs works.:laughing:

What I unterstood is that the qubicle, for example, has a “work table” like Vs (but they have some differences and I’ll explain later) and it has a “layer box” which can move the entire layer and show the layer position relative to the “work table”.


(Got in the forum, isn’t mine)
This image can show somewhat how it works.
We have the layer size and its relative position with the “work table” (i’m using “work table” cuz idk how it’s called :sweat_smile:). So, normally when I saw some tutorials using qubicle, they’re using the position (0,0,0) to create that layer and go on with the project.

When u import a model to Vs, it stays relative to the origin, but in a strange way :thinking:


(It’s mine)
For example in this image. The wolf was modeled at (0,0,0) and when u import to Vs it stays on that supposed “origin”, cuz the black point is the origin to the coordinates of voxels. (I have drawn that color lines to show what I understood how the origin is showed). Seeing this, however, u can see the black circle shows that maybe the supposed “work table” origin.

Do u get it? :grin:
I think yet it’s possible to work without those things, but the work will be hard, in my opinion. So my suggest is to create a way to see the layer position (not just all the content but the layer too) relative to the work table. Idk if this is a hard work to do :thinking: What do u think?

I also have others suggestions :thinking:. So if u want to know I post here.


#206

What you are calling 0,0 is not 0,0 The yellow box is not centered in Qubicle, that is why when you open in VoxelShop it is shifted to a corner.

Only the corner of the yellow box is at the 0,0.

You can have your model in any place. It does not matter, unless you are going to animate it using an existing animation. Then you need to have the object in the same place as the others that use that animation.


#207

But when exporting to qb from Voxelshop, if the model is not inside the bounding box it will be cut, right?
You still have to move it inside the bounding box before exporting it.


#208

Hmm, if I’m understanding you correctly, and I may or may not be, this is in fact incorrect:

This is what an in-game usable costume looks like just before I export it to .qb out of VoxelShop. Only the toe is touching the bounding box, and only a couple of voxels.


#209

If you activate the option to have the bounding box, than your model must fit inside that grid (and the grid should have the right size), else it should be positioned shifted at a corner.


#210

That’s it!
If u see the second imagem u can see I drawn that color line to compare. If u import, it will remain in the same place as in qubicle. The case is to have a way to see the position of one layer relative to the bounding box origin. This, in my opinion will make the way to model much easier.


#211

But you only need to care about that if your models is going to use one animation from the game. If you are doing your own animation or not using any at all, it does not matter where your model is.

If you really want to have the model positioned like in Qubicle, you can simple center it in Voxelshop, activate the bounding box and uncheck the “set origin to zero”. When you export like that, the model will be shifted to the corner as usual.
Keep in mind, it is not Voxelshop that is strange here, it is working fine. The strange here is the stonehearth models that are purposely shifted to the corner. (I don’t know why they chose to do that, isn’t easier to have everything centered?)


#212

I see :thinking::thinking:

I totally agree. I meant the way that the models are imported are strange.


I have a question. Is there a way to select all the layers and move them without leaving any voxel left behind. Cuz when I select all voxels, some layers share the same piece and when I select all, the layer below isn’t full selected.


#213

Try using the select tool and click and drag around the object, it should select voxels from all layers.


#214

I think one of the reasons why the models are in a corner is because it’s the way Qubicle works.
So when working with multiple matrices with the same size, it was super convenient to just cut / paste them and they would get aligned at the origin without you having to align them by hand.

I mean when spliting the model into several matrices for animation. Working inside the same matrix is pretty common in Qubicle too, instead of having to jump from one matrix to another (at least it was, in Qubicle 1). Then you copy pasted the model several times, separated the matrices to check that you’re deleting the right voxels, started isolating the different parts, renamed them, and finally selected all the matrices, ctrl+X, ctrl+V, and voila, ready to export.


#215

Doesn’t work :confused:
I have a head and a jaw. Some pieces of jaw are inside the head. When I select all with the select tool, the pieces of the jaw are left behind.


#216

Uhm, true, I tested it here and the same thing happened.


#217

You should be able to hide the layers, except for the one you want to move, select all, move. Then repeat for all layers. Maybe this is a function that should be added.


#218

ok so just downloaded this (im skint) :stuck_out_tongue: thank you @blackflux

i am wondering… is there anywhere where this is explained to use for DUMMIES? @Wouter_Sikkema is helping me with code but nothing to him is known about the use of VS and i know nothing about voxel art


#219

There are definitely some general tutorials on voxel art and on how to use VoxelShop (just google). If you’re looking for specifics on how to export and use models in stonehearth, this very thread has some information above ^ and if you have specific questions feel free to ask them here!


#220

my only issue currently (after looking online, i should have posted i foun d your faq - sorry) is that for some reason… every time i export as .qb the file is always blank (my modder friend who use Qb as their prog cannot read it - as neither can i import it back again - it jkust shows nothing there at all … even though its loaded… )

i guess this is part of the box issue? or is it different?

Also just tried the work around (uncheck all apart from right-hand etc) and still exporting/importing as blank (using windows 10 64 home if that helps)


#221

Had this problem, it depends on when you hit export, if you are still working on it (and can see the blocks) it will export that part. In the case of multi part models (armour!) , being outside of see all the blocks view works best, but make sure you select all the bodyparts before you hit export

But this is in qubicle


#222

Bug and suggestion:
There is a few conflicting shortcuts like ctrl+shift+a is for both moving the camera and selecting all voxels. Pressing it will only move the camera.
Using the button to select all voxels will only select visible voxels, those that are intersecting with another layer will not be selected. Hiding layers and moving them one by one is not only tiring when you have 30 or so layers, but also very hard as with everything hidden you lose the reference and don’t know how much you need to move.