Very Weird Issue

I noticed the shades of two of the colours I added to Stone weren’t what I expected/wanted, so I closed out of Stonehearth, changed them, reloaded the game.

Go back into the builder to check the change, it won’t let me select Stone foundations; I click on Stone, it jumps back to Wood. The other tabs are all fine.

Revert the change to my file, reload, everything fine.
I only changed hex codes; I triple checked this, even ran a few tests changing them to other codes such as FFFFFF or 000000. Can’t access stone foundation; revert, there it is again.

I don’t get it. Anyone have some insight?
I can post the code and/or my files if it might help.
I’m just baffled; suspect this might be why my Terra Cotta stopped working, it’s similar behavior to what it exhibited before I got frustrated and moved that to the back burner.

Maybe some small json error that snowballed into this? Check your file at

Yep, first thing I did out of reflex. Valid json.

If the only change was the hex, my only assumption (which should not matter, but who knows) is that the color is repeated somewhere else.

I’ll try messing around with that, but I’m fairly certain it shouldn’t matter, as I know the Terrain colours repeat within the Packed Dirt palette without issue - though, that is within the same palette, so theoretically could make a different for some oddball reason.

…possessive editor is possessive, it seems. Changed all the repeat codes by tiny amounts (1-3 points in one of the HSLA values), and…now I can tweak the colours without incident.

I don’t understand. Whatever! Thanks, @BrunoSupremo

INCREDIBLY possessive; my Terra Cotta works now, after deleting the lines that were based off the clay brick colours (despite being different saturations).

So, best guess, it wants very distinct names and hex codes when on different palettes. Repeats are fine if within the same resource palette.

…though I’m sure this will all be out the window with the new building manager when it’s rolled out anyways :cat:

Nevermind. Everything unique, name and hexes, and it just did it again. -.-

Logs? Else, you can send us the mod to check.

If I can find another copy of it; about 4-5 hours ago, I had a huge issue with my computer and have seemingly lost a lot of stuff from dealing with that, some of which was apparently not backed up on my portable hard drive. My last mod updates among them.

At my best guess right now, might just be that I changed file locations at some point, or I’ve lost some shortcut to where I kept things. If I resolve that, will post it, as another set of eyes would definitely be wonderful. If not…well, in the meantime, I’ve updated to the unstable build and have been working on a new build of the mod from scratch.

I am an exceptional noob. Here you are: Dropbox -

Remove the unused alias in the manifest, to stop calling files that does not exist.
Error at the overrides: "crab_rotten.json.json"
You can also simplify those overrides, changing them to simple mixinto where you just apply the rotten material tag to items. Not needed, but it is a better way to do it, cause if for example one of them changes, they would be override by your rotten versions, which would be different and outdated. You would need to update your files whenever those targets were update.

At the mining loot, you have repeated entries, two dirt_piles, change one of them to clay_mound

At resource constants, the stack value is how many voxels a hearthling can build using a single item of that material. 60 means he will build 60 blocks using up a single log for example. So you maybe want to change that 100000.
Also the rotten alias there is wrong, replace for “stonehearth:food:rotten:basket”

You are missing the rotten item in the building brushes.
You also have conflicting resources. Like “packed dirt resource” and “dirt resource” will target the same thing. This works by searching items that have those tags, so the “dirt resource” matches all items that have those two tags, including those that also have the packed tag. You will need to change those to avoid this, maybe change “packed dirt” to “packed_dirt” and the same for stone.
Remove all the wood, stone, clay colors that are already in the base game. Make your file only have new colors not in the stonehearth mod.
You have a “#b” color.
You have a "#FFFF92 " color. (a space at the end)

In your adobe item, it has the tags "“stockpile_clay adobe resource clay resource”, remove the clay (so clay will not target this) and the repeated resource

  • …rather ashamed I repeatedly missed a json.json typo
  • Ah, I’ll change it to that; I wasn’t sure if it would work that way
  • One of those was meant to be clay mound, don’t know when that mistake was made (as I know it was originally clay and dirt…)
  • Oh, good to know; the 60 was from just copied from the original wood resource
  • Woops, must’ve copied that wrong, thank you
  • Rotten was for use with composting, not the building directly
  • Good to know, wasn’t sure how the naming convention worked, will change to packed_dirt and such
  • Was originally using it to change the order of existing ones, but will remove so it can’t contribute towards conflicts
  • #b and the space at the end, I definitely missed, and those might be the main issue that the foundations were having… >.<
  • Originally did that on purpose, so that adobe could still be used in recipes that use clay, but if it’s an issue, I’ll change that one as well.

Oh, that is ok then. But you would run into issues like a hearthling grabbing adobe to craft more adobe.

Did that all fixed it for you?

I didn’t even think of adobe cycling, drats >.<
I’ll just add another recipe, to turn the crafted resources back into the source ones.

Working on it now to test, was in the middle of breakfast when reading/responding :slight_smile:

Stone foundations work again! With A23 unstable, no less!

…Adobe isn’t working still, on any tab, but I’ll look through that in a minute.

This is awesome, though, having it working again, and on the unstable build!
I have to test everything I added, naturally, but if nothing else, the expanded colors work! :smiley:
Thanks, @BrunoSupremo!

For me, I was not able to select it. It would just jump back to common clay (or wood, can’t remember). That was because the first color (the one that is selected by default when you first open that material tab) was the same from the other material, so the game tried to select the original color from there. Removing all those repeated make it selectable again.

Clay bricks, same thing it does for me. Very odd; while I did forget to change the name initially, I fixed that before the version I sent you, and the hex codes have been different, since they’re less saturated shades. Well, on to the of fixing the repetition anyways, maybe that’ll correct it. I’ll post an update either way.

Ah, that is what it was; my saturated changed colors didn’t save. Fixing that…

Success! Now I just need to fix the broken icons, check that the recipes still work, and it should be good to roll out!



Hey, @BrunoSupremo, can I bother you with one more thing?

So, I updated the resources like so,

…but the building brushes will only accept them without the line (ie packed dirt instead of packed_dirt). Any time I put the line it, they stop working in the building editor.

Any idea where I might be going wrong?
I can re-upload my current build if need be