Update to A20 not working for me

Hi there Hearthlings,

New to the forums and enjoying StoneHearth since A19.

I was about to try out the new build a few minutes ago, with unexpected results.
It’s already giving me an error on the main menu (which also has the same background image saying “alpha19” on it, but that’s probably not yet updated?). It says 0.20 in the bottom-left, so I suppose it did work, in a way.
When I try to load up a save, the game is stuck on pause and there’s no -visible- GUI. I can orbit the camera and select objects, but not much else.
So I thought, okay, save files become corrupted upon updating the game maybe? However, starting a new game works untill you place down your town banner, it won’t let you.

If necessary I could post screens or something.

Hey there @Nex, sounds like something went wonky with the update :glum:.

The first thing I would suggest trying is a full uninstall/reinstall of the game.

  1. Launch Steam.
  2. Right-click Stonehearth and click Properties
  3. Click on the Local Files tab
  4. Click Browse Local Files...
  5. If you have saved games or templates to save, complete the following. Otherwise, skip to step 6 below.
  • For saved games, copy saved_games to another location, like your Desktop.
  • For templates, copy saved_objects to another locaiton, like your Desktop.
  1. Go up one directory level to the common folder.
  2. Delete the Stonehearth folder.
  3. Close Windows Explorer and return to Steam.
  4. Right-click Stonehearth and click Uninstall...
  5. Once removed, right-click Stonehearth again and click Install Game...
  6. If you backed up saves or templates in step 5 above, do the following. Otherwise, skip to step 12.
  7. Right-click Stonehearth and click Properties
  8. Click on the Local Files tab
  9. Click Browse Local Files...
  10. Copy the backed up folders into Stonehearth folder.
  11. Close Windows Explorer.
  12. Launch Stonehearth
  13. Finally…
  • If this works, great! Please let us know so we can mark this as resolved.
  • If not, please upload your stonehearth.log from the game install directory (follow steps 2-4 if unsure how to access) to the Discourse so we can take a look.
1 Like

Thanks for your quick reply @jomaxro

While waiting I already tried doing a full re-install and that worked perfectly fine, so.
Thanks for your help anyways.

This one can be closed. :slight_smile:

1 Like

Perfect :jubilant:! Always happy when it’s the easy fix.